6 Replies Latest reply: Apr 20, 2013 10:19 PM by Waltherp99
Waltherp99 Level 1 (0 points)

For weeks now I have trouble closing iPhoto, either manually or as a result of a Restart. Any ideas other than deleting the iPhoto database?

iMac (27-inch Late 2009), OS X Mountain Lion (10.8)
  • Paul_31 Level 6 (13,645 points)

    Have you tried the steps in this knowlege-base article?



    Also, if the application re-opens on restart it's probably because 'resume' is enabled. If you deslect the tick as shown in the image on shutdown/restart it should prevent iPhoto re-launching.


    Screen Shot 2013-04-20 at 12.35.09.jpg

  • Waltherp99 Level 1 (0 points)

    Thanks, but that's not it. If I want/need to restart I have to force stop iPhoto. Even when I uncheck Resume it takes typically up to an hour to restart, making me believe iPhoto damaged something on disk which needs e lengthy recovery by the OS

  • Paul_31 Level 6 (13,645 points)

    Have you checked your HD doesn't need repairs using the Recovery HD. Restart holding down Command-r, select Disk Utility, click on Macintosh HD and click 'repair disk'. If anything gets changed click on repair disk again until you get a clear pass and then restart as normal from the Apple menu.

  • Old Toad Level 10 (135,418 points)

    Two ways to get iPhoto to close:


    1 - Force quit:



    2 - open the Terminal application and enter the following:

    killall iPhoto

    The second method is preferred as it will close all files that were open whereas a force quit doesn't.



    Now if iPhoto hangs again launch iPhoto with the Option key held down and create a new, test library.  Import some photos and test to see if the same problem persists. It the new library does not hang your current library is the culprit and needs to be repaired.


    Apply the two fixes below in order as needed: 


    Fix #1


    Launch iPhoto with the Command+Option keys held down and rebuild the library.




    Since only one option can be run at a time start with Option #3, followed by #4 and then #1 as needed.


    Fix #2


    Using iPhoto Library Manager  to Rebuild Your iPhoto Library


    1 - download iPhoto Library Manager and launch.


    2 - click on the Add Library button, navigate to your Home/Pictures folder and select your iPhoto Library folder.


    3 - Now that the library is listed in the left hand pane of iPLM, click on your library and go to the File ➙ Rebuild Library menu option.


    4 - In the next  window name the new library and select the location you want it to be placed.


    5 - Click on the Create button.


    Note: This creates a new library based on the LIbraryData.xml file in the library and will recover Events, Albums, keywords, titles and comments.  However, books, calendars, cards and slideshows will be lost. The original library will be left untouched for further attempts at fixing the problem or in case the rebuilt library is not satisfactory.





  • Linc Davis Level 10 (192,599 points)

    Please read this whole message before doing anything.

    This procedure is a diagnostic test. It’s unlikely to solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.

    The purpose of the test is to determine whether the problem is caused by third-party software that loads automatically at startup or login, or by a peripheral device.


    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode and log in to the account with the problem.  Note: If FileVault is enabled, or if a firmware password is set, or if the boot volume is a software RAID, you can’t do this. Post for further instructions.
    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on certain Macs. The next normal boot may also be somewhat slow.

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.


    Test while in safe mode. Same problem?


    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of the test.

  • Waltherp99 Level 1 (0 points)

    Thanks to all for their help and suggestions. I think I solved the problem by recovering the HD. Thanks again.