Skip navigation

Cannot download podcasts in iTunes 11

1591 Views 12 Replies Latest reply: Apr 22, 2013 4:07 PM by jsulzmann82 RSS
jsulzmann82 Calculating status...
Currently Being Moderated
Mar 24, 2013 6:30 PM

I recently reinstalled Mac OS X on my Macbook, and now I can't download any podcasts in iTunes. Whenever I click on the "download" button next to an episode, nothing happens but an exclamation point immediately shows up to the left of the episode title. I assume this is some sort of error message but I cannot figure out how to get any more details about what is going wrong. I can double-click on the same episode and listen to it streaming without any problems. At first I thought this might be some sort of permissions issue with the folder where I save my podcasts since I've had a few of those issues with files I backed up before the reinstall, but I ran "Repair Disk Permissions" and also manually went into the "Podcasts" folder and changed all of the permissions to "Read & Write" and I'm still having the same problem. I also tried upgrading from 11.0.1 to 11.0.2 and no luck. Does anyone have any idea what might be causing this or how I can get more information on the error?




MacBook (13-inch Aluminum Late 2008), OS X Mountain Lion (10.8.3)
  • Roger Wilmut1 Level 9 Level 9 (64,095 points)
    Currently Being Moderated
    Mar 29, 2013 3:02 PM (in response to jsulzmann82)

    If you click on the !-in-a-circle you will get a message telling you what the problem is (though it may be a bit unspecific). When you say you can stream an episode do you mean you can play it in the iTunes Store page but cannot get it when subscribing (since there is no streaming when subscribing).

  • Roger Wilmut1 Level 9 Level 9 (64,095 points)
    Currently Being Moderated
    Mar 29, 2013 3:15 PM (in response to jsulzmann82)

    Double-clicking does download the episode, playing it as it does so (you should see the progress in a little circle to the left of the title): I don't know why the download button doesn't work - it certainly should do so. You can get round this by double clicking the episode and then hitting the space bar to pause it - it will go on downloading and be available to play when required.

  • Roger Wilmut1 Level 9 Level 9 (64,095 points)
    Currently Being Moderated
    Mar 29, 2013 4:00 PM (in response to jsulzmann82)

    I'll correct what I said before - I was misled when I checked into this. Double-clicking does stream and not place the file in the library (I don't know what happens when you've played it all but probably it just disappears). On the other hand I had no difficulty downloading an episode, and when first subscribing the top episode downloaded automatically. You say this happens with all your podcasts, in which case it can't be a peculiarity with the actual podcast; and your Permissions have nothing to do with it, they apply to files actually on your hard disk.


    My guess would be that something has become corrupted, most likely the Preferences. Try quitting iTunes and going to (user)/Library/Preferences and removing to a folder somewhere else all files beginning with (there may be quite a lot of them). Then try it all again. You could test it by going to my iTunes Store page:



    and subscribing from that, as I know that works. If it now works for you, then just trash the prefs files - obviously you will have to reset any settings.


    (Apple have hidden the user’s Library folder in Lion and Mountain Lion to casual viewers, in an attempt to stop new Mac users messing their machines up. To access it, in the Finder go to the ‘Go’ menu and hold down the Option (Alt) key; the Library folder will appear as a choice.)

  • Roger Wilmut1 Level 9 Level 9 (64,095 points)
    Currently Being Moderated
    Mar 30, 2013 12:42 AM (in response to jsulzmann82)

    I'm afraid I'm out of ideas - it's not a situation I've come across before, and I can see no logical explanation for it.

  • DukeToma Calculating status...
    Currently Being Moderated
    Apr 16, 2013 7:01 AM (in response to jsulzmann82)

    I'm having the same problem.  It just started happening this week for some reason.  I've tried deleting all apple folders under my user folders and everything.  It's so weird.  I can't download podcasts and I can't download my audible books either.  Itunes is officially totally broken right now.

  • theroguemusiclab Calculating status...
    Currently Being Moderated
    Apr 19, 2013 2:30 PM (in response to jsulzmann82)

    The issue is the permissions of the iTunes library file. Run Disk Utility and repair permissions on your system drive. If that doesn't work, you need to start up from the Recovery Partition. Hold down the alt/option key during start up and select the Recovery Drive from the choices that will appear. Then run its Disk Utility and repair permissions on your system drive. This corrected the problem on both of my systems.

  • DukeToma Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 22, 2013 9:09 AM (in response to theroguemusiclab)

    It was a permissions issue.  I'm on Windows 8.  I had to change the permissions on the folder where my music was stored.  Specifically I believe it was the ".iTunes Preferences.plist" file that was causing the problems.  Not sure how the permissions got messed up on that folder, but once I gave myself full permissions on that folder and all sub folders I was able to download pocasts and audible books again.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.