1 2 Previous Next 25 Replies Latest reply: Apr 22, 2013 3:22 PM by LucasPellizon Go to original post
  • 15. Re: Wrong Netflix Audio Language
    Ninja Taka Level 1 Level 1 (0 points)

    Mine is doing the same thing.  I'm trying to watch Joseph animated movie. It plays in english on my iphone, but spanish on my appletv. Can't change language on there, only subtitles. 

  • 16. Re: Wrong Netflix Audio Language
    arnefromca Level 1 Level 1 (0 points)

    I am having the same problem. I have the 3rd generation of Apple TV and am trying to watch "Transformers: Dark of the Moon". On my computer and iPhone it plays in English but on my Apple TV it will only play in French. I have restarted, reset and begged my Apple TV but it will not play it in English. I have also called Netflix and made sure that my account is set to English. The strange thing is that I bought a 2nd Apply TV unit for another room a month later than my first unit and it plays the same movie in English. Also strange is that I had this same issue with "Thor" a while back on my first unit. I finally gave up trying to watch it. After it disappeared from the recently watched section of the menu on my Apple TV a few weeks later, I went back to try and watch it again and then it played in English. I am sure this is a software issue for the Apple TV unit as it only happens on Apple TV. It does not happen on my computer or iPhone. I am new to Apple products and what troubles me is that this seemed to have been an issue last year with the 2nd generation of Apple TV as I found it discussed in the forums back then. That makes me wonder if Apple doesn't always resolve issues such as these with their products. I hope this isn't the case.

  • 17. Re: Wrong Netflix Audio Language
    X1Zero Level 1 Level 1 (10 points)

    Yep. This is happening now with Iron Man 2. On Apple TV (third generation) it plays in French but on iPhone/iPad/PC/Mac, it plays in English.

  • 18. Re: Wrong Netflix Audio Language
    ainigmati Level 1 Level 1 (0 points)

    I have had the same problem and was told two different things by Netflix.

     

    1. The first time it was with 'Transformers: Dark of the Moon' about 6-7 weeks ago. On any device it could play in English, but if the device was set for the Best Quality and was providing Dolby/surround audio it would be in French. This was my problem with the Apple TV (2 Gen). Netflix Canada told me the reason was that the surround audio license was only purchased for French. If I watched the movie on another device that did not support surround sound or watched it on my Apple TV at a lower quality, then it would be in English. This worked, but I wanted HD and Dolby.

     

    2. The next time was this week with Thor and Iron Man 2, both of which I had watched previously via my Apple TV on the Best quality and with Dolby...in English. Suddenly they were both in French. This time Netflix Canada was quick to lay the blame on Apple, say thing Apple had been trying to fix some issues and the result was that they broke several movies on Netflix. This does not seem to make sense, but this was repeated several time. Netflix Canada (via their support line) insisted that Apple is to blame and that until Apple fixes these movies (whatever that means, considering Netflix is streaming the content) they will only be available in French. This is very odd. Both that it doesn't seem to make a lot of sense and that Netflix seemed to basically have thrown in the towel.

     

    So, I don't know what the real problem is, but if this persists it does seem to make Netflix a tad useless on the Apple TV, unless you are francophone or extremely biligual.

     

    Here's hoping that this problem gets addressed, soon. Although, I guess this is another reason to start working on my language skills. For the moment, you've got to either reduce the quality of the video/audio on the Apple TV or choose another device. No other fix I've read about here or elsewhere has worked for me.

  • 19. Re: Wrong Netflix Audio Language
    psyfrog Level 1 Level 1 (5 points)

    Incidently I am having the same problem on my new Mac mini while trying to watch Thor.  It only plays in French and there is no language option for the film.

  • 20. Re: Wrong Netflix Audio Language
    54m Level 1 Level 1 (0 points)

    It appears to me that some movies in some countries only have some languages at some qualities (ie: Star Trek: Nemesis at the highest quality in Canada has a French language track, but not an English language track). If you hold the Select button you get to a language choice dialog, but only French is available. My guess is that when the AppleTV tries to play Star Trek: Nemesis at the highest quality it can't find the English track so it plays the French track instead.

     

    If you go into the quality preferences on Netflix.ca and you can turn the quality setting from "Best" to "Better" more language options become available. Every movie I've tried that has only French at "Best" quality has both English and French at "Better" quality.

     

    Hopefully either Apple or Netflix fix this in the future.

  • 21. Re: Wrong Netflix Audio Language
    Rieth Level 1 Level 1 (0 points)

    Hi guys,

    I was having the same issue you guys have and going nuts trying to fix it. Finally I found a very simple way.

    Just go to AppleTv audio and video options and change the "Dolby Surround" option from "auto" to "off".

     

    Then, when you start playing your movie, simple press and hold the central button until it shows you all the subtitles and audio options. That's it!

  • 22. Re: Wrong Netflix Audio Language
    Rieth Level 1 Level 1 (0 points)

    Hi guys,

    I was having the same issue you guys have and going nuts trying to fix it. Finally I found a very simple way.

    Just go to AppleTv audio and video options and change the "Dolby Surround" option from "auto" to "off".

     

    Then, when you start playing your movie, simple press and hold the central button until it shows you all the subtitles and audio options. That's it!

  • 23. Re: Wrong Netflix Audio Language
    superdifficult Level 1 Level 1 (0 points)

    I have set my Audio Language setting to English, I have set the device laguage to English. I have rebooted. I have clicked and held the centre button. I have changes my audio preferences on the Netflix website. I have done all of these things and still I do not get to choose audio languages and I do not get movies in English. *** apple.

  • 24. Re: Wrong Netflix Audio Language
    superdifficult Level 1 Level 1 (0 points)

    I did however just turn off Doldy Audio and BAM! English audio suddenly. Perhaps, Apple, this can be a clue as to what;s going on for SO MANY PEOPLE!

  • 25. Re: Wrong Netflix Audio Language
    LucasPellizon Level 1 Level 1 (0 points)

    Might be the answer:

     

    http://youtu.be/tO6SwavcK9Q

1 2 Previous Next