Skip navigation

Upgrading iphoto 09->11 but 'modifieds' don't appear

2300 Views 10 Replies Latest reply: Apr 25, 2013 11:25 AM by Old Toad RSS
bderms Calculating status...
Currently Being Moderated
Apr 23, 2013 8:45 AM

Hey everybody. I've been trying to upgrade my iphoto 09 (8.1.2) to iphoto 11 (9.4.3). I've come into the same problem as many with upgrading the iphoto library (iphoto 11 just crashes upon trying to upgrade). In reading the forums, I decided to try iphoto library manager to rebuild my iphoto 8.1.2 library into a 9.4.3. It worked great, keeping just about everything intact except that I noticed that iphoto 9.4.3 wouldn't show any of the edited versions of the images I had in iphoto 09. In other words, it's as if the connection to the modified versions of the photos were completely lost. I feel like I'm just going to be stuck in iphoto 09 for eternity unless I can figure out a workaround, as I have too many edited photos to just go and edit them all over again. Please help!

iPhoto '11, OS X Mountain Lion (10.8.3)
  • léonie Level 8 Level 8 (46,380 points)
    Currently Being Moderated
    Apr 23, 2013 8:53 AM (in response to bderms)

    Have you tried to rebuild your iPhoto 8.1.2 library using the library first aid tools in  iPhoto 8.1.2? Do you still have iPhoto 8.1.2 running on your system or can you restore it from your backup? Rebuilding with iPhoto's First aid Tools will preserve all edits and products.


    See:  iPhoto 6 and later: Rebuilding the iPhoto library


    And only after the library has been rebuild, then to upgrade to iPhoto '11?

    It is safer to do the update with a library that is in working condition.


    Before you try to rebuild, make sure you have a backup of the library.




  • LarryHN Level 9 Level 9 (54,865 points)
    Currently Being Moderated
    Apr 23, 2013 8:52 AM (in response to bderms)

    Since we do not know exactly what you did and how you did it there is no way to tell what went wrong - do you still have a working iPhoto '09 with its library? If so try Back up your iPhoto '09 library, Depress and hold the option (alt) and command keys and launch iPhoto '09 - rebuild your iPhoto '09  library  - test it and tehn do the upgrade to iPhoto '11



  • LarryHN Level 9 Level 9 (54,865 points)
    Currently Being Moderated
    Apr 23, 2013 9:33 AM (in response to LarryHN)

    Another thing to try - use IPLM to rebuild the iPhoto '09 library - check it with iPhoto '09 and if it is ok then upgrade to iphoto '11


    And please post what you have tried - this is really slow to make suggestions only to have you come back with "I already tried that" - knowing what has been tried will save all of us a lot of time



  • LarryHN Level 9 Level 9 (54,865 points)
    Currently Being Moderated
    Apr 23, 2013 8:19 PM (in response to bderms)
    When I look at the new library in iphoto 11 that I created under the iPLM explorer, all the edits/modified versions appear there but not in the actual iphoto 11.


    I'm not understanding this comment


    Are you saying that they appear in IPLM but not in iPhoto? If so it may make sense to contact IPLM support and see what they can add to this discussion



  • Old Toad Level 10 Level 10 (113,125 points)
    Currently Being Moderated
    Apr 25, 2013 11:25 AM (in response to bderms)

    You can have more than one version of iPhoto on your Mac, each with it's own library but to switch versions one must always launch iPhoto with the Option key held down and select the correct version of library for that app.  I have 5 versions on my Mac each with it's own library:





More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.