Skip navigation

iCal keeps prompting me for password

11485 Views 36 Replies Latest reply: Apr 23, 2013 4:53 PM by gregfromLA RSS
  • ibid Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 16, 2012 6:49 AM (in response to edlsoccer)

    As I mentioned in an earlier post, I am having this same problem with iCal except my calendar server is a Zimbra server, not Google. Because this is a work calendar, I reported the behavior to our IT group and they told me that the Zimbra server does not do any authentication -- it relies entirely on our AD (Active Directory) infrastructure. To test this, they asked me to try to log in to an internal password protected website when the iCal problem started occurring again. They were right -- when iCal started rejecting my password I was also unable to log in to the website with my credentials. So -- at least in my case -- this appears to be more of an AD problem than an iCal or calendar server problem. (Depending on how Google's calendar server authenticates, the root cause could be the same there as well.)

     

    I noticed that people testing the upcoming Mountain Lion patch release have been asked to focus on Active Directory, which leaves me hopeful that Apple understands the problem and has fixed it.

  • Vic van Dijk Level 1 Level 1 (10 points)
    Currently Being Moderated
    Aug 17, 2012 12:01 AM (in response to ibid)

    I noticed in the mean time that the problem can stop occuring after a wake from sleep. Furthermore, I have the problem most likely occuring in the morning, when I moved my MacBook from home to university. Perhaps it gets confused by the university's (Active Directory?) network stuff and needs a sort of reset (which sleeping apparantly can provide).

  • JerryQuerry Calculating status...
    Currently Being Moderated
    Aug 17, 2012 8:59 AM (in response to edlsoccer)

    I had this error too.

    I did following:

     

    1.) I have deleted in iCal and in Systemsettings the accounts of GOOGLE

     

    2.) I exited iCal and Systemsettings

     

    3.) I started SCHLÜSSELBUND and searched for "GOOGLE" or "GOO" and "DAV" or "CALDAV" and "GMAIL" and deleted ALL KEYS connected with.

     

    4.) I started Safari and GOOGLE-Account (with STAY-SIGNED IN = NO) and I then changed SIGNIN-PASSWORD in GOOGLE - not the same PASSWORD AS BEFORE

     

    5.) I exited GOOGLE AND SAFARI

     

    6.) In Systemsettings I have made a new GOOGLE ACCOUNT under "Email, Contacts ..."

     

    7.) In iCAL-settings I have then made a new GOOGLE ACCOUNT and entered the NEW PASSWORD

     

    8.)

    IMPORTANT:

    in GOOGLE I too have SUBSTITUTES. And after building a new ACCOUNT in iCAL

    VERY IMPORTANT:

    I did NOT ACTIVATE SUBSTITUTES but only my GOOGLE MAIL ADDRESS!!

     

    9.) GOOGLE SUBSTITUTES I have UPDATED in iCAL on NEXT working day! I did let GOOGLE SERVER time to update all calendar substitutes.

     

    10.) IMPORTANT: I did set UPDATING iCAL to EVERY 15 MINUTES - This because in Windows and LIVE-Mail I got errors on updating emails every 1 MINUTE - error said this is too fast to be updated and server could not be reached so shortly.

     

    ###############

     

    That's it! It my help You too. Try it.

     

    Yours, Gerhard

     

    System:

    OS X Version 10.8

    iCAL Version 6.0 (1639)

  • alex349 Level 3 Level 3 (635 points)
    Currently Being Moderated
    Aug 17, 2012 12:50 PM (in response to Vic van Dijk)

    It's too early to tell if the issue has gone away for me (I plan to report back sometime tomorrow or Sunday when I'm more certain, or as certain as I can be for the moment), but I think it has. Due to entirely unrelated issues I moved my wireless router from one floor to another for most of today (it is still on the first floor). When I turned the network back on after about 10 minutes or so of downtime (and my Mac woke from sleep after being asleep all night) I read this post and then opened Calendar. The password prompts haven't returned since I did that at around 11 am, and my Mac has gone through several sleep-wake cycles since then. With any luck I'm out of the woods, so to speak, on this issue and if it returns I'll first try restarting my router. The one thing this (hopefully more than temporary) reprieve from this issue has taught me is that my Mac itself is fine, but the issue may be in the wireless network (and caches there of some sort?) instead. Or Google just fixed something at the same time, but that is less likely.

  • alex349 Level 3 Level 3 (635 points)
    Currently Being Moderated
    Aug 17, 2012 7:34 PM (in response to emarmite)

    For the record, I got the following response from Apple regarding the bug report I filed:

    This is a follow up to Bug ID# 12092315. This bug has been closed as a Duplicate. The issue is being tracked under the original Bug ID# 8096824 which is also listed in the Related Problem section of your bug report. To check the status of the original bug report, please visit the Related Problem section of the Problem Detail view of your closed duplicate bug.

    So maybe this bug will get fixed in an ucoming update?

    MacBook Pro (13-inch Mid 2010), OS X Mountain Lion, 8 GB RAM Core 2 Duo
  • gregfromLA Calculating status...
    Currently Being Moderated
    Apr 23, 2013 4:53 PM (in response to edlsoccer)

    I had this exact problem while using 2-factor auth.  When I went to look at the application-specific passwords I'd generated, I noticed the one issued to the computer in question conked out at exactly the 1-year mark.  Issuing a new one solved it. 

     

    Fix: 

    • visit https://accounts.google.com/b/1/IssuedAuthSubTokens?hl=en
    • scroll down to Application-specific passwords
    • enter a name (e.g. iMac 2013) and hit the "generate password" button
    • copy password
    • go to settings/email & calendars and the account in question, click details, and replace the password there with the one you just copied.
1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.