1 2 Previous Next 19 Replies Latest reply: May 7, 2013 9:44 PM by KinoViel
KinoViel Level 1 Level 1 (0 points)

I have uploaded 48 hours ago my first (free) ibook with iTunesProducer and everything seems fine (no errors and a green checkmark at the end). However, nothing appears in iTunesConnect, neither a ticket nor a book. Also no result if I search the metadata in itunes Producer. Is this normal? Shouldn't there be some kind of receipt? I have tried to resend but no difference.

  • 1. Re: upload seems ok but then nothing happens
    evernoor Level 1 Level 1 (0 points)

    Hi,

     

    You might have the same problem than me.

     

    On Itunes Producer go to File -> Package History you will realize then that an import error has occured.

     

    In fact there is another validation on Aplle's server...

  • 2. Re: upload seems ok but then nothing happens
    KinoViel Level 1 Level 1 (0 points)

    Thanks evernoor,

     

    you are right, there is an import error listed. But how do I find out what's actually the problem?

  • 3. Re: upload seems ok but then nothing happens
    evernoor Level 1 Level 1 (0 points)

    First check the total amount of pixels inside each images used in your book (not the cover image in Itunes Producer) but all other images in "images" folder.

     

    Remove every spaces in your url or replace it with "%20" or "-".

     

    Don't put files that are not declared on your package.

     

    Then check everything mentionned in this post will help you a little: http://www.zdnet.com/blog/government/six-tips-for-getting-apples-ibooks-to-accep t-your-epub-file/9054

     

    And after doing all that you can start thinking of calling Apple, or call them before and try to get the exact source of your problem...

     

    Hope this will help, I'm actually discussing with them about my problem. They will get back to you very quickly.

     

    Here is their number: 1 877 206 2092

  • 4. Re: upload seems ok but then nothing happens
    KinoViel Level 1 Level 1 (0 points)

    I found three images with >2million pixels and have downsized those - no difference.

     

    I used iBooks Author for preperation of the book. Tried to eliminate possible unicode by marking everything and changing the font to "Helvetica". There have been some greek characters in "Symbol" font before (this is an engineering book so I do need some greek characters). Maybe this is stupid but I don't have a clue how to find and replace unicode in iBA and couldn't find anything else. - still the same error

     

    I am waiting for a reply from Apple for more than 10 days now. This is really frustrating! So thanks very much for your help evernoor!

  • 5. Re: upload seems ok but then nothing happens
    Tom Gewecke Level 9 Level 9 (71,730 points)

    KinoViel wrote:

     

    Tried to eliminate possible unicode ... I don't have a clue how to find and replace unicode in iBA

     

    That doesn't make sense, because what you submit to Apple is supposed to be in Unicode.   If you do have stuff that uses the old non-Unicode Symbol font, which maps Greek to Latin, you might want to get rid of that and replace it by Unicode Greek.

     

    Does the error message say anything?

  • 6. Re: upload seems ok but then nothing happens
    KinoViel Level 1 Level 1 (0 points)

    Well, Apple Support wrote to me "please make sure that your book doesn't contain any emoticons or unicode". Since there are no emoticons in the book I was looking for any "unusual" characters, thats why I tried the change. I found some hints (see also the link above by evernoor) about possible problems with unicode. However, I am not a programmer and not familiar with the exact meaning of this and it did not help anyway.

     

    Regarding the error message: there is none except the "Import Error" without further specifications...

  • 7. Re: upload seems ok but then nothing happens
    Tom Gewecke Level 9 Level 9 (71,730 points)

    KinoViel wrote:

     

    Well, Apple Support wrote to me "please make sure that your book doesn't contain any emoticons or unicode".

     

    It seems crazy for them to write that without some more detailed pointers.  As it says in the evernoor link "Tip #2: Make sure all your files are either UTF-8 or UTF-16 encoded. "  That is Unicode.  iBooks accepts books in almost all languages, which is only possible with Unicode, and the epub standard also requires Unicode. It is unfortunate if Apple Support is really so clueless on this subject.

     

    One place where Unicode might trip you up is in urls contained in the text, or in chapter titles if these become file names.  Have you used any Greek or other non-ascii characters in these perhaps?

     

    I'd be happy to have a look at your book if you have a place to upload it or if it is not too large to email.

  • 8. Re: upload seems ok but then nothing happens
    KinoViel Level 1 Level 1 (0 points)

    I am not aware of urls with special characters in my document (I think there are ony two or three in all).

     

    Yesturday I had a look inside the .itmsp package and noticed, that a lot of the picture files have underscores in the filename. Is this a problem and if so, is there a way of changing the filenames without having to delete and insert the file again?

     

    Tom, I would be happy to email the file or a link (13 MB): gf at mechanischeverfahren.de.

  • 9. Re: upload seems ok but then nothing happens
    KinoViel Level 1 Level 1 (0 points)

    Tom, thank you so much for looking into the files! Ihave since tried two more changes without success:

     

    - eliminated the german Umlaut "ä" from an URL de.wikipedia.org/wiki/Sättigungsdampfdruck (although just replacing with "ae" makes the link useless)

    - tried not to modify the book-titel suggested by iTunes Producer (funny that a different title from iBA ducument title field is displayed when opening Producer anyway)

     

    I am still waiting for a response from Apple Support Engineering Team...

  • 10. Re: upload seems ok but then nothing happens
    Tom Gewecke Level 9 Level 9 (71,730 points)

    KinoViel wrote:

     

    ( just replacing with "ae" makes the link useless)

     

     

    In a url you could replace ä by %C3%A4 (escaped UTF-8 bytes) to have it still work.  But as you note that one is not a problem for your book.

     

    I've gone through the files in your book and not seen any problems myself.  Hopefully a phone contact with the support folks can provide some info on what is wrong.  

  • 11. Re: upload seems ok but then nothing happens
    ElaineLevine Level 1 Level 1 (0 points)

    I was having this same issue (but with a novel not a scientific or engineering work). My .ePub file would appear to upload correctly, but it never showed up in my dashboard. Nor did I ever receive a ticket for it.

     

    I produced the .ePub file from a Scrivener Compile.

     

    After 3 weeks and going round and round with the help desk, I figured out that it was not liking the book cover that was embedded in the book. Since the book cover is provided in Producer as a separate upload file, I removed it from inside the .ePub. I was then able to upload my book successfully.

     

    Elaine

  • 12. Re: upload seems ok but then nothing happens
    KinoViel Level 1 Level 1 (0 points)

    I have tried a new cover picture but without success. I have exported the book from iBA and then assembled the files "manually" in iTunes Producer rather than directly importing from iBA.

     

    I have also tried to remove all images from the cover (plain text) and export it the usual way from iBA - still get the Import Error.

     

    I am still waiting for a reply from Apple Engineering. I called earlier this week but phone support wasn't able to help.

     

    Thanks Elaine

  • 13. Re: upload seems ok but then nothing happens
    ElaineLevine Level 1 Level 1 (0 points)

    It's so frustrating. The help desk tries to be helpful but they just don't give you the info you need to resolve the problem. I'm sure they're mobbed. Did you actually get them to provide you with the actual error messages? Mine were pretty cryptic but one of them mentioned an image. The only image I had in the book was the cover. Like I said, once I removed it from the Scrivener compile, it uploaded fine.

     

    Did you try putting your .epub file through a validator? That's helped me in past discover other errors. You can try this one at http://validator.idpf.org.

     

    Or, the next thing I was going to try (if I hadn't gotten it to work) was downloading the iBooks Author app, importing my book into that, then try publishing from that. That might work for you since you have special characters and a few internal images.

     

    Another option is to open it in Calibre (http://calibre-ebook.com). If it looks fine in Calibre, save it as a new file, then try uploading that.

     

    Another choice might be to get a 3rd party to handle the upload for you.

     

    I hope one of these options helps you. Good luck!

     

    Elaine

  • 14. Re: upload seems ok but then nothing happens
    KinoViel Level 1 Level 1 (0 points)

    Unfortunately the helpdesk wasn't able to send me anything at all. They just told me they were waiting for the engineering team to reply.

     

    I have written the book in iBooks Author (msorry if that wasn't clear from my posts). So I believe the only way to check the file is by transferring it to Apple with iTunes Producer.

     

    I thought about converting the file to ebook format but since there seems to be no easy way to do this and I would loose a lot of the formatting I dropped that idea..

1 2 Previous Next