Skip navigation

How do I disable Mail?

19451 Views 45 Replies Latest reply: May 30, 2013 6:42 PM by dmjaeger RSS
  • CMAC9999 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 5, 2013 2:54 PM (in response to TresRoque)

    Having same issues with Mail.  It's an absolutely painful experience and has messed up the use of all my business email accounts (3 which are gmail hosted, and my hotmail). Ever since linking my accounts to Mail, my gmail accounts linked to outlook on my PC have stopped working properly.

    I've tried diabling (ie removing and unchecking my email accounts in Mail) and still causing issues.

     

    <Edited by host>

  • dmjaeger Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 19, 2013 8:35 AM (in response to TresRoque)

    I also have a problem with Mail and would like to see it go away. I just upgraded to Mountain Lion. Whenever the notification center tells me about an appointment on my google calendar, mail pops up and wants me to configure it.

     

    I would love to just delete Mail. Can I do that or will I be in for a world of pain?

  • Glenn Leblanc Level 5 Level 5 (5,935 points)
    Currently Being Moderated
    Apr 19, 2013 8:43 AM (in response to dmjaeger)

    Just open Notification Center preferences, select Mail, and uncheck to show Mail in notification center. Then it won't bother you anymore.

  • dmjaeger Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 21, 2013 12:53 PM (in response to Glenn Leblanc)

    Doesn't work, Glenn. The icon for the mail application bounces up and down at the bottom of my screen whenever my notification center tells me about appointments that are coming up. Seems like the calendar and the mail integration with google are linked, and that i can't have one without hte other.


    What would happen if I just trashed Mail?

  • Glenn Leblanc Level 5 Level 5 (5,935 points)
    Currently Being Moderated
    Apr 21, 2013 1:02 PM (in response to dmjaeger)

    I won't say it will harm anything by trashing Mail, but I wouldn't do that. If you don't want to use the Mail application, open up Mail's preferences and delete all accounts you have installed in it. Then you should get nothing in Mail.

    Also delete the mail accounts in iCal preferences Accounts tab if you don't intergrate mail with iCal.

    Also check your settings in Google to make sure they are not sending out email notifications for alerts.

  • dmjaeger Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 21, 2013 2:45 PM (in response to Glenn Leblanc)

    Thanks, Glen. I'm one step ahead of you on the first recommendation and the second one will remove my Google calendar from the notification center, which I do not want to do.

     

    As for Google, I enjoy receiving email alerts in my gmail that remind me of what I have planned.

     

    I admit, the problem is not huge. The Mail icon keeps popping up and down when the notification center flashes alerts for google calendar items.

  • Glenn Leblanc Level 5 Level 5 (5,935 points)
    Currently Being Moderated
    Apr 21, 2013 2:58 PM (in response to dmjaeger)

    Well since you aren't using Mail to read messages, which application are you using? Have you opened Mail preferences under the General Tab and change the default email reader to the application you are using? That should direct alert messages to that account.

  • dmjaeger Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 21, 2013 6:31 PM (in response to Glenn Leblanc)

    I use gmail, and i only use it online. But if this problem is truly created by alert messages, then I can try to disable that feature in my gmail account and see if it goes away.

     

    I like seeing my google calendar through the notification center, via the sync between Calendar and G. Calendar, but i don't need Mail to be involved.

  • Glenn Leblanc Level 5 Level 5 (5,935 points)
    Currently Being Moderated
    Apr 21, 2013 8:28 PM (in response to dmjaeger)

    Drag the Mail icon off the dock. Then you shouldn't see the bouncing. You might check in System Preferences, the Mail, Contacts & Calendars icon. Click on the Google account and deselect Mail if it is selected.

     

    If you have no accounts in Mail, I can't understand why it would even be affected. If you deselected Mail in Notification Center, then alerts should not trigger anything in Mail to begin with.

    However since you set alerts in a Google Calendar to sync with iCal to send email alerts which show up in Notification Center, I will assume that the OS is looking for an application to send the alerts to. That is probably why you are getting the Mail app activation telling you to set up an account to recieve the email. If this is the case, I wouldn't know how to stop it. Trashing the Mail application may create further problems because the OS won't be able to find it.

    Maybe a different approach for you would be to set up the gmail account in Mail (set it up as IMAP). Once set up and working properly, quit the Mail application. That may solve you problem. Mail will have a valid account to recieve messages. You have to leave Mail activated though, but you can still deactivate the badges and sounds in Notification Center so it won't bother you. If you don't want to use the Mail application and it is set up properly as IMAP, you won't have to touch it anyway. It will stay synced with the webmail site.

     

    I don't know what else to suggest except start your own discussion with your specific problem. Someone else may have the answer for you.

     

    In addition: You posted in SL forum and you show you are using SL. I haven't used SL in years, but SL shouldn't even have Notification Center in it if I remember correctly. If you post a question, be sure to put it in the correct duscussion for either Lion or ML.

  • Lanny Level 5 Level 5 (4,165 points)
    Currently Being Moderated
    Apr 25, 2013 10:48 AM (in response to TresRoque)

    1st, in Mail's preferences, select Thunderbird for your default email:

    Screen Shot 2013-04-25 at 1.38.16 PM.jpg

    Delete any visible email accounts:

     

    Screen Shot 2013-04-25 at 1.47.01 PM.jpg

     

     

     

     

     

    2nd, in System Prefereces' Mail, Contacts......:

     

    delete the iCloud Mail account:

     

    Screen Shot 2013-04-25 at 1.45.17 PM.jpg

  • dmjaeger Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 25, 2013 11:34 AM (in response to TresRoque)

    It's your perogative, but I would request that you leave the thread open and unfollow it (if that's possible). I have found some of the suggestions educational, if not completely useful. All of these issues are related, even if they are not directly answering your own individual specific issue.

  • Glenn Leblanc Level 5 Level 5 (5,935 points)
    Currently Being Moderated
    Apr 25, 2013 11:38 AM (in response to TresRoque)

    Marking it solved will not close this discussion. Sorry your problem hasnt' been solved, but if you don't want to see the other posts, click the Actions on the right side of discussions to stop recieving email notifications on this topic.

     

    I still see people such as Lanny still posting to your specific problem.

  • dmjaeger Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 3, 2013 9:55 AM (in response to Glenn Leblanc)

    Thanks for this reply, Glen. I missed it originally, but I appreciate the extra thought.

     

    I think that the notification center engages mail by default. it appears that the calendar and the mail integrations cannot be configured separately. the one thing i never tried was to turn off notifications FROM my google calendar to email. I will try that soon.

     

    as for removing mail from the dock, i'll investigate, but i think that it only appeared on the dock because it wanted to be configured.

     

    If this persists I will create my own thread. That's a good recommendation too. Thanks for your help.


    David

  • Glenn Leblanc Level 5 Level 5 (5,935 points)
    Currently Being Moderated
    May 3, 2013 12:39 PM (in response to dmjaeger)

    Yes, notification center will engage mail by default since it is the default application built into the OS. You can change the default mail reader in Mail's preferences.

     

    From what you said, you aren't using any email readers at all. You are just using web based email. Notification Center needs an email application to read the email messages as far as I know. It doesn't work on it's own. It needs applications to work with. Since you don't have one set up for email, that's why it asks to open one. Therefore, if you want to use email alerts in Notification Center, you need to have one set up. It probably will need to be open. Other than that, you would need to turn off the email alerts altogether. If you don't sync google alerts with iCal, then you may be able to set google alerts just to send email messages which won't set off Notification Center. Or, turn off the email alerts, sync with iCal, and just use alerts without the email messages.

     

    Maybe someone else might know something I don't.

    Good Luck.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.