Skip navigation

iPhoto 11 fails to import videos recorded with iPhone

51995 Views 50 Replies Latest reply: Mar 30, 2014 10:11 AM by RockRoad RSS Branched to a new discussion.
  • Terence Devlin Level 10 Level 10 (121,860 points)

    Okay last try. I think you have a corrupted Library. If you have, and you fix it, those frustrations you speak about will be solved. If you have a corrupted Library and you don't fix it, then you risk dataloss. That's why that question is important.

     

    Regards

     

     

    TD

  • LukeOB Calculating status...

    How has apple not fixed this problem yet!? I have a Lumix FT3 (a very popular camera in Australia) and it won't import my videos like it used to in iPhoto v9. This must driving hundreds of thousands of people nuts.

  • alanngnet Level 1 Level 1 (0 points)

    I had the same problem today, importing any movie from my iPod Touch (recorded by it) into iPhoto 11 (latest version).

     

    Unmounting, rebooting, and remounting the iPod did not help, nor did exiting and restarting iPhoto.

     

    I did get it to work finally after I emptied the trash in iPhoto (which only had a few photos in its trash).

     

    I tried that after reading the advice above about corrupted iPhoto libraries. Perhaps emptying the trash makes iPhoto rebuild its library?

  • docliam Calculating status...

    I had the same issue today. For me, it seemed to be a unix permissions issue (pictures imported with read premissions but movies didn't)...

  • jeynesm Calculating status...

    My videos taken on a 4S were not importing to my Macbook (running Lion).  To resolve it I made sure that the default photo application was set to iPhoto (I had changed it to Picasa) and I rebooted the Macbook.  On reboot, with the phone connected by USB iPhoto automatically launched and all the videos which had previously refused to sync were now available for import.  Pressing import all and they transferred in seconds.

  • canadajo Calculating status...
    Currently Being Moderated
    Apr 17, 2012 12:43 PM (in response to LukeOB)

    I had the same problem, this helped:

    1. install Quicktime 7 from your old snow leopard CD, don´t download from the internet

    2. then follow the instructions that Neutronjon gave in https://discussions.apple.com/thread/3211124?start=0&tstart=0, if you have the same error message

    I have had this problem for a year now, tried all sorts of things, and this finally worked!

  • canadajo Level 1 Level 1 (0 points)

    I had the same problem, this helped:

    1. install Quicktime 7 from your old snow leopard CD, don´t download from the internet

    2. then follow the instructions that Neutronjon gave in https://discussions.apple.com/thread/3211124?start=0&tstart=0, if you have the same error message

    I have had this problem for a year now, tried all sorts of things, and this finally worked!

  • Canadian1982 Calculating status...

    I have found that if you import your video files that Iphoto does not accept via File and then Import that it will then import your clips into Iphoto.

  • gmandel2 Calculating status...

    I had the same problem, except that initially both stills and videos imported to iphoto just fine. then yesterday my videos were all left out and when i tried to manually drag them to iphoto i got a message they were unreadable by the program. then i remembered that  i recently changed my recording quality AVCHD to AVCHD Progressive. i thought this may be the difference. i was right. as soon as i set the rec. quality back to AVCHD the videos all showed up and imported into iphoto. i'm not saying this is always the problem, but i bet it's responsible for a large percentage. Check to see if you changed any settings or if your settings are originally compatible. Hope this helps.

     

    George

  • guildandepi Calculating status...

    I'm making progress.  I emptied the iPhoto trash and then successfully downloaded one video from my iPhone....as you suggested.  I thought I was home free, but got the error again when I tried to download the whole lot on my iPhone.  Then I tried one just one video and got the error again.  So close to getting this resolved.  I wonder if my closing and reopening iPhoto had something to do with it.  I will let you know if I figure this out.  Very frustrating!

  • CGrace Calculating status...

    I'm having the same problem. Called Apple, and they were able to give me some very viable options:

     

    Open "Image Capture" -- all the content on your iPhone should appear. Then just select the videos and hit IMPORT.

     

    This worked for me, when iPhoto kept getting hung up on two very large video files (30 and 40 minutes each, 5/6GB).

     

    If this doesn't work, I would suggest installing the Dropbox app, and have all you photos and videos sync to it.

     

    Good luck!

  • c1mth0g Calculating status...
    Currently Being Moderated
    Nov 17, 2013 3:39 PM (in response to CGrace)

    I have the same problem.  I managed to use Image Capture to copy the movies to my Mac, but iPhoto will not import the movies from my iPhone or from the copy on my Mac.

     

    The movies seem to play fine.

     

    Not sure if this is realated to the iOS 7.0.4 update.

  • Lance Fortenberry Calculating status...

    Just in case it helps anyone here, I had a problem importing and viewing videos in iPhoto 11 (9.5.1). After seeing some of the discussions here and in other threads, I started looking into QuickTime components. Once I removed the Flip4Mac & Perian components from /Library/QuickTime and restarted iPhoto, everything went back to playing and importing.

  • dunno Calculating status...

    Thank you! I could not figure out what was blocking the import of videos from my iPhone 5S into anything on OS X 10.9.1 -- some videos would import fine, others had errors in iPhoto, iMovie, ImageCapture. They played fine on the phone, just wouldn't come in. Deleted Perian, re-booted, all is well.

  • JonBoyEditor Calculating status...

    Lance, YOU ARE AWESOME!!! I have been looking for a solution to this problem since upgrading to MAVERICKS. I've done install/wipe and install/preferences, new libraries, new users, and in one short answer you solve it. You are a legend, Sir.  All my videos now import into iPHOTO. **** YOU Flip4Mac! Cheers Jono

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.