Skip navigation

Recently restored computer won't charge

158 Views 1 Reply Latest reply: Apr 26, 2013 6:08 PM by Eustace Mendis RSS
Fifi21 Calculating status...
Currently Being Moderated
Apr 26, 2013 4:52 PM

Hiya, I just go a small problem with my macbook, the battery won't charge, and if I unplugg it it will turn off immediatly. There is just this black cross on the battery logo. I saw numerous posts about this, but the thing with my computer is that I just got it back from the Apple Maintenace Service, so did something happened, did they changed something or damaged the battery ? Or do I just have to switch something in the Preferences, or update ? I tried to reset the SMC, but nothing.

 

Need some help, I'm really confuse.

MacBook Air, Mac OS X (10.6.8)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.