Skip navigation

Is my Magic Mouse Dead?

63889 Views 116 Replies Latest reply: Apr 21, 2014 6:16 AM by seemebefree RSS
  • Sergio B Netto Level 1 Level 1 (55 points)
    Currently Being Moderated
    Apr 26, 2013 9:39 AM (in response to carpethanger)

    But as I said earlier, I think this problem probably can be related to Mountain Lion, because I was using the same mouse for a long time with an iMac running Lion, and this problem began when I connected it to a Mini Mac with Mountain Lion.

  • carpethanger Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 26, 2013 9:31 PM (in response to Sergio B Netto)

    Yes Sergio, as you say, YOUR issue may well indeed be entirely related to Mountain Lion and nothing else.

     

    I don't have Mountain Lion.  I have Snow Leopard.  And fortunately I have never had any connection issues with the mouse which you are suffering from.

     

    I attempted to be clear that my posts were ONLY addressing the issue that started this entire thread, the fact that the Magic Mouse would suddenly no longer power on. NO GREEN LIGHT on the bottom of the mouse. The original poster was having this exact problem, as did I, which was why I posted my "fix" in the event someone else might be suffering similarly and if lucky this same "fix" would work for them likewise.

     

    If the mouse won't turn on in the first place, then Mountain Lion or any other operating system will not be able to communicate with it no matter what, poorly or otherwise.  I'm sorry to hear Mountain Lion is causing issues with yours and hope you soon find out what is causing those problems.  I can certainly appreciate your resulting frustrtations.  Thankfully for me, my battery swapping experiments with new and used batteries back and forth in the mouse totally fixed MY problem and I'm once again a happy Magic Mouser.  I hope you shall soon discover your own fix likewise to end your frustrating Mountain Lion connection woes.

     

    So, my posts refer ONLY to folks whose Magic Mouse simply will NOT turn on, even with brand new batteries installed.  No Green Light on bottom of mouse. 

     

    Anyone having actual mouse connection issues using Mountain Lion or a Mac Mini should follow Sergio's posts for I'm sure a fix will pop up for him to post soon.  Good luck Sergio! 

     

    (BTW: perhaps these mice are somehow getting into a "bluetooth lock" of some sort, which may be part of all of our issues here, which might explain why for some folks resetting the computer pram "clears" or resets the mouse bluetooth to work again, and may also be why the mouse locks itself off in the first place and then refuses to power on again until its own bluetooth is tweaked somehow, either from computer pram reset, or voltage fluctuations from numerous battery swaps, or battery terminal cleanings etc.

     

    I previously experienced bluetooth stereo headphone connection issues while trying to stream video to an ipad which were only fixed by changing some settings in the wifi router (- really!) to keep from dropping the bluetooth headphone audio connection between the imac and the ipad.  Go figure, change the wifi router to fix the bluetooth headphones. But it worked!

     

    And on that note Sergio, maybe even try moving some of your equipment around a bit. Perhaps its and/or the mouse are somehow picking up interference of some sort and causing your glitches. The above mentioned bluetooth headphone issue was also agravated by where they might be and what might be in between them and the signal source (other electronics, walls, chimneys, whatever...). The Mini is certainly easy enough to try in a diff't spot for a bit and see if you notice any change. Could be interference from something as simple as magnetic field from poorly shielded speakers nearby, or even a nearby television or telephone, etc.  Hey, you never know!... worth a shot if it works!  Again, good luck!)

  • Bertie Von S Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 22, 2013 5:18 AM (in response to smartsale)

    I had same problem as many other people above. My Magic Mouse is two years old and for the first time since I've had it the low battery warning came on last week. Yesterday the batteries finally died, so I bought some more this morning and the mouse still wouldn't work (no green light). Having read above posts I tried the SHIFT+CTRL+OPTION button trick and that didn't work, nor did cleaning the sensors. Finally, I tried both pairs of batteries from my TV and Sky remote and they both worked fine. The original batteries were Energiser, the new ones I bought today were Duracell and, weirdly, the ones from my remote controls were one pair of Duracell and one pair of Energiser!?

     

    So just as someone above suggested it seems to be a lottery when it comes to the brand (or even specific pair) of batteries which will work...

  • Sergio B Netto Level 1 Level 1 (55 points)
    Currently Being Moderated
    May 24, 2013 4:05 PM (in response to Bertie Von S)

    Besides all the problems with the Magic Mouse, I have noticed now that with the Mountain Lion the battery lasts less than half the time it lasted when I used it with Lion. I wonder what is going on with this new OS?

    I think I'm going to use back my old wired Apple mouse.

    It's a pity that I will lose all finger commands that are embedded in Mountain Lion.

  • jamesfromsoldiershill Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 25, 2013 11:21 PM (in response to smartsale)

    Hi,

     

    I had the same problem. My Magic mouse inexplicably just stopped working one day- no green light, no anything even with new batteries. I thought it was gone for good- but weird because it's never been mistreated, dropped, or anything and always used in a clean environmnet. It looks brand new apart from the fact its about 2 years old.

     

    After reading this thread, I cleaned the battery connectors, even though it looked like there was nothing on them, I just rubbed them with a clean dry cloth. I put in another set of batteries, and it just started working again.

     

    I've got absolutely no proof to back this up, but I suspect it might be some kind of build up from using alkaline batteries. But I could be totally off the mark.

  • shazfran Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 29, 2013 10:46 AM (in response to DaveLord)

    Coincidentaly, both magic mice on our home desktop imacs stopped responding within a day.

    I changed batteries several times without success until reading your post. After scraping the terminals, we are

    up and running on both computers. Thank you DaveLord.

  • frankie the dog Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 29, 2013 5:32 PM (in response to Bertie Von S)

    I started having the same problems, especially after changing batteries. After trying some of the posted remedies I noticed the small access holes for the + end of the batteries. I put a small piece of foil into each hole to allow for better contact. So far so good. I will update if this turns into a long term cure.

  • frankie the dog Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 24, 2013 4:58 AM (in response to smartsale)

    Update: the foil I placed in the battery + holes did not work long term. I have found that when left Idle my mouse will link to my wife's Imac in the next room, therefore it stops looking for my mac mini. This, along with unwanted zooms, is a new feature that came with Mountain Lion. I will keep searching. Maybe a new address, though I'm not sure how.

  • Nick Lightbody Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 17, 2013 3:03 AM (in response to smartsale)

    I had a Magic Mouse disfunction some time ago which was solved with the advice fro IB retired earlier in this thread as reported above. Having now suffered the issue or a similar one again I have collated all the various advice into a logical series of steps as follows:

     

    Fixing unexpected behaviour of a Magic Mouse

     

    (1) delete com.apple.bluetooth.plist in Library/Preferences

     

    ----

     

    (2) Reset the tracking and lag for the magic mouse:

     

    Open terminal and type in: defaults write -g com.apple.scaling (choose any number between 2 and 8)

     

    Then you need a restart your mac and it should be sorted - so now take step (3).

     

    ----

     

    (3) Resetting the SMC - on portables with a battery you should not remove on your own

     

    Note: Portable computers that have a battery you should not remove on your own include MacBook Pro (Early 2009) and later, all models of MacBook Air, and MacBook (Late 2009).

     

    Shut down the computer.

     

    Plug in the MagSafe power adapter to a power source, connecting it to the Mac if its not already connected.

    On the built-in keyboard, press the (left side) Shift-Control-Option keys and the power button at the same time for 10 seconds.

     

    Release all the keys and the power button at the same time.

     

    Press the power button to turn on the computer.

     

    ..... Now you can take step (4) below if you wish ......

     

    Note: The LED on the MagSafe power adapter may change states or temporarily turn off when you reset the SMC

     

    Move pointer over Bluetooth icon on menu at top right. Choose “Set up Bluetooth Device”. When window opens up turn off the mouse for 2 seconds and turn back on. Mouse should show up in window. Pair mouse.

     

    If that does not help, delete the device, restart the computer, and let the assistant find it again.

     

    ----

     

    (4) Reset the NVRAM / PRAM.

     

    Shut down your Mac.

     

    Locate the following keys on the keyboard:

     

    Command (⌘), Option, P, and R. You will need to hold these keys down simultaneously in step 4.

     

    Turn on the computer.

     

    Press and hold the Command-Option-P-R keys before the gray screen appears.

     

    Hold the keys down until the computer restarts and you hear the startup sound for the second time.

     

    Release the keys.

     

    ----

     

    (5) Bluetooth and wifi can conflict with each other because they both use the 2.4Ghz band.  Another way to fix the problem is to change your Wifi to a lower channel like 1-3 or to change to the 5Ghz band.

     

    http://support.apple.com/kb/HT1365

     

    ----

     

    Cheers

     

    Nick Lightbody

  • enjaybee Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 26, 2013 5:23 AM (in response to Nick Lightbody)

    My Magic Mouse died this morning. I was using Duracell Plus Power batteries which my computer had already told me were running low on power.

    So when it died this morning I put new batteries in which happened to be Duracell Ultra - No green light, tried 2 sets of batteries (both of which worked fine in a torch) and still no light.

     

    Dug around the kitchen drawer and found a couple of Duracell Power plus in the back corner - Put them in and hey presto! Mouse working again!!!

     

    Weird!

  • faramarzh Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 26, 2013 6:20 AM (in response to smartsale)

    SO i left the dead mouse on my desk and forgot about it since I got a new one..

     

    4 months later, I switched it on and the magical green light went on! So happy! Now i have 2 magic mouse, one for home, one for office.

     

    I think it had to do with the Aluminum housing that makes it much easier for condensation or corrosion to build. leave it indoors for a while to dry out and it should work again.

     

    cheers

  • gam3r Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jul 27, 2013 9:02 PM (in response to smartsale)

    It's been 5 months since I purchased multitouch magic mouse and I have the same problem. I'd suggest you to take it to Genius Bar and get it replaced. I am already on 4th Mouse!! I've been taking it to Genius bar and getting it replaced almost every month. Whats strange is, energizer batteries that come along with the mouse seem to work fine and after 1 month of usage when I swap them with duracell, this random disconnection problem arises, everytime I lift the mouse whilst scrolling results in disconnection. Random mouse shakes, turning on and off seems to bring it back to life. And sometimes it won't even turn on.

     

    This is totally unacceptable for a mouse to disconnect with movements. I'm glad that stuffing paper seems to work for some people. But for a mouse for that price and build quality should not have such basic connectivity problems imo.

  • SmileyPR Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 29, 2013 2:32 AM (in response to monkeyinaspasm)

    Same problem here.

  • SmileyPR Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 29, 2013 2:35 AM (in response to enjaybee)

    I have tried different Duracell types and nothing

  • SmileyPR Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 29, 2013 2:58 AM (in response to SmileyPR)

    OMG!!! I had a pair of used Energizer batteries and IMMEDIATELY our Mighty Mouse started to work!!!

1 ... 4 5 6 7 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.