7 Replies Latest reply: May 6, 2014 6:10 AM by ziggy15
Marty23 Level 1 Level 1 (0 points)

Please help.  My Iphone5 was texting perfectly to both iphones and non-iphones but now it won't text to other iphones.  I can text and receive texts from any phone other than an Iphone.  Incoming IPhone texts appear on my IPad and Mac but not on my phone.  When I try to send a text to another IPhone, it doesn't appear on my friend's iphone.  This problem only occurs when I try to message other IPhones ... it still works with droids, etc.  I'm wondering if I inadvertently changed something in my settings.  Any suggestions???


iPhone 5, iOS 6.1.3
  • 1. Re: My IPhone5 won't text other IPhones.
    ChrisJ4203 Level 7 Level 7 (28,180 points)

    Go into Settings>Messages>see if iMessage is activated. If so, see what the send & receive at settings are, as well as if you have start messages from, and see if it is your cell number. See this support document also http://support.apple.com/kb/TS2755

  • 2. Re: My IPhone5 won't text other IPhones.
    Marty23 Level 1 Level 1 (0 points)

    Thanks for the reply.  My send and receive settings are my phone number and two email accounts.  All three are checked, with the phone number locked (can't remove the check mark) on the "You can be reached by iMessage at:" section.  I've shut down the phone and restarted but still not sending/receiving from other IPhones.  :-(  I'm reluctant to reset the settings but I'm also reluctant to pay the apple store $20 to fix my phone.  Any other suggestions??

  • 3. Re: My IPhone5 won't text other IPhones.
    ChrisJ4203 Level 7 Level 7 (28,180 points)

    You don't say if iMessage was activated. Try a reset on the phone. Hold the sleep/wake and home buttons together until you see the Apple logo and release. This will have no affect on data on the device. See if it works after that. If not, then go to Settings>General>Reset>Reset Network Settings. While this will delete the wifi passwords for existing networks, it does refresh the network. You will have to do into Settings>Messages and activate iMessage again. You will probably need to activate Facetime again as well.

     

    I don't know of an Apple store that charges $20 to fix a phone. If the phone is in warranty and has a defect, they will judge if it should be replaced.

  • 4. Re: My IPhone5 won't text other IPhones.
    Marty23 Level 1 Level 1 (0 points)

    Thank You!!!  I reset the network settings and it did the trick.  You made my day.  This was soooo frustrating!

  • 5. Re: My IPhone5 won't text other IPhones.
    ChrisJ4203 Level 7 Level 7 (28,180 points)

    Glad everything is working.

  • 6. Re: My IPhone5 won't text other IPhones.
    805Librarian Level 1 Level 1 (0 points)

    I was having this same iMessage issue today.  It was so frustrating.  I'm so glad I came here for help.  I reset network connections and now everything works perfectly.  Thanks so much!

  • 7. Re: My IPhone5 won't text other IPhones.
    ziggy15 Level 1 Level 1 (0 points)

    I am having the same problem and as far as I know reset hasn't helped me at all yet? Annoying really, everything was working fine, then I switched on imessage and probably facetime too, trying to be too technical. Texts go to all other phones and I only know one person with an iphone, my Dad. Thing is I only got it him to make texting easier, which was fine until I messed around, but then texts started arriving saying they were from me, having gone through my email account on my Mac, even though they were from him. Mine aren't getting to him at all I've switched off imessage, and MMS messaging too, not sure whether that's right or not and reset the iphone as suggested. Still it seems no message is getting through, but works on all non iphones as far as I can see. Other suggestions have been to switch off cellular data, but I can't have to do that every time to send him a simple text surely? Thing is I live 200 miles from him, so can't even get both phones together at the moment to mess around with them or see just what's happening, and at 82 he's not a lot of help. Texts are as technological as he's got, and couldn't do it on a normal phone, so the iphone keyboard was the perfect answer, until I completely messed it up. All the numbers in contacts are just listed with an area code and actual number, though my number is listed as +44 for uk with the 0 missing. Has anyone got any cure for this annoying problem please. Thanks in anticipation. It's been driving me nuts for two weeks now.