Skip navigation

how to add a web site to the "Java" preferences?

6480 Views 15 Replies Latest reply: Jul 1, 2013 9:30 PM by the-masked-avenger RSS
1 2 Previous Next
the-masked-avenger Level 1 Level 1 (0 points)
Currently Being Moderated
Apr 30, 2013 7:19 AM

Apple states the following regarding Safari 6.0.4:


"When you first visit a website that requires the Java web plug-in, Safari presents a prompt similar to this one but containing the specific website ..."


I didn't authorize a web site when i first visited it. Now, I'd like to add this web site to the list in the "Java" preferences in Safari 6.0.4.


Is this possible and how?


Thanks in anticipation.

MacBook Air (13-INCH, MID 2011), Mac OS X (10.7.4)
  • CT Level 6 Level 6 (14,955 points)

    Safari, Preferences, Security.


  • CT Level 6 Level 6 (14,955 points)

    What did you do when the dialog box appeared, just close the window?

  • CT Level 6 Level 6 (14,955 points)

    And the website doesn't appear in the "Manage website settings" ?  I guess if this happened to me I would try to get the website to ask Safari to load java again.  I would try things like disabling/re-enabling java.  I would try the "clear all" option in the "Manage ... " list. I would try restarting Safari, if not logging out logging in.  Resetting Safari.  etc.

  • Dorse Calculating status...

    I noticed certain features simply do not happen in Safari with Java turned off when I recently changed ISPs and was making change of address at sites that had been using the earlier one. In several instances I clicked "Submit" or the like and got exactly no feedback. Which made no sense. Then, two days ago, in trying to price some Adobe software, when I clicked on a button for more information, again nothing happened. I went to Chrome, pasted the URL, clicked on the button and got a drop down information window.


    I came here because, when I went through the Help symbol at Preferences>Security but got no helpful instructions, so I wrote an explanation in the comment box, but when I clicked Submit THERE I got an error message that included something about a Java exception. I enabled Java and went back to try Submit again, with the same error!


    For the record, here is what I was trying to send to the comment-readers:


    Wanting to control where Java can be run, I clicked on "Manage Website Settings" and got an empty list.



    So I clicked on the Help button on the Preferences>Security page and came to help, which told me NOTHING about HOW to enter websites on that list, that empty list.



    Therefore, no help.



    Hunh! In trying to send this apparently I need to have Java turned on. See? That's just another indication of confusion out here in user land.


    Well, that didn't work either. I will try another route.  END OF NOT-SENDABLE COMMENT.


    Now I will web search for useful information. I have chosen to be kept abreast of this discussion, too.

  • jnojr Level 1 Level 1 (0 points)

    I, too, am looking to find how to add sites to this list.  Whatever "should" have happened when any dialogue box popped up, that ship has sailed... we need to be able to allow sites to run java after the fact, or at a bare minimum to reset a setting so Safari will start to ask all over again.

  • mvrander Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 10, 2013 11:02 AM (in response to jnojr)

    I had the same issue having closed the tab on without providing an answer to the java pop up. Resetting safari didn't work and revisitng the site didn't help. I then went to a different site, java's own in this case and tried the version checker which has an applet on it. That then gave me the pop up for that site. Then going back to the original site which I had previously problems with displayed the pop up question this time.


    Maybe it's having an empy list or safari thinking it's already in the process of asking for permission or something but that let me get past it. Can't be certain it will work for others though

  • aurelw Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jun 12, 2013 7:11 AM (in response to mvrander)

    I'm having the same problem: "Manage website settings" is empty, cannot add a new website, even if I authorize it when the popup opens on my website containing a Java applet.


    Can Apple do something? At least, write an answer?



  • Loki Level 1 Level 1 (70 points)

    This is messing me up as well.  I have a military site that uses a java app as a document viewer which does not load because the site is not authorized to run java.  However, I was NEVER prompted to allow java to run on this site.  This is a royall pain in the a s s.

  • aurelw Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jul 1, 2013 12:25 AM (in response to Loki)

    Finally, I went first to and I got prompted to accept or block this website to my java accepted websites.

    After that, I went back to my website, and it finally asked me if I wanted to add my website to accepted websites.


    Hope it will work for you!

  • jnojr Level 1 Level 1 (0 points)
1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.