1 Reply Latest reply: Apr 30, 2013 3:21 PM by logosfrombellingham
jfch Level 1 Level 1 (0 points)

This problem has dogged me since 10.6. I am running 10.8.3 on a MacBook Air and a MacBook Pro (Retina), and this workaround does not work. Does anyone have a valid solution that consistently allows me to unlock my Macs using AD credentials? Currently, when there is no connectivity to the AD Domain Controllers, I cannot consistently unlock the screen saver. When it fails it either hangs, or the password field is simply cleared and I cannot renter a password (or the password is not accepted). Interestingly, if I type a bad password it will be rejected, and I get the 'shake', but a good password is not accepted.


MacBook Pro (Retina, Mid 2012), OS X Mountain Lion (10.8.3)
  • 1. Re: Still a problem on 10.8.3
    logosfrombellingham Level 1 Level 1 (0 points)

    I'm also seeing this problem within my organization, especially on laptops with mobile accounts. Another (possibly related) issue has been that I've seen the kcm and opendirectoryd processes near or over 100% cpu utilization each sometimes.

     

    We use AD for user authentication, and Open Directory running on a Mountain Lion Server for client management. AD is the first directory in the search policy.

     

    When the clients hang I can use screen sharing to access them remotely, so the system isn't hard locked, it's just the lock screen.

     

    I'm in the process of digging through system logs to try and find any clues, but in some of these instances it doesn't even look like an attempt to unlock the computer is being made based on what I've seen so far.

     

    If I can get a really good log file sample, I'll post them up here.