Skip navigation

Magic Mouse - Disable horizontal scrolling ?

78114 Views 56 Replies Latest reply: Apr 10, 2014 8:43 AM by iamquoz RSS
  • Michael at Choice Hotels Level 1 Level 1 (0 points)

    Scrolling (in any direction) continues to be an issue with the magic mouse in almost any app that requires user input.  The screen is constantly jumping about as windows scrol left, right, up and down.

     

    The problem is that my index finger rests on the mouse.  As I move the mouse to position the cursor, the device detects my index finger hitting the surface and concludes incorrectly that I want to scroll.

     

    After nearly 9 months, I finally solved the problem today.

     

    By creating a small dead zone on the mouse surface using some tissue paper and blue painters tape to hold it in place, I have "patched" my magic mouse so that it works the way I want it to. I'm not getting any random scrolling any more maiking a huge improvement in general usage.

     

    The great thing is that the gestures still work.  Just use any other part of the mouse that isn't covered by the tissue and tape (about 90% of the mouse in my case) for standard magic mouse gestures.

     

    Now If I could just convince Apple to modify the software to ignore the upper left corner of the mouse I could remove this ugly blue tape.

  • vilko Level 1 Level 1 (0 points)

    Is anyone listening at Apple? Please allow either through command line prefereces or in preferences panel to disable vertical one finger scrolling with Magic Mouse.

     

    Thank You!

  • Andrew Kinnear Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 8, 2011 12:00 AM (in response to Robert Gallup)

    Thank you LEK 2 and Robert,

     

    That was just the job.

  • Woody Vondracek Level 1 Level 1 (10 points)
    Currently Being Moderated
    Dec 29, 2011 11:20 AM (in response to Robert Gallup)

    Robert Gallup,

     

    THANK YOU! That does the trick without entering any code... SIMPLE!

  • DarrinL Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 31, 2011 9:59 AM (in response to Woody Vondracek)

    I've found the MagicPrefs app to be the perfect solution to this problem.  Let me explain:

     

    While browsing the web, I prefer to have horizontal mouse scrolling enabled but when using Lightroom or Photoshop, horizontal scrolling becomes a nightmare and I want it disabled.

     

    With MagicPrefs, I created a preset that disables horizontal scrolling and then bound both Lightroom and Photoshop to this preset.  You can do this in MagicPrefs by clicking on the "Preset Actions" button at the bottom of the screen and selecting "Bind specific applications to this preset".  I then switched back to the default preset within MagicPrefs to return to the normal scrolling behavior (horizontal scrolling enabled).

     

    With the above setup, horizontal scrolling is enabled for all applications except Lightroom and Photoshop.  Whenever you switch to one of these apps, MagicPrefs automatically disables horizontal scrolling.  It will also re-enable the setting when you switch to a different app.

     

    Give it a try, I think you'll find that this solution provides the most flexibility.  Best of all, MagicPrefs is a free app!

  • Lorin Toews Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 23, 2012 11:50 PM (in response to DarrinL)

    DarrenL, your suggestion is exactly what I was looking for. After installing MagicPrefs, I disabled side scrolling in Dreamweaver but kept it for everything else.

  • John Link Level 1 Level 1 (85 points)
    Currently Being Moderated
    May 1, 2013 11:48 PM (in response to RonHerrema)

    Thank you for posting the information about MagicPrefs! I like the Magic Mouse scrolling for viewing documents, but when I'm editing documents, especially in Final Cut, Pro Tools, Sibelius, InDesign, and Excel, the inadvertant scrolling that happens so often drives me nuts! By turning off all three finger scrolling I eliminate the inadvertant scrolling. Perhaps I will even turn off all two finger scrolling, so that if I want to use the scrolling I must intentionally remove from the mouse all but one of my fingers.

  • muttzart Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 14, 2013 10:42 AM (in response to walter maldeghem)

    I'm a graphic designer with a brand new Imac running Mountain lion. The Magic Mouse horizontal scroll has been driving me nuts.

     

    Tried the Terminal method - didn't work for me.

     

    Tried downloading Robert's little Applescript posted on page 1 - didn't work for me.

     

    Finally tried MagicPrefs - solved the problem instantly. Very easy to download & install - and seems to reliably do everything you're likely to need a mouse to do. (I've disabled everything except vertical scrolling!).

     

    Just one question to ease my anxiety: having put the required command into Terminal (which seems to have had no effect) can I just forget about it? Or is it likely to cause me a problem? (Same question applies to the Applescript - but I think I reversed the command on that just in case).

  • TOSONA Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 12, 2014 12:59 PM (in response to muttzart)

    MagicPrefs! Brilliant! Thanks so much. Really, I don't know why Apple wouldn't build in at least some (working) options into OS X.

  • Lipamala Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 18, 2014 10:30 AM (in response to RonHerrema)

    I installed MagicPrefs on my Mac with OS 10.8.5, because I wanted to disable horizontal scrolling in inDesign and was unable to using the standard Mac mouse prefs. This only disables horizontal scrolling for the finder.

     

    Magic Prefs only worked part way for me in inDesign.

     

    Once MagicPrefs is installed, launch it from your preferences window>Other, and see the MagicPrefs icon.

     

    In MagicPrefs, I first tried to disable horizonal swiping for inDesign under the Magic Mouse tab (the first tab of three), but this did not work in inDesign. So then I opened the "Configure Scrolling" radio button at the bottom right side of the MagicPrefs dialog window, which launches a new window above. There you can disable the horizontal finger scrolling for 1-3 fingers. I opened inDesign and tried to horizontal scroll again. This time it did scroll slowly when gesturing my index finger right to left, but I could not get it to horizontal scroll right to left again. This is not a complete fix, but it is better than before. Before it would scroll horizontally quite quickly without my intention.

     

    Apple needs to allow users to adjust the mouse gestures to be application specific. The horizontal scrolling has caused me much frustration and two embarassing mistakes with clients projects when using inDesign. I wish that I could get my money back on this mouse. They need to send out a software fix if they can. I hate to go any now re-buy a mouse.

  • muttzart Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 18, 2014 2:45 PM (in response to Lipamala)

    MagicPrefs works fine for me in all software - including InDesign (which I use all the time and, like you, needed stabilised for professional reasons). My configuration is:

     

    a) In Apple's Magic Mouse preferences - nothing selected except 'Scroll Direction: natural' and 'Secondary click (on right side)'.

     

    b) In MagicPrefs preferences - nothing selected except (under 'Configure Scrolling') just all the boxes for 'vertical'.

     

    I'm also running OS 10.8.5 - so if that configuration doesn't work same as mine, I don't know why.

  • iamquoz Level 1 Level 1 (0 points)

    To Michael at Choice Hotels who put tape/tissue over the mouse... I got desperate enough today to try this after trying to edit artwork in Illustrator with someone standing at my side and I was shooting all over the screen.

     

    I'm left handed so I blocked the upper RIGHT corner of the mouse. I just tried a small post-it at first, placed at an angle over that corner. It didn't do anything at all; no improvement. I still need it to recognize my index finger, of course, so I don't quite get how you're making this work. Can you post an image?

     

    Otherwise I think I'll beg our Sys Admin for a different mouse.

1 2 3 4 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.