Skip navigation

Safari links not working on apple.com

5072 Views 20 Replies Latest reply: May 12, 2013 2:35 AM by dogweather RSS
  • donkbonk Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 21, 2013 7:48 AM (in response to donkbonk)

    For me, it looks like it was something in my network. Using opendns via my aebs gave the problem on one machine, but not on other computers on the same network. Opendns was also reporting some apple.com pages as webspam (e.g. metrics.apple.com).

    Whitelising apple.com in opendns fixed it for me - a quick test you can do to check if this is the problem you're seeing is switch your dns servers to something like google's dns servers (8.8.8.8 and 8.8.4.4).

     

    Hope it works for others.

  • donkbonk Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 21, 2013 4:52 PM (in response to donkbonk)

    Hmm, can't seem to update my own post, so here's an update:

    I also found a problem with opendns and omniture's tracking.  Requests to 2o7.net were being reported as webspam by opendns and blocked, though traffic to 2o7.net (as far as I know) is to omniture's web analytics, which should be harmless.

  • .ben Calculating status...
    Currently Being Moderated
    May 2, 2013 9:43 AM (in response to Susan Howard)

    I'm having a very similar issue:

     

    Os 10.8.3, latest Chrome and Safari. Clicking links on Apple.com does nothing. Right clicking "new tab" works. Using a user agent spoofer for chrome and reporting as firefox 10 works. Turning off Javascript in Safari and chrome works. Turning Javascript back on allows me to follow one link, then clicking doesn't work. Hovering brings up the link in the status bar.

     

    I'm running little snitch, but with a profile that allows everything, and turning it off doesn't change anything.

     

    I seem to remember the same issue a few months ago, on apple.com and another site (cant recall which). uk.nook.com (mentioned above) works for me today.

     

    This is a weird bug, and I'm not sure where to submit a report - is it Javascript, webkit, the site(s), or the browsers?

  • andyBall_uk Level 6 Level 6 (17,515 points)
    Currently Being Moderated
    May 2, 2013 9:47 AM (in response to .ben)

    you're not using opendns in the router ?

  • dogweather Level 1 Level 1 (10 points)
    Currently Being Moderated
    May 12, 2013 2:28 AM (in response to donkbonk)

    I've had this problem periodically for at least a year.

     

    I use Open DNS. Same problems as everyone else: Apple.com links don't work in Chrome & Safari. They do work though via the "new tab" option. They work in Firefox.

     

    I change my laptop to use Google's DNS - 8.8.*.  Everything works, in all browsers. I change my laptop back to the Open DNS configuration ... things are broken again.

     

    I'd say that confirms it. I'll see if I can send something to Open DNS about it.

     

    By the way, there was a similar problem with Dropbox, but a new release fixed it.

  • dogweather Level 1 Level 1 (10 points)
    Currently Being Moderated
    May 12, 2013 2:35 AM (in response to donkbonk)

    I've started a discussion in the OpenDNS community forum:

     

    http://forums.opendns.com/comments.php?DiscussionID=56515

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.