Skip navigation

iCloud calendar not syncing to iPhone, iCloud calendar not syncing to iPhone

175905 Views 81 Replies Latest reply: Apr 1, 2014 12:46 PM by wout86 RSS Branched to a new discussion.
  • sculley Level 1 Level 1 (5 points)

    My problems were solved by restarting my Mac... the ONE thing that hadn't yet done.  Everything is now syncing properly between the iPad and iPhone and Mac. 

  • ethel Level 1 Level 1 (60 points)

    After scanning through replies I tried easiest solution and it worked for me....just went to iCloud settings on iPhone and turned off sync calenders, then turned back on and everything showed up -- previosuly nothing on my calenders was showing up....

  • Rebecca1125 Level 1 Level 1 (0 points)

    Last week, everything magically synced. I guess Apple had been working on it. However, since then, it has fallen apart again. Items added to my iPhone are once again not showing up in iCloud and the iPad isn't at all accurate. I am careful to only add items via my iPhone and rely only on that since I know the others aren't reliable.

  • MHJ5280 Level 1 Level 1 (0 points)

    ewhizz,

     

    New to Apple "ecosystem" (Macbook Air, iPhone, iPad, all on same day form Mac). Thank you for the clear and simple instructions. Some community member's responses are, like, "Whaaat... ?"

     

    Thanks for helping.

     

    MileHighJames

  • Caliredbud Level 1 Level 1 (0 points)

    I sync both to iCloud, and through a separate one-way sync with Iphone that loads the office's Outlook entries to my iphone. The goal is to have iphone layer the two calendars.  This went fine with Google calendar until I switched over to iCloud in order to get my Ipad in on the fun. Then, items I was entering on my iphone -- which should be syncing to iCloud - weren't showing up on my desktop at home.  What I found solved the problem was to change the default calendar on iphone to the iCloud calendar.  Somehow that got bungled in the transition and iphone was categorizing incorrectly all new entries as Outlook/work.  I did the following and then edited a bunch of entries to re-code them, and it worked.

     

    Settings

    mail, contacts and calendars

    scroll way down to calendars

    tap Default Calendar - make sure your cloud calender is checked, not any other calendars (gmail, etc).

  • yao.rabbitz Level 1 Level 1 (0 points)

    Hi, I don't know if your issues with iCloud, Calender and iPhone has been solved, but I had the same problem a while back, and I just fixed the problem, so I thought I would share my solution and ope that it works for you.

     

    What I did was, I went to Setting - Mail, Contact, Calenders - Calender section - Sync - choose All Events.

     

    Then I refreshed the Calender app by double-pressing the Home button to open the multitasking menu, tap and hold the Calender icon until it jingles, tap the "X" to remove it from the lost, press Home button again to return to Home screenm wait for a few minutes before reopening the Calender app.

     

    After that, I went to Settings - iCloud - off iCould and turn it on back again.

     

    All my calender events are the same with iCloud and Mac Calender! Yay!

  • citykitty00 Level 1 Level 1 (0 points)

    I had the same problem until just now jedimasterkyle. I only started using iCloud a few months ago, so mine was a rookie error, and don't know if it will help you.

     

    When I set up icloud, I found I had two identical sets of calendars showing up on my iphone, one called "From my Mac" and the other called "iCloud".

    I did the right thing and stopped the "From my Mac" calendars from syncing or showing up in the calendar on my phone, and made only the iCloud calendars visible. I was (and still am) too scared to delete the "From my Mac" list, however just in case...

    Anyway, when setting my default calendar on my phone (the one that new events are made in) I wasn't careful, and chose one of the calendars from the "From my Mac" list - which of course aren't syncing with my computer. As the colour and name were the same as the iCloud ones I didn't notice my mistake until just now (obviously after googling lots of stuff and getting annoyed).

     

    BTW if anyone knows whether it's safe to delete that "From my mac" list of calendars from the iphone without affecting all my old appointments on my computer (which I refer to for my tax return) I'd be grateful. I assume it is but you know, technology is scary.

  • Sarah Mao Level 1 Level 1 (0 points)

    yao.rabbitz your tip completely solved my Calendars issue. Thank you a million times over, I was getting stressed out!!

  • DavidBCambridge Level 1 Level 1 (0 points)

    I am in the UK time zone. The times on my iCloud calendar were one hour ahead of the times in my iPhone. I checked was using same calendar for each and also checked time zone on each. However, when i checked time zone on iCloud by clicking on my name in top right hand corner, it stated Greenwich Mean Time. But now we are in British Summer Time so I altered this to London time and voila! all times on the iCloud calendar now sync exactly with times on my iPhone.

  • Davieravie80 Level 1 Level 1 (0 points)

    After much toil and trouble tonight I found the default setting the new iPad 4 has is "My Calendar" when you input new appointments.

    My new iPhone 5 has the default setting as just "Calendar" in the list of boxes below.

     

    Hence why the 2 never sync! Make sure you are syncing both sets by ticking the relevant boxes.

  • mainetc Level 1 Level 1 (0 points)

    This worked for me!

  • nateracecar5 Level 1 Level 1 (0 points)

    I figured out what is going on. This will work, I promise! Go to Settings > iCloud and turn on Calender. It will ask you if you want to merge your calenders. Click "merge" or whatever it says and presto! Everything immidiately syncs! You don't need mess with any calender settings. Do this with all your iCloud stuff and you can use iCloud with all your deviced. These are disabled by default, that is why they weren't working.

  • Mattlaw Level 1 Level 1 (0 points)

    Figured I'd quickly note what worked for me here, since I didn't see it.

     

    I couldn't get my calendars to sync on my iPhone, although they were appearing correctly on my mac, iPad, and at icloud.com.  I tried repeatedly to turn calendar sync under the iCloud settings on and off, to no avail.

     

    What finally worked: Turning off calendar sync, but this time selecting 'remove from iPhone' when it prompts what to do with existing entries.  Turned calendar sync back on, and all my entries appeared. 

  • Sonya221 Level 1 Level 1 (0 points)

    I too had this problem. Events entered into IPAD not syncing with Iphone.  I spent hours deleting reinstalling, making sure ALL settings were EXACTLY the same and nothing worked.  In the end I finally realized that when I opened the event there was a calendar in the event. Once I changed all the calendars to the one I had as defalt they all synced instantly.

  • TorontoMarkham Level 1 Level 1 (0 points)

    This solution worked for me.  Thank you

Actions

More Like This

  • Retrieving data ...

Bookmarked By (5)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.