1 2 3 4 Previous Next 48 Replies Latest reply: Jul 1, 2014 3:34 AM by mayorova Go to original post
  • 30. Re: wi-fi: no hardware installed
    Darth Level 3 Level 3 (620 points)

    Update to my own post - eventually upgraded to ML and the problem seemed to be better (ie, less frequent) for a while. It showed up again, worse than ever, after upgrade to 10.8.2. Tried just about everything described anywhere online -checking and unchecking things, deleting preferences of all sorts, reverting to a Snow Leopard kernel extension, 2 erases and reinstalls of Mountain Lion, disabling/deleting all log-in items, launch agents and launch daemons, trying everything under a test user account as well. 2 Apple hardware test came back negative as did all Genius-perfromed hardware diagnostics. Finally waved the white flag and brought it into my local Apple store where they proposed replacing the Wifi card and flex cable. That was Tuesday night. Just now the store called to say that they could see when they opened the machine that the cable was damaged. They had difficulty detaching the cable from the logic board and damaged the logic board in the process, necessitating replacement of the logic board. They are concerned they "fried a couple of circuits" in the process and asked my permission to send the machine out to the repair depot for further troubleshooting and repair, as needed. Permission? What choice did I have? Actually the choice was for them to order the parts and do the additional repairs in-house. I opted to have it shipped out. Should be back to me in a week or so. Great, and I get my work done how in the meantime? I'll keep my fingers crossed that Friday means Wednesday, I guess. Hopefully and end to the saga, thank goodness for warranties and Apple Care, the MBP is 10 months old.

  • 31. Re: wi-fi: no hardware installed
    Tony850 Level 1 Level 1 (0 points)

    @Darth

    Was your bluetooth working when your wifi went bad?? because I am about to tear my macbook apart to replace the flex cable.

     

    Sorry for your troubles, I know exactly how you feel. I am lucky to have an iMac to comeback to, but still hate that my macbook has had such problems.

  • 32. Re: wi-fi: no hardware installed
    Darth Level 3 Level 3 (620 points)

    I don't believe I was having Bluetooth issues, but can't reliably confirm it as I was not actively using Bluetooth. I've got an iMac at home as the family computer (meaning I have to wait in line to use it) but my MBP is my primary work machine, by my choice. My employer-supplied desktop is an ancient Power Mac G4 with a 1.25 Ghz processor running 10.4. It chokes on just about anything I ask it to do. If I give that up, I'm stuck using a crappy Dell box like everyone else in my department. Sorry I can't be more help re:Bluetooth.

  • 33. Re: wi-fi: no hardware installed
    Darth Level 3 Level 3 (620 points)

    Update to the update. Wifi card, flexcable, and logic board replaced not quite a month ago (see above). Problem is back.

  • 34. Re: wi-fi: no hardware installed
    Robe0706 Level 1 Level 1 (0 points)

    I think all we have to do now is waiting for upcoming update. I've had this problem recently. So frustrated!!!!

  • 35. Re: wi-fi: no hardware installed
    bauherr Level 1 Level 1 (0 points)

    I own an early 2011 MBP 15”, suffering from the well known problem of Airport WiFi (hardware not installed). BT is perfectly working. My OS is ML 10.8.3

     

    I would like to share my thoughts on the (low) probability of fixing it.

    That’s my story, till now.

    I unsuccessfully attempted the usual remedies, such as the SMC and NVRAM reset.

    Since my Mac is still covered by the AppleCare, I contacted the online support. Again, unsuccessful SMC and NVRAM resets. The support personnel told me it is a hardware problem. This sentence “slightly” worried me, and the rest of the story confirmed my darkest concerns.

    I contacted an Apple technical assistance center for fixing the problem. 2 days later, they gave me my MBP back, after the flat (ribbon) cable substitution. We tested together the WiFi in the Apple center: no problem at all. Unfortunately, once back in my office, at first startup the WiFi again refused to run (and still it refuses now, ab 24 hrs after the repair attemp).

    Now, I’m working with a mini-dongle, a solution not properly fitting with a 2000 US$ Mac, bought for professional use. I’ll go back to the technical assistance again, but w/o much hope. The reason of my pessimistic thought arises from an idea I have on the WiFi antenna location inside the Mac.

    I’ve never dismantled a MacBook Pro, but I learnt that the WiFi antenna is placed in a very strange location, that is: practically INSIDE THE MONITOR HINGE (is it true?)

    This is a very delicate place for any notebook, because it is … mobile.

    Yes, it seems that the antenna (mobile) is connected to the motherboard (fixed, in the aluminum case) with a flat ribbon, and it rotates with the monitor.

     

    And now, that’s my concern.


    The movement involves a mechanical action on plugs and pins, with possible and subtle deformation of such pins, plugs and their supports. Again, that location is subject to heating up and, then, to possible thermal action combined with mechanical ones. That could mean that, very rarely and with erratic and random evidence, the WiFi antenna can loose its connection, perhaps for the monitor movement as well as for small tolerances in production and/or assembly steps (in my opinion may be matter of microns).

    This could explain the erratic results of the repairs. Erratic means ranging from complete success to temporary stops or recovery, without any predictable behavior.

     

    And now… HOLD ON TIGHT !


    If my hypothesis is correct (doubt is mandatory), the problem may be CAUSED BY THE DESIGN CONCEPT of the MBP, concerning the WiFi location. This may have a direct influence on the erratic results of the technical assistance work. Then, it is very difficult to foresee the problem will be 100% fixed by the ordinary technical assistance. To tell all the truth, if I’m right (doubt is mandatory), a well lowest score may be regarded a first class result in these conditions.

    On the other hand, locating the airport (WiFi antenna) inside the metal (aluminum) case, may also have its operating, and even worse, drawbacks.

    I want to point out that I’m not complaining about the Apple support and technical assistance, both friendly and skilled, and I’m not blaming the Apple design department.

    However, I’ve a few consultancy experiences concerning operating and safety problems reported in electric and electronic consumer products. In many cases, sneaky and subtle problems were due to particular design choices, correct for “almost” 100% of equipment. Almost means: random problems for a number of equipment with NO STATISTICAL RELEVANCE. And this may be a problem for us, “poor consumers” when facing the producer. No statistical relevance can mean: problem not recognized by the producer. This is just to be realistic. Continuous improvement is required from Apple, in any case.

     

    Last but not least, this is an useful video on MBP WiFi:

    http://www.youtube.com/watch?v=UsSIUs7jzQc

     

    PS: I’m writing from Rome - Italy

  • 36. Re: wi-fi: no hardware installed
    holyfolly Level 1 Level 1 (0 points)

    AHHHHHHHH. THAT, is magic. Read through the discussion with all the cumbersome sounding troubleshoot methods that almost drove me crazy and I decided to start with the easiest - the bluetooth. My bluetooth is always hidden from the menu bar so I had to check its status from the system preference. That was when I realised I've ALWAYS had it turned on. So Instead of turning it on like you did, I turned it off. And after a restart, I witnessed the miracle. This **** thing is finally working again! Had to log in just to thank you for that! Thanks!

     

    P.S I have a iPod and a Macbook and I got a new phone recently too. A Droid. HA.

  • 37. Re: wi-fi: no hardware installed
    stansongman Level 1 Level 1 (0 points)

    I have fought this issue since I installed Mountain Lion.  I tried following all the wives tales to fix this, from SMC/PRAM reset, deleting the sleepimage, etc.  I even put in a new wifi card which didn't work either, so I went back to the original card.

     

    Yesterday I took the back off once more, and made sure the antennae wires were all seated properly so they could not be pinched in any way.  I then removed the ribbon cable, reseated it, and put a piece of black electrical tape over the wifi side of the cable (the original black plastic "tape" wasn't sticking any more), and actually I covered the antennae as well.  It's been working for over a day now without fail which it hasn't done since my Mountain Lion upgrade.  I believe that the problem has either been some pinching of the antenna from the display, or else a ribbon cable that had a flaky connection to the wifi.

  • 38. Re: wi-fi: no hardware installed
    feeel Level 1 Level 1 (0 points)

    Hi all,

     

    This is my first post in the apple discussions forum (even though I've been a Mac user since 2006), and I'm happy to say that this is a FIX post not a problem post.

     

    I was in the same situation as all of you - "Wifi - no hardware detected". I have an early 2011 MBP 15", and like most of you, I tried all the suggestions and I even stripped the laptop down so that I had the screen off and had access to the antenna.

     

    No matter what I did, the problem kept coming back after a couple of hours.

     

    Eventually I came accross a post that said it was something to do with the soldering at the point where the wifi / bluetooth ribbon cable attaches to the motherboard. Given that I'd exhausted all other options (other than going to an Apple store), I figured why the **** not give it a try.

     

    The fix:

    I ripped an ordinary Post-It note so that I had about 1/4 of the size, and folded it so that it was the size of my thumbnail (3 folds thick). I then took the back off my MBP and stuck the thumbnail-sized Post-It note to the back of the ribbon cable at the point where it attaches to the motherboad. Then I replaced the back cover and booted up. Basically, the Post-It provides additional pressure at the connection point, which stops the cable loosing contact with the faulty soldering connection.

     

    I've been without any issues for a good 14 hours straight now (including moving the lid, moving around the house, shaking it, etc). You might say that this is a bit too soon to claim that I've fixed the matter, but I've been struggling for 7 days with this, and 2 hours was the longest I managed without having the error.

     

    Fingers crossed!

     

    Phil

  • 39. Re: wi-fi: no hardware installed
    stansongman Level 1 Level 1 (0 points)

    I finally bought a new ribbon cable (probably wasn't necessary - I think the problem is just what you've discovered - the connections can become lose with movement).  I taped it down really well at the wi-fi card end, and then also in the center of the cable at the DVD drive.  I have been running for a month solid now, without any wifi problems at all.

  • 40. Re: wi-fi: no hardware installed
    Licious84 Level 1 Level 1 (0 points)

    I have the idea that there are several forms of this bug. All of the above didin't help for me so i tried something i read in a similar post.

     

    Open terminal :

    run: sudo -rm -f /var/vm/sleepimage

     

    After this you do a hard reboot so no settings get saved again. (A hard reboot is when you keep holding the power button until the computer shuts off).

     

    After i did this my wifi was up again and it hasn't failed yet. ( 8 hours ).

     

    Hope this works for you.

     

    Cheers

  • 41. Re: wi-fi: no hardware installed
    fuchatortuero Level 1 Level 1 (0 points)

    How do you "Open terminal"?

  • 42. Re: wi-fi: no hardware installed
    Darth Level 3 Level 3 (620 points)

    Terminal is an application in your Utilities folder in your Applications folder. However, it's generally recommended that if you're not sure what you're doing with it, that you leave it be, as it gives direct access to the Unix underpinnings of the Mac OS and it's possible to do some very scary, irreversible things to the OS from a Terminal window, especially using "sudo", which is a shortening of "superuser do". Be careful, good luck.

  • 43. Re: wi-fi: no hardware installed
    ViruSynergy Level 1 Level 1 (0 points)

    Let me save you all some major time as i went through this and tried everything and no fix!! 

     

    1. Take your bottom case off.

    2. Disconnect your battery.

    3. Take out your HDD

    4. Externally mount your HDD and boot into it.

    5. Turn on wifi test it then install back into your machine.

     

    hope this helps !

  • 44. Re: wi-fi: no hardware installed
    goransson Level 1 Level 1 (0 points)

    A very great fix Phil!

     

    And it did the trick for my early 2011 MBP 15". I'm really happy to be wireless again.

     

    Thank you for your post!