2 Replies Latest reply: May 5, 2013 5:52 AM by LarryHN
brenthudson2 Level 1 Level 1 (0 points)

Please can you help

I have an old whight mac duel core intell just installed snow lepard and now need iphoto but version11 will not work so ? can I use version 6


iPhone 5, Mac OS X (10.6.8), Old mac