Skip navigation

MacBook Pro will not remember my wireless network after sleep

50910 Views 53 Replies Latest reply: Feb 13, 2014 4:03 PM by chressaapple RSS
  • RTen1 Calculating status...

    thanks to drfrot -

    I had the same problem and it is a simple solution, at least for me:  go to Sys. Preferences, Network, and open the small gear icon under the Network list and go to Set Service Order, then drag your current / primary wifi network to the top of the list. 

     

    Since the MBAir does not have ethernet built in, and it typically will use wifi networks, I assumed it would default to the wifi networks to which I've connected,  BUT if one of the bluetooth networks is set above the wifi network in the service order, it seems it will not usually connect automatically to one of your preferred networks.

     

    When I set my network to the top in Set Servie Order, it worked perfectly for connecting to preferred networks after coming out of sleep. 

     

    drfrot:   "It was the simplest thing that got it working - using the "Set Service Order..." option from the little gear icon underneath the list of my connections. I thought that Airport was at the top of the list, because when nothing else is connected, it automatically moves itself up to the top of that list. But when I went in to "Set Service Order...", it was actually at the bottom, underneath (disconnected) Ethernet + Bluetooth + FireWire."

  • SRA Calculating status...

    I found the solution when I changed my SSID name and password.

  • jivetalkingturkey Calculating status...

    i have the same deal. i am now running Lion 10.7.3. my wife has the same os. i have a newer 15' macbook pro where hers is and earlier 13' mac book. she has no dramas connecting anytime or any dramas with Lion....(thank God for that) but me i have to plug in the ethernet cable to recognise... frustrating.. i'll keep reading these forums for a solution. i nuked my drive and reformatted it with Lion and it started to work. as soon as i loaded all my data back on to complete the install. it decided to forget again...

  • stanleykup Calculating status...

    I have a Macbook Pro 17" 10.5.8 OS and have been dealing with this problem for quite some time and finally took the time to search for a solution.  After reading a number of these threads I started with the easiest fix, which was the Time Zone adjustment to my Airport Extreme to sync with my computer.  Since changing the timezone on my WIFI a few days ago, I have not had a single issue since.  I wanted to give it a few days before I posted my response to make sure it was in fact resolved.  The timezone change was the perfect fix for me.  Thank you to whom ever it was that posted this fix!!

  • stanleykup Level 1 Level 1 (0 points)

    I have a Macbook Pro 17" 10.5.8 OS and have been dealing with this problem for quite some time and finally took the time to search for a solution.  After reading a number of these threads I started with the easiest fix, which was the Time Zone adjustment to my Airport Extreme to sync with my computer.  Since changing the timezone on my WIFI a few days ago, I have not had a single issue since.  I wanted to give it a few days before I posted my response to make sure it was in fact resolved.  The timezone change was the perfect fix for me.  Thank you to whom ever it was that posted this fix!!

  • mark.allender Calculating status...

    Thank you.   I was having this exact problem over the last week and never tied it to DST.  Seeing this point, I went to my router settings and changed when the router recognizes DST (it's running ddrt).  After saving that, I've had sucessful connection everytime I come out of sleep on my MBP.

     

    Thanks again.

  • Slugfest Calculating status...
    1. THIS WORKS:
    2. Go to System Preferences > Network.
    3. Click the Wi-Fi connection.
    4. Click the Advanced... button on the bottom right.
    5. Click the Wi-Fi tab.
    6. Under Preferred Networks, select your wireless network.
    7. Click the - (delete) button.
    8. Turn off your Wi-Fi connection.
    9. Turn it back on.
    10. Select and login to your wireless network. This will re-save your connection under Preferred Networks.
    11. Close your laptop and reopen it to test whether it worked.
  • mikee316 Calculating status...

    this worked very well cheers

    this solved my problem, would give it a tick if i could work out how to do it

  • Mcclaude Calculating status...

    Thanks so much, my WIFI connection is now remembered. simple and reliable trouble shooting.

  • Gummyworms Calculating status...

    I had the same problem. As soon as I changed my internet settings to WPA2, my macbook did not automatically connect. The fix was to remove my network in advance settings WHILE THE AIRPORT UTILITY IS OFF. i then selected my network to WPA2. I think the problem for me was that my linksys status in airport said "none" under 'security' when I actually had the WPA2 settings on the router. The good news is the answer is within your macbook not the router settings. Goodluck!

  • at tenagra Calculating status...

    I'm having the same problem and none of suggestion made here make sense to me. I don't understand how to for example--uninstall parallels! What does that mean? This began about a week or so ago and must have to do with some recent update since I've not changed anything. I'm so frustrated to have to change networks and wait for things to take before sending a rush email everytime my MBP wakes. 10.6.8 by the way.

     

    ###@%^&*!!! ARGG!

  • TheLoracle Calculating status...

    Thank you so much!!!!  I tried the other suggestions on this chain and only this one worked!!!  Yay!

  • javrivera Calculating status...

    Thanks SLUGFEST! Your steps are what fixed mine. The other posts prior to yours did not work unfortunately.

  • mdinfl Calculating status...

    Perfect, easy nontechnical fix 2013 mba

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.