9 Replies Latest reply: May 7, 2013 12:49 AM by mdi
Dabooss891 Level 1 Level 1 (0 points)

When ever I go to a website using safari it always loads weird and not how it should. Here is a screen shot.

Screen Shot 2013-05-06 at 4.09.38 PM.png

How can I fix this?

Thanks!


MacBook Pro, OS X Mountain Lion (10.8.3)
  • 1. Re: Safari not working correctly!
    William Lloyd Level 6 Level 6 (19,350 points)

    Are you running a 3rd party extension?  AdBlock can cause things like this.  You need to tell AdBlock to not block things on Apple.com as it is wrongly mangling the site.

  • 2. Re: Safari not working correctly!
    Imp68 Level 4 Level 4 (2,155 points)

    Click the Safari menu >> reset safari.  Uncheck everything except remove all website data, then click reset and confirm it.

     

    You could also trash ~/Library/Caches/com.apple.safari and ~/Library/SavedApplicationState/com.apple.safari.savedstated.  If you do this, safari should be quit, first.

     

    edit - William makes a great point.  You may want to look at this article:  http://support.apple.com/kb/TS3230

  • 3. Re: Safari not working correctly!
    William Lloyd Level 6 Level 6 (19,350 points)

    I have seen this specific issue with AdBlock on apple.com which is why I mention it.  It's easy to add apple.com to AdBlock's white list. I forget exactly how I did it but once I did everything rendered fine.

     

    Apple's site doesn't have ads on it so there's no reason for AdBlock to go blocking/breaking stuff there.

  • 4. Re: Safari not working correctly!
    Dabooss891 Level 1 Level 1 (0 points)

    I dont have adblock

  • 5. Re: Safari not working correctly!
    Imp68 Level 4 Level 4 (2,155 points)

    Ahhh good to know.

     

    I actually just installed AdBlock to give it a test, and you're absolutely right.  I was able to produce very similar results to the screenshot above.  Not exactly, but close enough to be suspicious. 

  • 6. Re: Safari not working correctly!
    William Lloyd Level 6 Level 6 (19,350 points)

    Any extensions?  Go to Safari Preferences->Extensions and turn off ALL extensions (big toggle at the top) and refresh the page.

  • 7. Re: Safari not working correctly!
    Dabooss891 Level 1 Level 1 (0 points)

    Ive tried

  • 8. Re: Safari not working correctly!
    Linc Davis Level 10 Level 10 (117,820 points)

    Please read this whole message before doing anything.

     

    This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.

     

    Step 1

     

    The purpose of this step is to determine whether the problem is localized to your user account.

     

    Enable guest logins* and log in as Guest. Don't use the Safari-only “Guest User” login created by “Find My Mac.”

     

    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.

     

    Test while logged in as Guest. Same problem?

     

    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.

     

    *Note: If you’ve activated “Find My Mac” or FileVault, then you can’t enable the Guest account. The “Guest User” login created by “Find My Mac” is not the same. Create a new account in which to test, and delete it, including its home folder, after testing.

     

    Step 2

     

    The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login, or by a peripheral device.

     

    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode and log in to the account with the problem. Note: If FileVault is enabled, or if a firmware password is set, or if the boot volume is a software RAID, you can’t do this. Post for further instructions.

     

    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on certain Macs.  The next normal boot may also be somewhat slow.

     

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    Test while in safe mode. Same problem?

     

    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of steps 1 and 2.

  • 9. Re: Safari not working correctly!
    mdi Level 1 Level 1 (20 points)

    Uncheck Safari Menu > Develop > ”Disable Styles“