Skip navigation

Why can't I boot from my hard drive internally but no problem externally?

2155 Views 6 Replies Latest reply: May 14, 2013 9:51 PM by Too_Talls RSS
Too_Talls Calculating status...
Currently Being Moderated
May 2, 2013 10:30 AM

Being unable to 100% solve my problem based off solved problems I have decided to log in. I will start from the very beginning. The computer is the Macbook late 2009 unibody. I upgraded the ram from 2GB to 8GB. everything was going smoothly until like 2 months ago. My 250Gb Hard drive was geting maxed out and in the midst of downloading I was getting warnings to free space so I was deleting and downloading the same time.....and then boom...the computer froze. Couldn't forse quit or anthing only choice was to manually power off. when I powered back on the screen was grey and would not start. I reserched solutions and ended up resetting the PR ram. after that the screen changed to white and nothing happened for a long time I was stuck...until......:


I bought an external hard drive incasing. and like magic everything I thought I lost was right there booting externally. Now I'd be fine with that if not for the reason I bought the computer in the first place, which is to be ultra portable and kep me awake as I work nights as a security in various changing post on a nightly basis. lugging the external case around has complicated a system that was working fine to the point of death.


So over time I have acumilated these things:

a 16 GB hp flash usb currently holding the bootable snow leapard DVD installer


a 500GB wd scorpio blue hard drive from an old PC pased laptop


a 250GB toshiba hard drive (came with laptop snow leopard installed)


a  250GB can't think of the brand cause I'm using it now hard drive (mountin lion installed)


neither Hardive holding apple operating systems will boot internally but boot externally. I have tried putting snow leopard, lion and mountin lion on the scorpio blue but everytime I get the same result, an install failed error. So you may have guessed, I was hoping the scorpio blue as my last hope, getting an operating system on it maybe I could boot internally but for what ever reason it won't  intall fully any mac os X. So at this point I want to know if it's possible for me to just put a windows operating system on it ad if it may be able to boot that way.



when partioning the hard drive, if I have it connected internally, the computer recognizes it but I get cannot unmount errors. externally everything moves smoothly but it won't install the operating system. Currently I'm running mountin lion externally and I have the big hard drive inside the computer and it shows up as "untitled 1" it contents is two folders "Mac os X Install data" (red icon attached) and "private" It tells me I don't have permission to look inside the mac os folder. if I drag a fle from my computer to untitled 1 it says "The operation can’t be completed because an unexpected error occurred (error code -50)."


HELP! whatever it takes I just want to boot something without lugging this external case everywhere.



More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.