11 Replies Latest reply: May 10, 2013 10:42 AM by georgesdev
John Hobbles Level 1 Level 1 (0 points)
I tried to burn a dvd and found some old DVD+R's laying around the house. I put in the disc, and then iTunes froze. I force quit that, but then was unable to eject the DVD+R. I restarted my computer and tried again but it would not eject. Is there anything I can do? The DVD+R shows up on my desktop, and I even tried to drag it to the trash but to no avail. Thanks for the help!

Black MacBook, 2.2GHz Core 2 Duo, 1 GB 667 MHz DDR2 SDRAM, Mac OS X (10.5.8)
  • 1. Re: Unable to Eject Disc
    Lyssa Level 6 Level 6 (15,515 points)
    Try restarting your computer and holding the trackpad/trackpad button down. This should force the disc to eject.

    ~Lyssa
  • 2. Re: Unable to Eject Disc
    Grantman Level 1 Level 1 (60 points)
    I have the same problem. Hope you don't mind jumping on your post.

    I've rebooted holding down the trackpad button, trackpad and button, cmd-E, the eject button, etc. The icon for the inserted disk does not show up on the desktop so I can't drag it to the trash.

    The optical drive makes all the appropriate noises but the disk does not eject...it's simply stuck. Any further ideas?

    Thanks, and Merry Christmas.
  • 3. Re: Unable to Eject Disc
    DICKWRIGHT Level 1 Level 1 (0 points)
    I have same problem. Help
  • 4. Re: Unable to Eject Disc
    ayyonikkib Level 1 Level 1 (0 points)
    I had the same issue today.I was attempting to install SL on mine when someone told me a way to help read the thing i suppose was shut down the computer with the program in.Not such a good idea cause mine got stuck and my computer wouldn't turn on past the turn on noise.

    However,the way I got it out was I stuck a small thin cardboard piece inside.It basically stopped the cd from going around a couple times and then it popped the thing out.You might have to hold it in for a few but by doing that it will come out.
  • 5. Re: Unable to Eject Disc
    A guy out west Level 1 Level 1 (0 points)
    I am also having this won't-eject problem (including noises from the drive that make it seem like the disc is being ejected), and am happy one of the posters got the disc out by sticking cardboard in the slot. There has to be a less intrusive fix, however. More suggestions welcome.
  • 6. Re: Unable to Eject Disc
    Grantman Level 1 Level 1 (60 points)
    I finally went to the Genius Bar to have them do it. In my case, it seems that when the laptop was carried from here to there around the house, quite often we've been carrying it with the screen open and have been squeezing the top and bottom together on the sides rather than closing it and carrying it on the hinge side. As our MacBook is plastic, the slot itself was getting closed.

    They have a plastic doohicky that gently reopens the slot. The "genius" made it clear not to put anything inside the drive itself but to *very, very gently* twist something like you'd be opening a can of paint in the slot and the slot only. You do not want to even come close to the brushes.

    I don't know if this fix will help the rest of you but my drive has been behaving itself since.

    Good luck to you all.
  • 7. Re: Unable to Eject Disc
    Crystal Phalanx Level 2 Level 2 (215 points)
    Try opening the application 'terminal' and typing the following command

    drutil eject
  • 8. Re: Unable to Eject Disc
    skate108 Level 1 Level 1 (0 points)
    I have had the same problem for ages, saw on a forum that i should insert a piece of cardboard and have been doing that. But it hasn't fixed the problem. I took it to the Mac dealer in Cape Town (where I bought it) and they "repaired" it at a cost. It worked for about two weeks and then the same thing started happening again. It is not every time, but probably 3 out of 5 times I try to eject a disc, this happens. I was so surprised when I saw how many people have this same problem with the MacBook. Does anyone know of any way to have this repaired for good?
  • 9. Re: Unable to Eject Disc
    Kevin Maness Level 1 Level 1 (0 points)
    I'm having the same problem. I just received my brand new MacBook in the mail yesterday, and the first few times I ejected a disk--today and yesterday--it made an unusual racket. I thought maybe I was just used to the MacBook Pro's slightly quieter eject process. But then, one time, it made the racket and didn't eject the disk. The disk icon, which had left the desktop, reappeared. I tried a couple more times, and the disk came out.

    Now, there's a disk in the drive (Delicious Library 2 install disk), and it won't come out. I've tried ejecting it repeatedly. When I look at the disk slot while attempting to reject, I see the very edge of the disk just barely visible through the foam bumpers for a moment, and then the disk gets stopped and sucked back in. Pretty soon the disk icon appears happily back on the desktop.

    This shouldn't be happening to a computer that's been out of the box for less than 24 hours. I'm not used to shoddy crap coming out of Apple boxes. I'm pretty **** mad, even if this is a fairly small, mechanical problem. And there's NO WAY that I'm going to accept shoving a piece of cardboard into my drive as a "solution."
  • 10. Re: Unable to Eject Disc
    craftyrancher Level 1 Level 1 (0 points)
    I had the same problem. The tip about the cd slot being squished while carrying it around worked my drive was trying to eject and couldn't, so I pried it apart a few times and the disk has finally popped out. Thanks so much for that tip, hope it helps others too!
  • 11. Re: Unable to Eject Disc
    georgesdev Level 1 Level 1 (0 points)

    I had the same kind of problem, but in my case the cause was a virtual machine (virtualbox) "owning" the drive.

    When I told the virtual machine to release the drive, then I could eject the cd with the eject key of the keyboard.