1 25 26 27 28 29 Previous Next 432 Replies Latest reply: Feb 7, 2014 10:16 AM by Big Rock Go to original post Branched to a new discussion.
  • 390. Re: Mail bug in Mountain Lion
    Csound1 Level 8 Level 8 (35,285 points)

    xairbusdriver wrote:

     

    And you don't think the code for the two Mail apps is similar?! DOH!

     

    OK, stick with the OS X versions. It broke with 10.8. How long ago was THAT?!

     

    It's not like they don't know about the problem. Look at the number of threads about it. Look at the number of PAGES of post in this thread!

    I'm still waiting for mine to break, so I can't answer that. But if you don't want to explain what is wrong, why you are here I can't help at all.

  • 391. Re: Mail bug in Mountain Lion
    xairbusdriver Level 2 Level 2 (160 points)

    if you don't want to explain what is wrong

    Sorry, I thought the previous 26 pages (and the other several threads) pretty well covered that part. I'm here because I finally lost enough patience to seek an answer. Instead I find several dozen (hundred?) people still waiting for the fix. I'll see if I can find a "Rant" smlie to mark my posts...

     

    I'm still waiting for mine to break

    Does that mean you're not using ML or that your addy is not being included in every "Reply to all" message?

  • 392. Re: Mail bug in Mountain Lion
    Csound1 Level 8 Level 8 (35,285 points)

    Yes, am using ML

     

    No my address is not included in reply all

  • 393. Re: Mail bug in Mountain Lion
    xairbusdriver Level 2 Level 2 (160 points)

    So, why isn't your 'fix' shown as the 'best solution?" Why are there still posts about this problem as late as Apr 8, 2013? I'd be most happy, thrilled, even, to know the solution.

  • 394. Re: Mail bug in Mountain Lion
    Csound1 Level 8 Level 8 (35,285 points)

    Clearly you are not looking for help from me, good night.

  • 395. Re: Mail bug in Mountain Lion
    xairbusdriver Level 2 Level 2 (160 points)

    g'night. I'll check further the several other threads on this same topic. Maybe something happened between today and April 8. Idunno.

     

    Have a great weekend!

  • 396. Re: Mail bug in Mountain Lion
    seanfromminato-ku Level 1 Level 1 (0 points)

    I am also till waiting for a fix. Csound1, if you no longer have the problem I, along with xairbusdriver and I am sure countless others, would love to know how you made it go away. I have it on this machine, and also on a mchine that I did a complete disk erase and clean install of ML on (although I did migrate the account so I have no idea if the problem resides in mail itself (I am almost certain it does given the nmber of people complaining about it) or with the mail settings for the account.

     

    Anyhow, I can't alter the behviour and it is as annoying now as it was when this thread started.

  • 397. Re: Mail bug in Mountain Lion
    Kawanaut Level 1 Level 1 (50 points)

    I think I have an idea what might be going on, since some say they have the bug and others say they don't.

     

    I remember for several years now, I've had the issue with Mail.app including my own email when I "reply all". But sometimes it didn't happen.

     

    However, with all this fuss, I started paying more attention, and it seems that whenever my own e-mail is included in CC, and I "reply all", then I'm _not_ included in my own reply.  But, if my own email is in the "To" field, along with a bunch of others, and I reply all, my own email is included back into the CC field along with all the other recipients (except the sender, he goes into the "To" field).

     

    So for me, I would prefer people to CC me, because then I can just "reply all" without having to remove myself from the recipients

  • 398. Re: Mail bug in Mountain Lion
    xairbusdriver Level 2 Level 2 (160 points)

    @seanfromminato-ku: I saved every thread I could find in a search of these forums and plan on spending a few hours reading them this morning to see if anyone has found a permanent/useable solution. Apparently, I upset Csound1 with my imitial rant, Sorry 'bout that. I was amazed that there is still no obvious fix. Hopefully, it is on Apple's list.

     

    Additionally, with this thread being so long, it is possible that a solution is hiding in one or more of its 26+ pages. All the others I found are much shorter, but the majority simply state the problem in a slightly different manner. What a way to spend a nice Saturday! 

     

    I did see one 'solution' that requires adding a line to a Plist. Unfortunately, that can be dangerous for some noobies. I will try that as a last resort. It is certainly not a user-friendly solution and one that Apple could have offered in a very meager 'update.'

  • 399. Re: Mail bug in Mountain Lion
    xairbusdriver Level 2 Level 2 (160 points)

    That may be a solution but not really a fix. We hardly have an opportunity to 'teach' everyone sending us messages how to do it differently just for Mac users using ML. Sounds like a good way to simply be removed from a lot of messages! Many email users can barely use the basic features much less figure out how and where to put their friends addresses. I'm amazed that so many have no idea what BCC is for or why they should be using it instead of CC. :headbash:

     

    OTOH, it may be easier to 'teach' everyone else i the world than the developers at Apple!

  • 400. Re: Mail bug in Mountain Lion
    Ernie Stamper Level 8 Level 8 (37,475 points)

    I have continued to carefully test this "bug" as originally observed.  I could originally replicate the initial problem statement (reply from wrong email address) when replying to messages that had been Moved to a new folder -- that has now been fixed.

     

    However, a side issue now clearer since that correction, is that a Reply All to a message that has been so Moved will included your own email address.  However, that cannot be replicated with 1) any message that has remained in the original Inbox, nor 2) with any messages opened via their inclusion in a Smart Mailbox, but not Moved.

     

    To summarize, I can only replicate the issue with inclusion of your own email address in the distribution on messages residing in a mailbox folder to which they have been Moved from the receiving Inbox.  A message Copied to such a folder, but also left in the original Inbox will demostrate the issue when replying to the message from the folder, but will not when replying from the message still residing in the Inbox.

     

    On those few catagories of messages I Move to a specific folder, it has not been a problem, and I don't worry about it.  Most of my email processing takes place in the original Inbox, and there it is not a problem.  If a Smart Mailbox is used to provide a segration of certain types of emails that remain in the receiving Inbox, it will not be a problem there, either.

     

    Ernie

  • 401. Re: Mail bug in Mountain Lion
    xairbusdriver Level 2 Level 2 (160 points)

    Seems there are/were two different "Reply" problems:

    1. A 'simple' Reply to the sender and not to anyone else
    2. The Reply to All problem

     

    Number one seems fixed, probably by the last update (10.8.3). Although I never neoticed it to begin with.

     

    Number two is still around for me regardless of where the message is located.

    • Some had found that if the message is moved (manually or by Rules), the Reply to all would always include your addy. That certainly is my problem.
    • Others seemed to find that if the message is still in he Inbox, the Reply to All did NOT add your addy. That is not what I'm seeing.

     

    Of course, I can prevent the inclusion of my addy by changing the Compose preference to Automatically Bcc: myself. But unchecking that pref simply reverts to putting my addy in the CC field.

     

    The only thing I can suggest to to keep sending bug reports to Apple: http://www.apple.com/feedback/macosx.html

  • 402. Re: Mail bug in Mountain Lion
    DPBest Level 1 Level 1 (0 points)

    I'm at 10.8.3 and issue #1 is definately NOT fixed on my system.  Issue #1:  A simple reply to a message that has been moved out of the inbox is not adddresed from the email account to which the original message was sent.   Can someone other than the last poster check issue #1 again and post the result please?

  • 403. Re: Mail bug in Mountain Lion
    ShsAz Level 1 Level 1 (0 points)

    DPBest, when you reply, you want the "From" to be equal to the "To" from the original message.  This is fixed for me and many others in 10.8.3.

     

    Recall that any address you want to appear in your reply's "From" must be in your account's "Email Address" list in preferences.  You can add multiple addresses there separated by Commas.

     

    For example: Email Addres: myAcct@gmail.com, thatName@foo.com, otherName@bar.com, etc...

     

    The only remaining bug in this thread is if you "Reply All" instead of "Reply", your own address appears in the CC list.

  • 404. Re: Mail bug in Mountain Lion
    DPBest Level 1 Level 1 (0 points)

    This is definately NOT fixed on my system. 

     

    I'm at 10.8.3, Mac Mail is 6.3 (1503).   Incoming message to account X is moved to a folder other than the Inbox.  Reply (simple) to that message is sent from the default account Y, NOT from the account X to which it was originally sent.  Verified 100 percent as accurate description of the behavior on my system.  Guaranteed.

     

    Would someone else double check this behavior on you 10.8.3 system and post results.  If it is indeed working correctly on your system, I'd love to hear an astute suggestion as to why my behavior doesn't match yours.

     

    ShsAz:   WRT your comment regarding account setup, just how would you expect me to have received the original message to account X, if account X wasn't in my account list to begin with?   Duhhhhh.  So yes, the From account in question IS in my account list.