Skip navigation

MAIL won't stop asking for a password.

3564 Views 12 Replies Latest reply: May 11, 2013 5:07 PM by somanyjaimes RSS
Scott Mosher Level 1 Level 1 (5 points)
Currently Being Moderated
Jan 18, 2013 9:16 PM

For some reason this just started happening. Mail is CONSTANTLY asking for a password in one of my accounts. I've zapped the PRAM, I've used Keychain and deleted the one account and used Keychain first aid, and I've repaired permissions and re-started the **** computer. ALL to no avail. I keep getting Mail asking for the password at random intervals. Any ideas or what am I missing here? This is literally driving me nuts.

Quad-Core Intel Mac Pro, Mac OS X (10.5.6)
  • BDAqua Level 10 Level 10 (114,790 points)
    Currently Being Moderated
    Jan 18, 2013 10:20 PM (in response to Scott Mosher)

    In Mail's Window Menu, choose Connection Doctor, any red dots for status, if so what is the exact message?

     

    Then click the Show Details button & Check again.

     

     

    The Password rejection can confuse people since it's a catch all meaning...

     

    This Password, Username, Authentication method... is not recognized on this Port to this Server.

     

    So if WebMail works it's not Name or Password, but one of the other ones.

  • BDAqua Level 10 Level 10 (114,790 points)
    Currently Being Moderated
    Jan 18, 2013 11:53 PM (in response to Scott Mosher)

    Could be this?

     

    Keychain Access asks for keychain "login" after changing login password...

     

    http://support.apple.com/kb/HT1631

  • BDAqua Level 10 Level 10 (114,790 points)
    Currently Being Moderated
    Jan 20, 2013 10:05 AM (in response to Scott Mosher)

    If using a browser to login via WebMail works with the same info, it's not Name or Password, but something else.

  • Brewster Magneto Level 1 Level 1 (40 points)
    Currently Being Moderated
    Jan 20, 2013 11:22 AM (in response to Scott Mosher)

    I've had this problem too, and it's always because the password for the POP3 account gets deleted from Mail's Preferences (under Accounts), or else a duplicate keychain entry has somehow appeared--without a password--and that's the one that Mail chose when it was time to fetch the mail. Have you verified that: (a) the password for this account is in the Account Information pane of Mail's Account preferences, (b) Password authentication is selected under the Advanced pane of Mail's Account preferences (with the port that your ISP has recommended and also the Use SSL checkbox if applicable)?

     

    Also, check Keychain Access for anything that looks like a duplicate entry for this account that doesn't have a password--for this you'll need to click the "i" button when the account is highlighted and then click "Show Password" in the popup window.

  • BDAqua Level 10 Level 10 (114,790 points)
    Currently Being Moderated
    Jan 21, 2013 10:37 AM (in response to Scott Mosher)

    Who is your eMail provider, the part after the @ sign?

  • BDAqua Level 10 Level 10 (114,790 points)
    Currently Being Moderated
    Jan 28, 2013 9:34 AM (in response to Scott Mosher)

    The Password rejection can confuse people since it's a catch all meaning...

     

    This Password, Username, Authentication method... is not recognized on this Port to this Server, or a server end problem.

     

    If using a browser to login via WebMail works it's not Name or Password, but one of the other ones.

     

    The receiving email ports are:

     

    IMAP is port 143

    IMAP-SSL is port 993

    POP is port 110

    POP-SSL is port 995

    Outgoing ports are...

    SMTP and SMTP-SSL is on ports 25, 587 and 465. Port 587 has to be SSL, and port 465 is enforced TLS-wrapped and is generally used by Outlook users.

  • strida Level 1 Level 1 (5 points)
    Currently Being Moderated
    Feb 6, 2013 7:17 AM (in response to Scott Mosher)

    I have been plagued by the same problem for months.  Just tried something which seems to have fixed it; no idea if it will work for you.  Under Preferences > General, I found that my Default Email Reader said "Eudora", which I used as my mail client years ago.  I set it back to Mail, and the password requests seem to have stopped.

     

    Could be wrong, but thought I'd share.

  • somanyjaimes Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 11, 2013 5:07 PM (in response to Scott Mosher)

    This happens to me too, incessantly!! The worst thing is I can be typing in another window and suddenly I'm typing in the password bar that aggresively pops up again and again - driving me so nuts! At the very least, the password request could remain in the background. Alternatively it would be good if I could limit the number of times Mail prompts for a password per hour.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.