Skip navigation

Delete all backups of "filename" from Time Machine not working in Mac OS X 10.8.3?

1096 Views 35 Replies Latest reply: May 11, 2013 10:01 PM by Pondini RSS
1 2 3 Previous Next
antdude Level 1 Level 1 (0 points)
Currently Being Moderated
May 11, 2013 1:03 PM



When I right click on a Time Machine (TM)'s back up file to delete ALL back ups. They don't seem to go away. I can still do quick look, restore, etc. on the requested deleted all files! Am I doing this wrong, misunderstanding this, or is there something wrong with this TM backup that started late last summer 2012?


Thank you in advance.

OS X Mountain Lion (10.8.3), 13.3" MacBook Pro (9,2/MD102ll/A)
  • Linc Davis Level 10 Level 10 (107,630 points)

    Are you trying to delete a whole snapshot, or all snapshots of a single file?

  • Linc Davis Level 10 Level 10 (107,630 points)

    First add the volume to the exclusion list in the Time Machine preference pane.

  • Pondini Level 8 Level 8 (38,710 points)

    antdude wrote:

    . . .

    Trying to delete all backup snapshots on the external USB HDD.

    You mean all your backups?  If so, just erase the drive with Disk Utility.


    The "Delete Backup" option is to delete a single backup.

  • Pondini Level 8 Level 8 (38,710 points)

    antdude wrote:

    No, not everything. Just the specific backed up files I don't want on the external USB HDD.

    Then you need to select the item(s), right-click, and select the "Delete all backups of <items>" option. Is that the one you used?


    Did you then get a confirmation prompt, and one for your Admin password?


    Message was edited by: Pondini

  • Pondini Level 8 Level 8 (38,710 points)

    antdude wrote:

    . . .

    Yep. They didn't get deleted right away on screen. But other snapshots do get deleted, but most aren't.

    If there are a lot of backups, it may take a few moments for the file(s) to be deleted from all of them.


    And note that it will only delete files with the identical name in the identical location;  if you've moved a file from one folder to another, so it's in different places on different backups, it will only delete the one in the location you specify.


    I noticed something else weird. Sometimes I do and do not get that administrator password prompt.

    I wouldn't swear to it, but you may only get the Admin prompt once, as long as you don't quit the TM browser.

  • Pondini Level 8 Level 8 (38,710 points)

    antdude wrote:

    . . .

    How long would it take if I started this TM machine back up back in summer of 2012?

    It shouldn't take more than a few minutes, unless the backups are on a network, and you're connected wirelessly.  That could take longer if the connection isn't good.


    If there's a large number of items selected, it may take a bit longer, too.


    Generally, if your backups are quick, the deletion should be fairly quick;  if your backups are slow, the deletions may be slow, too.


    If it's been a long while, there might be a directory problem with the backups;  you might want to repair them, per #A5 in Time Machine - Troubleshooting.

  • Linc Davis Level 10 Level 10 (107,630 points)

    Please navigate in the Finder to the backup volume. At the top level is a folder named "Backups.backupdb". Inside that is a folder with the name of your computer, and inside that is a folder named "Latest". Inside the Latest folder are subfolders with the names of each of the volumes that you back up from the computer. Is the name of the volume you tried to delete among them?

1 2 3 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.