6 Replies Latest reply: May 15, 2013 2:45 AM by NPJCA
NPJCA Level 1 Level 1 (0 points)

I have an ipod touch 3rd generation that has been lost for months and I have recently just found it. I tried connecting it to the computer because it was out of charge and it immediatley started charging. I left it until the apple logo came up and I waited for it to come to the slide to unlock screen but it didn't. Instead the little itunes logo came up and a usb connecting to it that showed me I needed to connect it to itunes. (I have the latest version of itunes) I opened up my itunes and the ipod didn't show. I searched my whole computer and I cant find it anywhere. I have tried holding the power and home button so the apple logo comes up but it just takes me back to connect to itunes. I cant do anything in settings on my ipod or whatnot because I cant even access my ipod, so don't mention anything that requires going onto the ipod itself. I really need help with this, and I don't want to pay for a reset from apple.

 

Cheers, NPJCA


iPod touch (4th generation), iOS 6.1.3, 8 GB Ipod touch 4th Generation