Skip navigation

After restoring iPhoto library, iPhoto does not recognize library

251 Views 6 Replies Latest reply: May 14, 2013 6:19 PM by ADillMN RSS
ADillMN Calculating status...
Currently Being Moderated
May 13, 2013 5:59 PM

OS 10.8.3

iMac 3.1 GHz Intel Core i5

iPhoto '11 ver 9.4.3

 

I had my iPhoto library on an external hard dirve that crashed.  I replaced the hard drive and restored the iPhoto Library from Time Machine (went into time machine, selected the last back-up, and selected restore).  When I opened iPhoto, it asked me to select a library.  I go to the hard drive and the iPhoto Library is there, but in light gray so I can not select it.  In the "Get Info", it list is as a package and says to open it with Terminal.  I tried to change it to open with iPhoto, but get the error message, "iPhoto is unable to open this library."  I click Rebuild, iPhoto thinks for a few mooments and then "quits unexpectedly".

 

In finder, when I click on "Show Package COntents", all of the photos, details, etc... are there.

 

Any suggestions on how to get iPhoto to allow me to actually select the library?

 

Thanks,

Adam

iMac (27-inch Mid 2011), Mac OS X (10.7.3)
  • Old Toad Level 10 Level 10 (113,150 points)

    What is the format of that external hard drive?  If it's not OS X extended (jourlaned) and set to have ownership ignored then reformat the drive and restore the library again.

    ignoreownership.PNG

     

    OT

  • Old Toad Level 10 Level 10 (113,150 points)

    If you have room on the EHD select the next to last backup to restore and see if it can be recognized by iPhoto. 

     

    I'd also try this:  create a new empty folder, open the library with the Finder and move all of the files in the library into the new folder.  Now see if iPhoto will recognize the new folder as a library.

     

    Alos download and run  iPhoto Library Manager  to see if it will recognize the library.

     

    There's something going on that prevents iPhoto from seeing it as a legitimate library.  This screenshot shows all of the files in my iPhoto library.  The highlighted file is a result of using iPhoto Library Manage on the library and won't be in your library.

    Finder002.jpg

  • Pondini Level 8 Level 8 (38,710 points)

    ADillMN wrote:

    . . .

    I replaced the hard drive and restored the iPhoto Library from Time Machine (went into time machine, selected the last back-up, and selected restore). 

    As OldToad suggests, as the drive was failing, it may have damaged the library, that damage got backed-up, and you restored the damaged copy.  Restoring an earlier version may well work.

     

    But if his suggestions don't help, are you sure TM really restored it?   Sometimes there are permissions problems with the iPhoto library, and you get a message to that effect, but it's in a fairly small window and folks sometimes miss it;  then TM stops restoring, leaving just the empty package (a special kind of folder), not any of the contents.

     

    That probably shouldn't happen when restoring to a volume that doesn't enforce ownership, though, so I'm not sure what's going on.

  • Old Toad Level 10 Level 10 (113,150 points)

    Try this:  launch iPhoto with the Option key held down and create a new, test library on the EHD.  Import some photos and test to make sure it works as expected.  If it does there's a last ditch effort method of regaining your photos but will lose all your organizational efforts, i.e. keywords, faces, places, books, slideshows, etc. If you get to that point post back and I'l post the workflow.

     

    If you can't create a new library then there may be something amiss with the applicaiton.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.