Skip navigation

how do I sync Gmail contacts on my iPhone?

53203 Views 10 Replies Latest reply: Jan 9, 2014 4:46 PM by Jillden RSS
carrie867 Level 1 Level 1 (0 points)
Currently Being Moderated
May 11, 2013 5:13 PM

I just switched to iPhone from an Android phone. How do I sync my Gmail contacts? My iPhone is pulling my Gmail, but I can't figure out how to sync Gmail contacts into my phone contacts.

iPhone 4S, iOS 6.1.3
  • allen a Community Specialists Community Specialists (2,440 points)
    Currently Being Moderated
    May 14, 2013 12:22 PM (in response to carrie867)

    Hello carrie867,

     


    The following article contains step-by-step instructions for settings up Google Contact Sync on your iOS device:

     

    iOS: Syncing with Google Contacts

    http://support.apple.com/kb/HT4872

     

    Follow these steps to set up contact syncing with Google Contacts:

    1. Tap Settings > Mail, Contacts, Calendars > Add Account > Other > Add CardDav Account.
    2. Enter the following information in the fields:
      • Server: google.com
      • User Name: Enter your full Google email address
      • Password: Your Google account password
    3. Select Next at the top of the screen to complete the setup.

    After you have completed the setup, open the Contacts app on your device. Syncing should begin automatically.

    Additional Information

    Note: Make sure that SSL is enabled (under Advanced settings), and that the port is 443.

     

     

    Best regards,

    Allen

  • salman8486 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 11, 2013 2:41 AM (in response to allen a)

    Thank you it worked for me, But I have another problem..... Now I am having duplicate contacts in my contact. how to delete the duplicate entry?

  • Xissaxbellax Level 1 Level 1 (70 points)
    Currently Being Moderated
    Jul 11, 2013 2:45 AM (in response to salman8486)

    Go into contacts and click "group" in the upper left hand corner. See which contacts are currently being displayed IE: iCloud, gmail, on my iPhone, etc. Turn a couple of them off, and see if half the contacts disappear. It is possible that the contacts are currently being synced from multiple locations, hence the doubleups

  • noodnick Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 17, 2013 3:48 PM (in response to allen a)

    I have the same question and followed the procedure outlined.  However, there was no automatic syncing when I opened my Contacts app.  If I added a new contact via my iPhone or iPad, it did automatically go into my Google Contacts, and vice versa.  But I can't seem to move all of my iPhone/iPad Contacts into the Google Contacts on the PC.

     

    Also, does it matter that I have the contacts on both my iPhone and my iPad?

  • TiffyTiff Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 17, 2013 11:26 PM (in response to allen a)

    Thanks Allen! It worked for me

  • SoGaWhee Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 15, 2013 6:07 PM (in response to allen a)

    Hi,

     

    After you have completed the setup, open the Contacts app on your device. Syncing should begin automatically.

     

    Mine didn't sync automatically.

     

    Regards

    Nicholas

  • noodnick Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 15, 2013 6:56 PM (in response to carrie867)

    Mind did not sync when I opened the Contacts app.  What does work is if I add a contact through the app, it's added to the gmail database, and vice versa.  But the current data in the Contacts app (which is more complete than the gmail database) does not sync/update the gmail database.

  • Hayateen Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 26, 2013 12:28 PM (in response to noodnick)

    Same thing here. New contatcst at my iphone do not go to my gmail

  • Alain024 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 4, 2013 7:18 PM (in response to Hayateen)

    Had the same issue, here is the fix:

     

    Shalu, I just experienced this same problem and the following represents my fix given to me by APPLE and it did work. First make sure you correctly set up your cardDAV account and it's titled "Google" with "Contacts" as the sub description. Click on >>settings<< >>Mail, Contacts, Calendars<<. Now look to make sure you see listed under the ACCOUNTS heading the "Google" account with "Contacts" as a sub heading. This confirms you set up your CardDAV correctly. Second scroll down to the "Contacts" heading on this same screen and click on >>Default Account<< click on >>Google<< to make sure there is a check mark to the right. You Are Done!!! Go back to home screen and refresh everything on your computer.

  • Jillden Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 9, 2014 4:46 PM (in response to carrie867)

    All you really have to do is download the free gmail app from the App Store.  It will ask you if you want it to import all your gmail contacts.  Touch "ok" and they will all be there!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.