Skip navigation

Urgent help. Finder not responding

24915 Views 26 Replies Latest reply: Nov 22, 2013 3:46 PM by gigimari RSS
  • Linc Davis Level 10 Level 10 (108,125 points)
    Currently Being Moderated
    May 13, 2013 7:05 AM (in response to haziqah)

    Unmount all mounted volumes except the startup volume. If the Finder isn't working, you can do this in the Disk Utility application. Launch it by following the instructions below. You may have to quit other applications to get the volumes to unmount.

      

    Relaunch the Finder if it's running, or launch it by clicking its Dock icon if not. Test. If the problem persists, continue.

     

    Back up all data.

     

    Triple-click anywhere in the line below to select it:

     

    rm -i L*/Pre*/{.Gl,com.apple.{rec,sid}}*.plist

     

    Copy the selected text to the Clipboard (command-C).

     

    Launch the Terminal application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

     

    Paste into the Terminal window (command-V). You'll be prompted to confirm that you want to remove each of the following files:  

     

    • Library/Preferences/.GlobalPreferences.plist
    • Library/Preferences/com.apple.recentitems.plist
    • Library/Preferences/com.apple.sidebarlists.plist

     

    Confirm each deletion by pressing the Y key and then return. If you're prompted to delete any other file, close the Terminal window. Don't delete any file other than the three listed above.

     

    Your lists of recent items under the Apple menu will be lost, and you'll need to recreate your settings for the sidebars of Finder windows and open/save dialogs, among others. If the crashes don't stop, post again.

  • Linc Davis Level 10 Level 10 (108,125 points)
    Currently Being Moderated
    May 14, 2013 12:20 PM (in response to haziqah)

    This procedure will revert the Finder views of all folders in your home folder to the default that you’ve chosen. If you don’t want that, STOP.

    Enter the following command in the Terminal window in the same way as before (copy and paste):

    find ~ -type f -name .DS_Store -delete

  • A.Sh Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 3, 2013 4:05 AM (in response to haziqah)

    Hi Everyone,

     

    I'm having exactly the same problem and i can't open the terminal window.

     

    Can you help me with that ?

  • mishmoosh Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 19, 2013 11:29 AM (in response to haziqah)

    I'm having nearly the same problem.

    I made a microsoft word document and saved it to finder, to move to one of my files.

    I moved it, but then finder stopped responding.

    Also there is a 'repeat' thing that comes up when I open anything. You cannot open this repeat, because is not a file.

  • BM2 Love Angel Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 2, 2013 9:48 AM (in response to Linc Davis)

    Wow, man! Thanks a lot for the info.

    I suddenly started getting this error and I thought that my HD had given up on me.

     

    Problem solved thanks to you, Linc! #respect

  • JavierRey Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 19, 2013 10:44 AM (in response to Linc Davis)

    Linc

     

    I have the same problem my finder doesn't open and all icons on desktop dissapear. I can log-in with other user and everything works but with the original user don't

     

    Thanks for your support

     

    J

  • Samnang.l Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 7, 2013 7:40 AM (in response to Linc Davis)

    Your solution work well, thx!

     

    Warning: All my data were delete.

  • gigimari Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 22, 2013 3:46 PM (in response to Linc Davis)

    Thanks Linc,

    I had the same problem.  Once I unplugged all peripherals and rebooted in safe mode the problem was fixed.  For others that have this problem, mine occured when I accidently selected the entire hardrive to open...it was a nightmare.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.