Skip navigation

Airport Express - Very Slow Connection

78719 Views 69 Replies Latest reply: Apr 12, 2014 9:55 PM by biggie69 RSS
  • MadMacs0 Level 4 Level 4 (3,320 points)
    Currently Being Moderated
    May 16, 2013 12:18 PM (in response to jojost1)

    jojost1 wrote:

     

    My Airport network (1 extreme, 1 express) is extremely unstable, my iPad and iPhone are being unconnected every 2 minutes or so.

    Start a new thread. This one is 2-1/2 years old and doesn't properly address stability or current software.

  • K I M B A K A T Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 17, 2013 10:53 AM (in response to Arash Zafarnia)

    I have an aiport EXTREME base station.

    We have an ethernet cable directly connected from EXTREME to an airport EXPRESS. (35 feet away)

     

    We have normal 50 Mbps download.

    The Express was only getting 5 Mbps download. Uploads were the same on both.

     

    Really couldn't figure it out until I found this setting in Airport Utility.

     

    I selected the "EXPRESS" which is the extended base station. EDIT - Made sure it had the same network name same password as the EXTREME.

     

    In NETWORK tab router is in - OFF (Bridge Mode)

     

    I clicked "Network Options" in the lower part of the NETWORK tab.

     

    There was an option to "Block incoming IPv6 conections". I unchecked this. It was checked.

     

    The Express was now getting speeds up to 25 Mbps download. Much better.

     

    I'm not sure why this is..if anyone can add to this..I'm happy now with the speeds but would like to improve it up to 30 or 40 Mbps downlaod.

  • MadMacs0 Level 4 Level 4 (3,320 points)
    Currently Being Moderated
    Jul 17, 2013 6:44 PM (in response to K I M B A K A T)

    K I M B A K A T wrote:

     

    ...In NETWORK tab router is in - OFF (Bridge Mode)

     

    I clicked "Network Options" in the lower part of the NETWORK tab.

     

    There was an option to "Block incoming IPv6 conections". I unchecked this. It was checked.

    Strangely I am unable to select "Network Options" as it's grayed out with Airport Utility 6.3.1 and the lastest Airport Express. It isn't even an option in the old AU 5.6.1. The only difference between your setup and mine would appear to be your use of wired connectivity between the AEBS and the AExpBS, mine is WiFi. All my IPv6 settings are all "Link-local only".

     

    That being said, I'm not seeing low download speeds on any of my Macs or iDevices.

    I'm happy now with the speeds but would like to improve it up to 30 or 40 Mbps downlaod.

    Unless you have upgraded your WiFi to the newest 802.11ac equipment, the rate you have is about as good as you should expect.

  • mohadd Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 9, 2013 7:59 PM (in response to Arash Zafarnia)

    I've been having the same problem for 2 weeks now. I have an Airport Extreme (5th Gen) and an Airport Express (2nd Gen) set to extend the network. I've had this setup for almost a year now with no problems. The two routers are 30ft and 1 floor apart (quite a few walls). 2 weeks ago my internet speeds went from 18.5Mb/s (down) to 8Mb/s and at times slower.

     

    I tried playing with the Wifi channels and frequencies, just for laughs I even started resetting the Airport Express every morning to get back to my original speeds. Nothing.

     

    I was reading through this and checked the band (802.11a/b/g/n) on the Airport Express and noticed it was connected at 802.11a/n with an 'Excellent' connection according to Airport Utility. I forgot to check the connection speed between two routers before I fixed it, sorry. I can tell you it was slow.

     

     

    SOLUTION THAT WORKED FOR ME:

    I went into Airport Utility and under the Airport Extreme > Edit> Wireless tab > Wireless Options > (hold option and click) Radio Mode > 802.11n only (5ghz)-802.11b/g/n. I moved the Airport Express 10ft closer to Airport Extreme and the connection went up to 'Excellent' 144Mb/s. and my Macbook Pro is connected to the Airport Express at 120Mb/s.

     

    Screen Shot 2013-10-09 at 10.44.37 PM.png

     

    My Internet speeds are now 18Mb/s (down) as opposed to the original 18.5Mb/s. I can deal with that.

     

    Screen Shot 2013-10-09 at 10.47.22 PM.png

     

    I hope this helps someone.

  • savmac Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 9, 2013 9:25 PM (in response to mohadd)

    mohadd - your solution totally fixed my same issue, thank you!

  • savmac Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 11, 2013 9:56 PM (in response to savmac)

    Well the lagging issue came back. Previous solution worked great for a couple days... grrrr!

  • dela4 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 9, 2014 1:13 PM (in response to mohadd)

    I was having identical problems to yours. This solution worked perfectly!

     

    Attention new readers-- don't forget to hold down the 'Option' key when selecting 'Wireless Options'. Otherwise you won't see the desired setting.

     

    Peace

  • Christiaan Level 3 Level 3 (525 points)
    Currently Being Moderated
    Mar 24, 2014 9:31 AM (in response to mohadd)

    802.11n only (5ghz)-802.11b/g/n worked for me too, thankis Mohadd.

  • expertlearner Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 4, 2014 8:41 AM (in response to mohadd)

    We have around 10 users and trying the express. Comcast 30Mb down but getting 5Mb after the wireless router in bridge mode. A few users losse conectivity a 1 or 2 times during the day and have to restart the wifi adapter. mohadd fixed the speed issue. Hope keeps well and maybe it fix the conectivity issues too.

     

    Hope Apple fix it in the next firmware update.

  • biggie69 Level 1 Level 1 (15 points)
    Currently Being Moderated
    Apr 12, 2014 9:55 PM (in response to mohadd)

    @mohadd THANK YOU! Instead of all the mumbo-jumbo reasons why it's probably MY fault, that most the big moderators put you through on this forum...you, a level 1, simply gave a solution.

     

    Thank you! I wish all these could be this easy.

1 2 3 4 5 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (5)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.