Skip navigation

How to remove my phone number from iMessage?

135336 Views 59 Replies Latest reply: Apr 11, 2014 3:37 PM by MikeFarbr RSS Branched to a new discussion.
  • Gbrother Level 1 Level 1 (10 points)
    Currently Being Moderated
    May 17, 2013 2:48 AM (in response to bovineone)

    I have this problem, I am also trying to remove the number from my MAC  / ipad also, but cant seem to get this to remove completely, and messages are still going from imessage to my other number, even though it is in a nokia windows handset

  • stevenojobs Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 17, 2013 5:31 AM (in response to Gbrother)

    On your iPad, just go to Settings -> iMessage and uncheck your number of reception, same on your Mac, iMessages - > Pref and uncheck.... Should do the trick. After one week or two where people who send iMessage will never reach one of the device, your number should be wipe out of the Apple server...

  • Viktor Lexington Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 19, 2013 4:42 PM (in response to bigtree1980)

    The ONLY thing that worked for me was to use iForgot (reset the iCloud password). It wipes all the associated phone numbers from FaceTime/iMessage.

     

    Thanks bigtree1980 !

  • FedUpWithApple2013 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 6, 2013 10:16 AM (in response to LeeBrenda)

    So many people are having this issue, I to am I, when trying to text my wife who no longer has a iPhone. Apple needs to fix this now, as in my wifes details it is not listed what so ever as a device or number, yet my works iPhone keeps trying to iMessage her.. Apple fix this immature iMessage product, because clearly it is leaving a data trail breadcrumb which at least is annoying and at the most is a data privacy issue..

  • codehammer10 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 20, 2013 8:07 PM (in response to LeeBrenda)

    I think I have the solution. IF YOU OWN A MAC. I switched from and iphone 5 and went to a s3. I was having the same problem as everyone else and what I dd to fix it is I went to my imessage app on my mac and I went to accounts and I clicked on the imessage account and I saw that my phone number was still checked in the box. I unchecked it and 5 mins later I had my friend text me sayin that the send button went from blue to green and now we can normal SMS text again. If you do not own a mac I would suggest trying to borrow a friends if you can.

     

    I hoped this helped.

  • Schlitz99 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 21, 2013 8:09 AM (in response to LeeBrenda)

    I am having the same issue as most.  The old iphone 4 is now being used as a Ipod Touch.  The new Iphone 5 is being used as a phone.  Just turning off imessage for the apple Id does not solve the issue that we want the ipod touch to still be able to use imessaging but just not with the phone number (just the icloud email address).  When we go to setting>message>send/receive the phone number is listed in the old phone with a check mark next to it but it is grayed out and does not let us uncheck the phone number.  The new phone shows the same except the phone number is unchecked and grayed out meaning we can't change it.  Why can't you just remove a phone number from a device.  None of the suggestions in this thread have worked for us so far.  I also tried setting up a new apple ID and even that is not working.  It keeps saying the me.com email is already set up but it isn't.  Why does Apple have to suck?

  • codehammer10 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 21, 2013 9:16 AM (in response to Schlitz99)

    So your telling me you made a new apple id but you didnt erase the previous backups of your old iphone? I would delete all the backups you have and get your itunes to a factory state(not removing any media) and then reset your phones settings back to factory state(without removing any media) and when you plug it back in set it up as a new phone and back it up from there.

  • Schlitz99 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 21, 2013 4:03 PM (in response to LeeBrenda)

    Is Apple this messed up that you have to go through those lengths?  It will not let me create a new apple id.  How can you get itunes back to a factory state without removing any media?  I tried resetting the phones and that did not work.

  • jdyment Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 25, 2013 6:02 PM (in response to stevenojobs)

    Stephenojobs, Apple said it will take 45 days to clear the system.  They said, "Sorry, it's a system wide problem.  Unless you have the old iPhone to disable iMessage, you just have to wait a month and a half.  Sorry.  We understand the frustation."  Ughhh.  I even went on my son's iPhone 5, logged in as me, turned off iMessage, and then deleted the account, and it did nothing. 

  • dfarnden Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 27, 2013 4:06 AM (in response to jdyment)

    thanks stevenojobs, your suggestion worked for me . Luckily I still have my old iPhone and it worked obviously 'cos it's a device, not sim, change (the sim in my iPhone is now obsolete). Frustrating if you no longer have your iPhone.. Presumably if you sell it on, when/if the new user activates the phone on their own ID it'll change and you'll be 'freed up', I don't know.

     

    **** stupid though

  • kayla127 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 3, 2013 3:51 PM (in response to LeeBrenda)

    I am having this same problem...I'm not really concerned about keeping my same number so do you think if I get a new phone number the problem will be solved?

  • jrdft Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 5, 2013 7:23 AM (in response to kurthurst)

    Thanks - this worked for me..  kurthurst

     

  • wrightty65 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 5, 2013 8:14 AM (in response to LeeBrenda)

    it also worked for me thx Kurthurst..

     

     

    doing a factory reset didnt fix the problem lol, i had to put SIM card back in iphone and turn off the imessage and i also turned off facetime just to be sure, i didnt have to restart that phone again,I put sim in the android phone and yes im getting normal txt from iphone users now :-) , i also had to turn it off the ipad also :-/ !!!

  • ghassanfromgatineau Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 7, 2013 4:52 PM (in response to LeeBrenda)

    People have had it half right. After trying everything I could find on the website, I finally figured it out. The method of signing out of and turning off iMessage is half of the solution. The other half is signing out of and turning off FaceTime on the phone as well.

     

    I recently switched to the Galaxy S4, and after hours of talking to Apple, scouring the internet and messing around with my old iPhone 4 (on iOS 7) this seems to have solved the problem of incomiong text messages from iPhones.

  • iGuyFargo Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 12, 2013 8:26 PM (in response to LeeBrenda)

    Signing out before I switched didn't work, nor did removing it form my other devices.    After all that I was able fix it by doing "reset all network" settings. After that text went right to the new phone.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.