Skip navigation

xterm: Xt error: Can't open display: xterm: DISPLAY is not set

9309 Views 32 Replies Latest reply: Mar 13, 2014 4:55 PM by Phud RSS
  • etresoft Level 7 Level 7 (23,895 points)

    I believe that you are expected to have installed VirtualBox and gotten the virtual machine running at this point. That VM, running on a virtual IP address, is what you should be connecting to. Are you in fact running VirtualBox and that download virtual machine image? As the tutorial suggests, you should ping that IP address to make sure it is working.

     

    The idea is that you will ssh into the virtual machine and have it display windows in your Mac environment. From those windows (running from the virtual machine), you run the mininet program.

  • etresoft Level 7 Level 7 (23,895 points)

    shja wrote:

     

    I have tried pinging the IP address. what should I do now?

    And what is the result?

  • etresoft Level 7 Level 7 (23,895 points)

    Do you have any firewall running or anything? If so, shut it off.

     

    Try the following:

    ssh -v -v -Y mininet@192.168.56.1

     

    It will spit out a bunch of stuff. Hopefully some of it is useful.

     

    You might also try it without the "-v"s or even the "-Y". You aren't trying to follow the tutorial anymore. Now you are just debugging Linux and VirtualBox. Your quest is just to log on at this point. You are far, far away from ever getting an X windows connection.

  • etresoft Level 7 Level 7 (23,895 points)

    Try ssh -v -v without the -Y. You are debugging Linux here. Baby steps.

  • etresoft Level 7 Level 7 (23,895 points)

    OK. Now I am confused. Originally you were user SHREYA20 and now you are starting and ending as mininet.

     

    Open a new terminal. Type "whoami" and press enter. Then type "hostname" and press enter.

    Do ssh mininet@192.168.56.1

    At the prompt, type "whoami" and press enter. Then type "hostname" and press enter.

     

    I am beginning to suspect you logged in correctly and are now just running in a loop.

  • etresoft Level 7 Level 7 (23,895 points)

    What you are doing is logging into the mininet account on your Mac. It must be Virtual Box that can't do the virtual network interface properly. On your Mac, go to System Preferences > Sharing and turn off remote login. Then restart your machine and try it again.

  • etresoft Level 7 Level 7 (23,895 points)

    Go back and re-do the "Finish VM Setup" portion of the tutorial. Virtual Box is either not running or is not listening for connections correctly.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.