Skip navigation

SMB Shares will not work. Ever.

3145 Views 8 Replies Latest reply: May 21, 2013 5:33 AM by Delarado RSS
Delarado Level 1 Level 1 (0 points)
Currently Being Moderated
Jan 4, 2013 4:42 AM

Guys,


Ive been trying for a while now and I cannot get my MBA to connect to ANY SMB Share through the GUI.


I can get it to work through the terminal using something like:


mount_smbfs //'COMPUTERNAME-OR-DOMAIN-NAME;USERNAME':PASSWORD@x.x.x.x/Shared SMB_Mount


This successfully mounts the windows based SMB share called "share" and shows in my finder. Note the single quotes. It WILL NOT work without these, although I can't find the usage of them listed in any documentation for the mount_smbfs command. In the case above I'm using my own, non domain MBA with a local login to connect to a windows 2008 server that is a member of a windows 2003 domain controller domain; Although I am using a local administrator account to authenticate with said 2008 server that contains the SMB share.


However, If i try and mount through the GUI using CMD+K, it just will not work. I have tried:


smb://'COMPUTERNAME;USERNAME':PASSWORD@x.x.x.x/Shared


Brings up a window saying enter your username and password for the server. It already has the correct computername\username filled in in the username box. I put the password in, hit ok and either the box just shakes, or it says:


"There was a problem connecting to x.x.x.x, you do not have permission to access this server"



smb://COMPUTERNAME;USERNAME:PASSWORD@x.x.x.x/Shared (As above without quotes)


"There was a problem connecting to x.x.x.x, you do not have permission to access this server"


smb://x.x.x.x/Shared


Brings up a window saying enter your username and password for the server. I put the username and password in, hit ok and either the box just shakes, or it says:


"There was a problem connecting to x.x.x.x, you do not have permission to access this server"


smb://x.x.x.x/


Brings up a list of available shares on the server. I select one. Brings up a window saying enter your username and password for the server. I put the username and password in, hit ok and either the box just shakes, or it says:


"There was a problem connecting to x.x.x.x, you do not have permission to access this server"




Is there a bug with OSX and SMB shares? I Cannot get it to open ANY SMB share on any machine. I've tried windows 7, windows 2003, windows 2008 and windows XP. I Always get the same result. "You do not have permission to access this server" regardless of what authetication credentials I put in, whether they are correct or purposely incorrect! I've tried using domain accounts, local accounts, specifying domains, computer names, forward slashes, backslashes, escaping backslashes with forwardslashes and vice versa; I just cant get it to work. Ever.


The MBA even sometimes detects SMB shares in the finder, but when I click on them it just will not work. No matter what I put in the "connect as" box. I have the same issue. You do not have permission.


Ive been searching for some time on this and found all sorts of posts about various problems with SMB sharing, but none that seem to directly relate to my issue. Most of it seems to be about accessing SMB shares on a mac server thats part of a W2k8 domain, or other, slightly different issues. I've found nothing yet that seems to just be someone having issue with SMB shares not working full stop, across any operating systems.


One thing I haven't tried is mapping an SMB share to my ubuntu VM, this may be worth a try for interests sake - but I still want to be able to open an SMB share through the finder like I should be able to!


Has anyone else experienced this incredibly frustrating issue? Excuse my lack of diagnosis on this as well; I've been a network/sys administrator for ten years now but have only owned my MBA for a few weeks and my osx knowledge is extremely shoddy. I haven't checked any logs because I don't know where they are :)

 

There are some workarounds for SMB filesharing problems in Lion listed here: www.macwindows.com/lion-filesharing.html


There were a number of approached that worked for some people. One is to set "streams=no" in the nsmb.conf file.

 

Streams = no did not work.

 

I am still able to map using the CLI but not the gui. It just says you do not have permission to access this server still.


 

I'd love it if someone here can point me in the right direction, this is incredibly frustrating.

MacBook Air, OS X Mountain Lion (10.8.2)
  • paulbeard Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 8, 2013 7:10 PM (in response to Delarado)

    I found this while looking into a different issue but what you're trying to do should be easy.

     

    smbutil view //user@server should ask for the authentication and then show you the available shares.

     

    Logs are in /var/log as on most (all?) UNIX variants.

     

    Can you access the shares any other way?

  • RodneyW Level 4 Level 4 (3,030 points)
    Currently Being Moderated
    Jan 9, 2013 4:28 AM (in response to Delarado)

    This doesn't solve your issue - but I have no problem connecting to Win 7 SMB shares on my MBP from Finder.

     

    It seems to me that you have an authentication issue of some kind - possibly a firewall setting on your Mac (? long shot).

  • etresoft Level 7 Level 7 (23,870 points)
    Currently Being Moderated
    May 21, 2013 5:07 AM (in response to Delarado)

    It sounds like your local permissions are all messed up. Try running Repair Permissions in Disk Utiltiy.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.