2 Replies Latest reply: May 22, 2013 11:33 AM by RRepsaj
RRepsaj Level 1 Level 1 (0 points)

Hello - I have Mail as my 'Default email reader' in Mail's Preferences. It works as expected except when I select an email from a Spotlight search. I then get, by default, Outlook.

 

Any idea how I can get emails that Spotlight finds to open with Mail pls?

 

Thanks!


iMac, Mac OS X (10.7.5)
  • 1. Re: Spotlight selects the wrong default mail client :(
    Carolyn Samit Level 10 Level 10 (89,640 points)

    Try deleting the assocaited Spotlight preference file.

     

    Open a Finder window. From the menu bar click Go > Go to Folder

     

    Type or copy paste the following:

     

    ~/Library/Preferences/com.apple.spotlight.plist

     

    Click Go then move that .plist file to the Trash.

     

    Restart your Mac.

  • 2. Re: Spotlight selects the wrong default mail client :(
    RRepsaj Level 1 Level 1 (0 points)

    Thanks very much for the advice Carolyn but I'm afraid that it didn't change anything for me (Spotlight still gives Outlook as the default mail client, even tho' Mail is the real default).

     

    FWIW, my employer (who owns my iMacs) runs on an Outlook Exchange server. I'd be surprised if that was something to do with this but I'm pretty much stumped otherwise.

     

    Cheers, Jasper