Skip navigation

iCal picks wrong calendar for invites - how do I change that?

9776 Views 20 Replies Latest reply: Apr 3, 2014 5:23 AM by keithdoc RSS
  • vkbs Calculating status...

    ical takes the first account mentionned in the settings/accounts. It's sorted alphabetically. I just renamed the account which I wanted as default so it was first in the order.

  • Mitra Earth Calculating status...

    I have the same problem, but in my case the solution was to log into icloud and drag the calender to the BOTTOM not the TOP as suggested in other posts. (inconvenient of course)

     

    Its a bug obviously, since OSX-preferences has a place to define the default calender, but equally obviously noone from Apple monitors these forums or anywhere else you could report a bug :-(

  • hallpower Calculating status...

    @apple:

     

    Same problem.

    I only have one Exchange and two Google Calendars setup.

    Renamed the Exchange to appear first in Settings.

    Defined the Exchange Calendar as Default.

    None of these calendars appear online in iCloud, so I couldn't change any preferences there.

     

    When I click on an ICS file in my Exchange mail account, it opens the invite in Calendar using my Google Account. When I right-click the event, I can only move it to the second Google account. When I drag the event to my Exchange calendar, the event is duplicated in Exchange (without the Accept/Reject options). From there, if I try to delete the original Google invite, I'm asked if I'm sure I want to decline the event.

     

     

     


  • kmcital Calculating status...

    Didn't solve for me using iCloud. After a long time of searching plists, settings, etc. I finally found that when I reordered my calendars on iCloud, then the meeting invite would be created in different calendars.  Strangely I found that the "default" meeting invite calendar (when receiving an invite attachment via email) is stuck to go to the 3rd position on my calendar list in iCloud. Whichever calendar was third down on the list, would get the meeting.  I played around for a long time reordering them, hoping it would clear out some bad setting, and hoping it would adhere to either the default calendar setting or the alphabetical rule or the first in the list rule...but in the end, I just put the calendar I wanted as the default meeting invite recipient in the 3rd slot.

  • seb100 Calculating status...

    when having all calendars in icloud, running ML, moving the desired calendar to the BOTTOM of the list in icloud solved my problem. thanks!

  • keithdoc Calculating status...

    I have same issue - Exchange work calendar invites are automatically accepted from mail.

    My exchange work calendar is NOT iCal, so there is no way to move it to the top of the list.

     

    The ONLY workaround I've found is to accept them from iOS device (they work perfectly, and update appropriately). 

     

    I changed the setting in mail to "Add invitations to Calendar", set to 'never'.

    As long as Calendar has the exchange account set to refresh, they will show up (changes too).

     

    Crappy workaround - CMON Apple.  Fix this, please!!!!!!

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.