Skip navigation

Shared iCloud calendar notification problems

36630 Views 94 Replies Latest reply: Apr 4, 2014 1:56 AM by roccit RSS
  • csxjgf Calculating status...
    Currently Being Moderated
    Apr 15, 2013 12:41 PM (in response to BeauChevassus)

    Hi Beau,

     

    Your solution works for emails, but unfortunately it doesn't prevent notifications from shared calendars.

     

    Living in hope that it gets sorted out at some point...

  • kthersh Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 15, 2013 12:47 PM (in response to drainsdigest)

    Anyone have an update on whether this is planned to be fixed or not?

  • ozcarwylde2 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 15, 2013 1:16 PM (in response to BeauChevassus)

    Thanks for taking the time to post Beau. I have tried this many times.. It is still a big fail!.. Thanks tho, keep the suggestions coming, cos Apple isn't.

  • BeauChevassus Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 15, 2013 1:55 PM (in response to csxjgf)

    Ah man, lame it didn't work for you?  (I'm so sorry!) 

     

    Quick clarification: When you say "notifications," do you mean the little red number on the iPhone's Calendar App icon? 

     

    E.g. Screenshot:

    invitation-notifications.png

     

    If that's what you mean by notifications, I turned those off on my shared calendar (on my iPhone) by going to:

    • Settings > Mail, Contacts, Calendar. > [Scroll down the very bottom] Turn off "Shared Calendar Alerts."
      photo2.png

    • Then I went to Settings > Notifications > Calendar > And turned the "Notification Center" off, along with all the Alert Styles, and Badge App Icon to "off" as well... basically everything because I don't really want to be bothered with little red number.

     

    E.g. Screenshot:
    calendar-notifications-1.jpg

     

     

    Hope it works for you as well!

     

    All the best,

     

    -Beau 

    YouTube.com/Beauch

  • kthersh Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 15, 2013 2:00 PM (in response to BeauChevassus)

    I don't want to entirely remove calendar from the notification center, just the shared calednars.

  • willarr Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 15, 2013 3:23 PM (in response to BeauChevassus)

    I'm not sure this is the same thing the OP is talking about. Regardless, I am *still* receiving email update notifications and this feature is turned off. When we originally set up the calendar when iCloud was first released, the individual calendar had the option to turn off emails. My wife never had emails sent to her. I did. Now, that option is no longer available at the individual calendar level. She still doesn't receive emails, but I still do.

     

    My settings look just like yours, Step 4 box is unchecked. I get emails everytime a new item is created or an old item is updated.

  • brycefrommn Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 18, 2013 6:46 AM (in response to drainsdigest)

    Hi folks, I like the way google handles viewing/sharing calendars way better, but I have been able to find a pretty decent solution: I subscribed to the calendar instead of "join" the calendar. I had the person send me their calendar's public subscription url instead of "inviting" me to the calendar. Then, I am able to remove alerts, and, if de-selected, it doesn't show up in the notification center on mac or on iphone/ipod.

     

    The cons: I don't think I can add events to that calendar, but I was willing to give that up so I could enable/disable alerts and notifications.

  • Soepi Calculating status...
    Currently Being Moderated
    Apr 29, 2013 5:26 AM (in response to BeauChevassus)

    @Beau: You are absolutely right that the action in your second screenshot SHOULD fix the problem. However, checking or unchecking the option: "Shared Calendar Alerts" does NOT do ANYTHING.

     

    icloud.com: Changing the notifications from on to off for calendar has NO EFFECT.

     

    iCal on OS X 10.8.3: Rightclick shared calendar and check "ignore notifications" and uncheck "activities influence availability" has NO EFFECT.

     

    The problem is with apple, they have to fix the options that are allready available. So put your settings in the way that has been suggested extensively and just wait till the problem is fixed (I would not hold my breath, since this will result in certain suffocation)

  • strethamhouse Calculating status...
    Currently Being Moderated
    May 21, 2013 12:43 PM (in response to drainsdigest)

    Hi Guys,

     

    My problem has got worse. When the calender alerts started on my partners iphone when she was at work she pressed all sorts of selections to try and stop it. The result is that I can't seem to get rid of her shared calender on my iphone, ipad, mac and macbook. I delete them and he presto they come back. I have switched it off on her phone but it makes no difference. I have also lost calender synching on all my devices.

     

    Any thoughts?

  • gordiefan Calculating status...
    Currently Being Moderated
    May 21, 2013 7:12 PM (in response to strethamhouse)

    Go to icloud.com click on the calendar, go to the settings icon on the upper right corner of your calendar, select preferences, click on the advanced button, uncheck the email shared updates.  This will remove you getting updates on your shared calendar.

  • sflomenb Level 1 Level 1 (40 points)
    Currently Being Moderated
    May 21, 2013 7:14 PM (in response to drainsdigest)

    I recommend going to your calendars, making new calendars (one for each calendar that you're having problems with) and copy all of the events to the new calendars, and then delete the old ones.

  • ozcarwylde2 Level 1 Level 1 (10 points)
    Currently Being Moderated
    May 22, 2013 1:46 AM (in response to gordiefan)

    Thanks for replying... but as you will see reading through this thread... most have done all the 'usual' so called normal soloutions...  this does not work... be that in iCloud, on the Mac, or IOS device...

  • ozcarwylde2 Level 1 Level 1 (10 points)
    Currently Being Moderated
    May 22, 2013 1:48 AM (in response to sflomenb)

    Thanks for the for suggestion. If I had one calendar with a few events. However we have several calendars with thousands of entries, just not a feasible option.

  • ozcarwylde2 Level 1 Level 1 (10 points)
    Currently Being Moderated
    May 22, 2013 1:52 AM (in response to BeauChevassus)

    Thanks again but this soloution then disables ALL notifications, that is not what we want. We would like to see the notifications for our events but not the 'shared calendar' events. On all devices, macs and iCloud the 'shared calendar notifications' are switch to the OFF mode, and we are still getting the alerts.... it is very annoying...

  • AMCarter3 Level 1 Level 1 (5 points)
    Currently Being Moderated
    May 22, 2013 1:13 PM (in response to ozcarwylde2)

    I agree with ozcarwylde2... literally all of the current "solutions" proposed have been tried by others multiple times on this thread.

1 ... 3 4 5 6 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (16)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.