8 Replies Latest reply: May 23, 2013 9:50 PM by LarryHN
HRR Level 1 Level 1 (0 points)

The Iphoto is version 2008 but it won't let me upgrade to a newer version.


IMac, Mac OS X (10.0.x)