Skip navigation

Aperture 10.8.3 library upgrade database inconsistency?

696 Views 8 Replies Latest reply: May 25, 2013 9:15 AM by woowooz RSS
woowooz Calculating status...
Currently Being Moderated
May 22, 2013 8:43 AM

After updating to Aperture 3.4.4, I am unable to update vaults from either of my two Aperture libraries.  A warning reads "An inconsistency in your database has been detected.  The application will now quit, relaunch, and restore your database to a consistent state.  This may take some time."  In fact, that does not happen (waited 12 hours).  I have gone through all three levels of Library first aid with no joy.  Libraries are 288 GB and 128 GB.  Is there a fix?  Should I delete the vaults and set up new ones, or is the problem with my Aperture libraries themselves?

Mac Pro, OS X Mountain Lion (10.8.3)
  • sheila_m. Community Specialists Community Specialists (3,060 points)

    Hello woowooz,


    I would be concerned about an error like that coming up repeatedly.  If you are getting this with both of your Aperture libraries, it sounds like it is not a library issue.  I found an article with steps that you can follow to troubleshoot library specific, user specific, and system-wide issues with Aperture:


    Aperture 3: Troubleshooting Basics


    You can skip the steps to restore your library from a backup and the Aperture Library First Aid, since it doesn't seem to be a library issue (because it's happening with two separate libraries).



    Sheila M.

  • Kirby Krieger Level 6 Level 6 (11,550 points)

    After running "Repair Database" or "Rebuild Library" your Libraries are likely to be in the best shape Aperture can put them, and should be reliably usable.  If I understand correctly, you have already run both commands on each Library.  Please confirm that this is the case.  My experience tells me that, as you may have guessed, the problem is best addressed by deleting your Vaults and using Aperture to create new ones.  Note that deleting your Vaults may take more than one step.


    You might consider using a back-up program instead of using Aperture's Vault feature.  Both Carbon Copy Cloner and SuperDuper are easy to use and recommended for many other reasons as well.  Aperture's Vault feature is just a built-in back-up program.  Any back-up program can meet your need as well as the Vault feature (and may work better).


    One thing that worries me, though, is when you say:


    In fact, that does not happen (waited 12 hours).


    What, specifically "does not happen"?  How did you determine that it did not happen?  Most importantly, did you then force-quit Aperture?


    Message was edited by: Kirby Krieger -- first sentence fixed.

  • Kirby Krieger Level 6 Level 6 (11,550 points)

    Hi Sheila.  The OP states:


    I have gone through all three levels of Library first aid with no joy.


    The three levels are Repair Permissions, Repair Database, Restore Database.  These are, of course, detailed on Apple's Aperture Trouble-shooting page, to which you linked.  I have asked the OP to confirm that this is what s/he meant when specifying having gone through all three levels of Library first aid.



  • Kirby Krieger Level 6 Level 6 (11,550 points)

    woowooz wrote:


    What is an "OP"?

    OP=Original Poster, i.e.: the thread-starter. 


    You seem to have untangled the mess.  You should not force-quit Aperture.  I have _never_ seen Aperture not finish a task (it may crash, and your system may crash, but as long as Aperture is running -- in spite of Activity Monitor or the Force Quit dialog reporting Aperture as "Not Responding" -- it always finishes what it is doing.  The problem is that this may take scores of hours.


    Any time you force quit Aperture you should run "Repair Database" before using the Library.  Force-quitting leaves your Library in an indeterminate and likely damaged state.  I would not use any Library that cannot or has not been let to finish "Repair Database".


    Since you own and are familiar with SuperDuper, I recommend you use that and stop using Aperture's Vault feature.  I ran into trouble with Vaults a few minor revisions of Aperture ago (that problem was, afaik, fixed), switched to using SuperDuper, and have not had any problems.


    Your problem may have happened when you upgraded, but could have been triggered by an unknown error in your database.  For that reason it it strongly recommended that everyone run "Repair Database" on all Libraries prior to upgrading.  (NB: this may be done by some of the upgrades.)



  • léonie Level 8 Level 8 (46,330 points)

      I had always been reluctant to "Repair Database". fearing it might screw something up and will do that in the future prior to upgrades.




    "repair database" and "repair permissions" are routine maintainance operations, perfectly safe to use.

    They will check the permissions and the integrity of the internal databases and fix minor glitches. Only it may take some time, if your library is large.

    I use these tools routinely to ensure my library is in perfect working condition before any major operations, like updating the library to a new Aperture version or moving it to a new location.


    The third fix "rebuild library" will do a major reconstruction of the library, and if the library is already badly damaged it might make matters worse. It is highly recommended to check the backup of the library, if it is up to date, before rebuilding.


    I could not do a restore from my SuperDuper Clone because it runs nightly and had already cloned the problematic libraries before I realized there was a problem.

    I second Kirby's advice to use clones instead of the vault.

    Just one more thing to add: Clones and vaults are only snapshots of one moment in time, and if you update your clone or vault you cannot go back in time. I include my Aperture library into my regular TimeMachine backup, so I can go back to previous versions, if need be, in addition to the clone.

    In total I have three backups of every library.

    If you do not have at least two backups, go for it. Your system may fail, when you are backing up, and both the backup and the computer may be damaged. This happened to me during a bad thunderstorm, when a lightning stroke close to our house and caused a power failure. I was very happy to have a second backup, on a drive that had not been turned on at that time.


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.