1 2 3 4 Previous Next 54 Replies Latest reply: Mar 5, 2014 2:51 PM by TheCoodu Go to original post
  • 30. Re: Ownership Enabled Question
    kstc Level 1 Level 1 (15 points)

    But what if you try the above things and you still do not see the option to ignore show up?

     

    It seems as though the partition map scheme of my drive is Apple Partition Map. Is there any hope then?

    I would assume GUID has a bit more control over permissions than the lowly Apple Partition Map.

    The drive is a client of mine that bought it last year. Way to go LaCie.

    Who the heck still uses OS9?

    LaCie fail.

    Just like there enclosures. The bridge always fail. The drives are usually ok, thanks Hitachi...Wait, the drive inside the LaCie is a Toshiba, the LaCie box says they use Hitachi. fck sakes.

     

    lmao and going into the latest alias folder for the backups and copying it by hand.

    Client will have to punt. They will not be able to browse for their files but at this point they have

    their data.

  • 31. Re: Ownership Enabled Question
    cbucbu Level 1 Level 1 (0 points)

    I have tried all of the suggestions listed above which include

    - clicking on my external hard drive, going to finder and then selecting get info - nothing.

    - right clicking on it directly and go to get info - nothing

    - unlocking the padlock and tried to scroll down - nothing

    - changing all of the sharing permission people listed as suggested - nothing

    - going to terminal and typing sudo /usr/sbin/vsdbutil -a /Volumes/NAME OF YOUR DISK - can't type in terminal, it won't let me when I'm promted for a password

    - switching off and leaving for a day, trying again - nothing.

     

    I'm feeling very frustraited as I have already used this external drive to make a copy of my time machine. 

     

    Any other ideas???

    Please help me!!!

  • 32. Re: Ownership Enabled Question
    Vampyrvet Level 1 Level 1 (0 points)

    I had to reformat my computer and reinstall the OS.  I want to save my last few months' of Time Machine backups.  I had the same problem with ownership as other users in this thread.  I was not allowed to move any of the backups out of the "Backups.backupdb" folder. 

     

    I found that if you move the folders containing the individual TM backups to the Trash (it warns you that this can't be undone, do it anyway), then move the folders from the Trash to your alternate destination, this is how you can circumvent the ownership restriction.  Apparently the act of moving the backups to the Trash releases the safeguards, and then you are free to move them anywhere you want.

     

    Just be aware that this is an extremely lengthy and time-consuming process.  But if it's the only way to reclaim your data, it might be worthwhile.

     

    Hope this helps

    Natalie

  • 33. Re: Ownership Enabled Question
    rudsteruk Level 1 Level 1 (0 points)

    For those people that don't have ownership option.  Just paste this into Terminal replacing APEX with your destination drive name...

     

    sudo diskutil enableOwnership APEX

     

    simples

  • 34. Re: Ownership Enabled Question
    WillowTVP Level 1 Level 1 (0 points)

    After all the explanations...this one worked.  Thanks for your expertise Alex.  I found it on the drive I wanted to transfer to, as you explained.    Brilliant. 

  • 35. Re: Ownership Enabled Question
    kstc Level 1 Level 1 (15 points)

    Glad this option came up and it worked for most people who didn't realize they were restoring to a previous Time Machine hard drive. I think the problem that exists is what if the drive was a new drive or recently formatted drive and you do not have the ability to change ownership?!?!?

     

    In my case the format of the drive revealed that Apple Partition Map was the issue and formatting to GUID was able to change ownership on the drive after reformatting.

  • 36. Re: Ownership Enabled Question
    Jpierce Level 1 Level 1 (0 points)

    ^problem solved

  • 37. Re: Ownership Enabled Question
    supraru Level 1 Level 1 (0 points)

    Thank you for this. Solved.

  • 38. Re: Ownership Enabled Question
    miller_tv Level 1 Level 1 (0 points)

    PERFECT, thanks!

  • 39. Re: Ownership Enabled Question
    betababe Level 1 Level 1 (0 points)

    Thanks so much! Solved my problem.

  • 40. Re: Ownership Enabled Question
    ADH69 Level 1 Level 1 (0 points)

    Thanks! This helped me with a similar problem.

  • 41. Re: Ownership Enabled Question
    Klaus Blume Level 2 Level 2 (305 points)

    You are my man,

     

    Thank you

  • 42. Re: Ownership Enabled Question
    laisony Level 1 Level 1 (10 points)

    Because of the postings on this discussion I was able to do this.

    At the risk of being repetitive this is what happened to me.

     

    I wanted to use a new external drive for my Time Machine backups.

    When I unlocked the "Get Info" Window on the newly formated drive

    then the option to [Ignore ownership on this volume] was displayed at bottom of Get Info Window

    The box could be checked and unchecked.

     

    While the box was unchecked I copied all my previous Time Machine Backup Files from the old drive to the new drive. Still the "Ignore ownership..." box could be checked and unchecked. I left it unchecked.

    Then in Time Machine Preferences I selected the new drive as a backup disk.

    After that I wanted to see if the box could be selected and unselected as before. But when I checked the box for [Ignore ownership on this volume], the box and text disappeared.

     

    The old external drive that was previously used for backups was not displaying "Ignore ownership..."

    After I erased the old drive [Ignore ownership on this volume] was displayed on the "Get Info" window after I clicked the lock and unlocked it. Then on the old drive "Ignore ownership..." could be selected and unselected.

  • 43. Re: Ownership Enabled Question
    mysticfaucet Level 1 Level 1 (0 points)

    A luddite question: Where can I find Terminal in order to do the following:

     

    "For those people that don't have ownership option.  Just paste this into Terminal replacing APEX with your destination drive name...

    sudo diskutil enableOwnership APEX"

     

    Thanks.

  • 44. Re: Ownership Enabled Question
    gregarious47 Level 1 Level 1 (0 points)

    Alex, thanks so much for straightening this out. I just enabled the destination drive and, whoopee!, files being copied.