Skip navigation

iTunes Annoyance

3480 Views 5 Replies Latest reply: Jan 3, 2014 10:19 PM by mcandre RSS
capaho Level 4 Level 4 (3,650 points)
Currently Being Moderated
Jul 10, 2012 6:00 PM

Whenever I connect my Bluetooth headphones to my MBP iTunes opens automatically and starts playing music.  It's a nuisance I don't need but I can't find the setting that is responsible for this.  Does anyone know how to disable this "feature?"

  • lmiller287 Calculating status...
    Currently Being Moderated
    Mar 22, 2013 7:59 AM (in response to capaho)

    Same thing happens to me when I use my Bluetooth Jaybird earphones. This setting change seemed to fix my problem. Are they going to fix this bug?

     

    I mean, earphones arent really a cd... haha

  • Wolf Harper Level 1 Level 1 (40 points)
    Currently Being Moderated
    May 28, 2013 1:12 PM (in response to capaho)

    None of that works for me.  I've tried every suggestion I've seen here and elsewhere on these forums.  Nada. I've even tried upgrading from OS X 10.6 to 10.8.  There are several other events which will also launch iTunes and autoplay, always to my great annoyance.

     

    I did write a perl script (posted in another thread) that kills iTunes when it tries to launch, that's the closest I've found to relief.  If it wasn't for that, I'd have removed iTunes entirely. 

     

    It's even worse on my iDevices.  Those have crossed the "annoyance event horizon" and I just removed all my music.   Isn't that awful?  Thank God they tore podcasts off into a separate app.  Genius idea, make podcasts out of all my albums.

  • sdchallis Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 30, 2013 7:37 AM (in response to capaho)

    I have found a good workaround to this. Download the app Event Scritps. This allows you run scripts based on events. So when bluetooth device connects quit itunes. I have actually selected the option to quit itunes when itunes launches becasue i never use itunes. works well. Make sure itunes isn't going to open in fullscreen mode to ensure it doesn't bother you at all.

     

    Steve

    MB Air 2012

    Plantronics Voyager pro

    latest version of Event Scripts

  • mcandre Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 3, 2014 10:19 PM (in response to capaho)

    There is no such setting post-Lion (e.g., Mavericks), especially on Macs without CD/DVD drives. Is there another way to disable this annoying iTunes behavior?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.