Skip navigation

Mac Mail Sent emails disappear and re-appear

29195 Views 44 Replies Latest reply: Feb 27, 2014 11:18 AM by slipman625 RSS
  • neilgoblue Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 5, 2011 6:12 PM (in response to martini27)
    I have the exact same problem on my 24 inch Imac. If I exit our of apple mail and then send a message it works, but if I then send another message it doesn't work. If I exit out of Apple Mail each time, i can send the messages each time.

    I also have a macbook pro and 27 inch imac with the same imap email account and there are no problems with either of them.

    HELP!
    Mac OS X (10.6.3)
  • Doug Jorgenson1 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Feb 7, 2011 10:38 PM (in response to martini27)
    This just happened to me tonight. Read a message from Zappos.com on my iPhone (confirming my order). Launched Mail on my iMac and the message is nowhere to be found. I've check my Junk mail folder and it's not in the Trash. I didn't delete it from the iPhone, plus my trash is set to only delete message that are a week old. The e-mail from Zappos.com was sent yesterday. This isn't the first time this has happened. I'm getting a little frustrated, not knowing if I've missed or lost important messages.
    2.8 GHz Intel Core i7, iPhone 4, Mac OS X (10.6.6), 8 GB, ATI Radeon HD 4850
  • DarrenBrackett Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 19, 2011 3:33 AM (in response to martini27)
    I have the same problem - seems to be with larger emails (with attachments). Sent emails don't appear in sent folder - almost routinely now, when before just on occasion. GoDaddy ISP. Preferences to delete sent - "never." Save messages on server - but has not done this since March 31 then abrupt stop.

    Also have the ridiculous and well documented issue of the draft folder spontaneously populating with old or duplicate emails. Been happening so long, I just accept it (sad). But, this sent email issue is not one I will be able to tolerate for long.
    MacAir, Mac OS X (10.6.6)
  • TBMor Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 22, 2012 2:39 PM (in response to DarrenBrackett)

    Same thing with me. I have gmail and mac mail accounts. Everything worked fine with both (sending/receiving/saving) until about 2 weeks ago. Suddenly no mac mail. Checked all settings, couldn't find anything odd. This lasted about 2 (frustrating!) days. Then when I opened one morning, my mac mail was back. BUT.... the only mail that shows up in my 'sent' folder is what I send through my gmail account. Oh... except for about 10 random mac mail messages that I sent several days ago (just a few on one particular day). I seem to have lost hundreds of sent messages - and that is not good.

  • machanno Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 22, 2012 1:18 PM (in response to TBMor)

    I have the same problem - seems to be with all emails (with attachments) that I send from my .mac account. Sent emails don't appear in sent folder (but they do get sent!).  Preferences are set for delete sent - "never." Save messages on server. If I hit the "replied mail icon" it gives the following message: "mail was unable to find your reply to the message "<message subject>". You may have deleted the message". This is bull ! It has been going on since several weeks now. I did not yet convert to the cloud and I consider not doing this at all but completely convert to gmail !!!

     

    When I use my gmail account, everything works fine. When I use Sparrow or Thunderbird everything works fine. I tried deleting my .mac account and re-configuring it: no result, sent mail disappears. So it must be the Apple mail app. APPLE! this has been going on for weeks!!! What's your cure ???

  • EllieS Level 1 Level 1 (15 points)
    Currently Being Moderated
    Apr 11, 2012 8:13 AM (in response to machanno)

    I have the same problem with occasional sent messages disappearing in Apple Mail - hate it! I've devised a workaround that maybe others could use too, at least until the issue gets resolved by Apple (if it ever does).

     

    For every email I send out that I want to make sure to have a copy of, I BCC it to myself. That way it comes back to me in my inbox and I can save it to my sent folder if I want to. Using BCC rather than CC assures me that no one else can tell what I'm doing!

  • Reasonable55 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 11, 2012 7:38 PM (in response to EllieS)

    I just started having the exact same problem.  I use a paid Yahoo personalized e-mail account.  I also use iPhone iOS5.1.1 and iPad2 iOS5.1.1 (both the latest builds), and just last week changed my Mail client on my MacBook Pro (v. 10.7.4) from using the POP3 settings with Yahoo to using the IMAP settings instead, and then it started to happen - every so often it will take an extra long time to send an e-mail (even a very short e-mail with no attachments) and then nothing in the Sent Folder.  Some of them have been important e-mails, and I really hate not knowing if they have been sent or not, and I also hate not having a copy in my Sent Folder.  I'll start using the bcc to myself or I'll just revert back to a POP3 configuration, but I agree with others, this is 2012 and Apple can't provide a reliable Mail app?  Come on Apple - no excuses!!!!

     

    One final note:  On one ocassion last Friday late afternoon, after about 30 minutes, the "sent" (really a disappeared message) message appeared as if by magic in my Draft folder.  What's that about?

  • sugus Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 10, 2013 11:46 AM (in response to Reasonable55)

    I have the exact same problem as Reasonable55 describes above.  It started after changing my ATT Yahoo account in Mail from POP to IMAP.  Here are some of my settings from Mail Accounts preferences:

     

    Account Information tab:

    Incoming Mail Server:  imap.mail.yahoo.com

    Outgoing Mail Server (SMTP):  smpt.att.yahoo.com:myname@bellsouth.net

    Use only this server - box is checked

    TLS Certificate: - None

     

    Advanced tab:

    IMAP Path Prefix: This field is blank

    Port: 993

    Use SSL - box is checked

     

    Do these settings look ok?

  • Tiago Cardoso Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 15, 2013 6:07 AM (in response to martini27)

    Having the described problem. Sent a huge text email. I can't find it anywhere and I'm not sure if it was received.

     

    I feel like swearing... A lot...

  • Kruegmeister Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 18, 2013 11:49 AM (in response to martini27)

    I have this usually when I typed a REALLY long email so it can really Pi$$ me off....

     

    THIS IS NOT A NETWORK ISSUE. But way to point the Finger...

     

    It happens on lots of different Networks randomly. Work, Home, Customers.

    Perhaps if their was an Outgoing Box that messages could go into as they are being sent.

    Then the Failed message could be selected and hit "Re-Send this Message"

    This feature is in Outlook, Thunderbird, etc...

     

    I am using an Yahoo Businness Email. Also using IMAP.

    I guarantee my settings are correct cause Outlook, My Android Phone, My Old Android Phone, my iPad, my Old Android Tablet. NONE of them have a problem with the IMAP settings. Just Apple Mail.

     

    Please Fix this and Stop Blaming peoples Network.

  • sharon275 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 2, 2013 11:27 AM (in response to neilgoblue)

    mac Mail program .... sooo frustrating.  I have iMac OS 10.8.3.  Mail disappears randomly.  Maybe there's a pattern ... I don't have timne to chase it.   Nowhere to be found.  Not in Sent, not in Trash, not on the server ... FIX THIS!!!

      PLEASE

  • Figaro\'s Cat Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 29, 2013 3:21 AM (in response to martini27)

    Same issue here (may 2013!)

     

    1. I've got used to make a copy of every message before sending.

     

    2. After sending Ihave to check, wether the message really went out.

    3. If it didn't I use my copy to try again.

    4. Then I go back to Step 2

     

     

     

    Well, I guess I'll soon start writing letters again, is probably more comfortable and more efficient...

  • Kruegmeister Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 10, 2013 7:03 AM (in response to martini27)

    Looks like Mail 6.5 that came with 10.8.4 fixes this problem.

    Simple as adding a Permanent Outbox.

    Thank You Apple!!!!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.