Skip navigation

Time Machine seems to run continuously...

514 Views 11 Replies Latest reply: May 31, 2013 6:55 PM by Pondini RSS
ChicagoAl Calculating status...
Currently Being Moderated
May 27, 2013 10:39 AM

Hi all.

 

I see a lot of Time Machine questions and they get into the dozens of replies, many of them getting into many other issues, other OSs, etc, so please forgive me for starting another discussion.

 

I don't know when it started, it could have been as of a recent update or change, but lately Time Machine seems to run almost continuously on my Mac Pro.  I am running OS 10.6.8, backup is to an WD 1TB drive via FW800.   It has always worked fine and I've never needed to use the backup...actually there was one point a few months back when for some reason it stopped backing up.   Replugging the drive and restarting fixed that.

 

Right now it's 12:37 and TM is running, 'cleaning up,'  after a backup that it started at 11:43.  According to the TM Widget, it takes 55-56 minutes to do each backup, so it's running almost all the time.  It seems to slow the computer down considerably, too.

 

I can't copy/paste the Widget's text, but in each of the recent backups it records requesting 9.15GB or so of space, with 90. something GB available.  No pre-backup thinning needed.  Then it says that it's copying about 770 MB of files from each of my computer's drives. 

 

Then the log appears to say that it repeats the process. Only now it requests somewhat more space, 10.x GB, and it copies somewhat more from each drive.  Then it deletes a past backup (which seems to take a very long time) and is done.

 

This isn't normal, is it? 

 

Any help welcome.  I am looking at Pondini's pages but wow is there a lot to look at there!

 

Thanks!

MacPro, MBP, many Macs in the house, Mac OS X (10.6.8)
  • Pondini Level 8 Level 8 (38,710 points)
    Currently Being Moderated
    May 27, 2013 11:56 AM (in response to ChicagoAl)

    ChicagoAl wrote:

    . . .

    I can't copy/paste the Widget's text,

    Click in the message area, press Cmd+A to select all, then Cmd+C to copy to the clipboard, then the usual to copy and post it here.

     

    Unless there's a clue there, work your way through the green box in #D2 of Time Machine - Troubleshooting.  Unfortunately, there are a lot of things that can cause slow backups, and most don't leave any sort of "trail" that would identify them. 

     

     

    I am looking at Pondini's pages but wow is there a lot to look at there!

    Yup. 

  • Pondini Level 8 Level 8 (38,710 points)
    Currently Being Moderated
    May 27, 2013 6:56 PM (in response to ChicagoAl)

    ChicagoAl wrote:

     

    Okay, ran through the D2 procedures.   My TM backup is dedicated, so all I needed to do was a repair--appears to be okay--and repair permissions on the OS drive.

    Uh, all the things there?  Including #15 thru #17?

     

    Copied 68861 files (40.5 MB) from volume Alan's MacPro.

    Copied 68963 files (40.5 MB) from volume Video Storage.

    Copied 70398 files (40.5 MB) from volume Music & Pics.

    Copied 70426 files (40.5 MB) from volume Scratch Disk.

    You're having another known bug -- it reports the same amount backed-up from all volumes.

     

    Worse, it sounds like you have a rare problem, not so much with Time Machine itself, but with the File System Event Store, a log of changes OSX keeps on each disk.  Spotlight, Time Machine, and other processes use it to find out what's new or changed.  If that's damaged, it can slow down multiple processes, including Time Machine.  So far as we can tell, this occurs only on 10.6.8. 

     

    One possible fix is to reinstall Snow Leopard (without disturbing anything else), but only going back to 10.6.7.  See Installing the ''combo'' update and/or Reinstalling OSX.

     

     

    Or, sometimes, #16 in the D2 list will fix it, but if not, deleting the Event Store often does (but no guarantee, and it may reoccur).  In your case, with 4 volumes being backed-up, you'll have to do it on all of them to try it. 

     

    Open the Terminal app (in your Applications/Utilities folder). Be very careful with this app.  It's a direct link into UNIX, the underpinnings of OSX, but without the protections of OSX.

     

    In Terminal, the prompt looks like this:  <Computer Name>:~ <your name>$

     

    (where <your name> is your short user name).  It's followed by a non-blinking block cursor.

     

    Copy the following after the prompt:

     

    sudo rm -rf /.fseventsd


    and press Return. You'll be prompted for your Admin password (which won't be displayed).  Press Return again.  That will delete the log for your internal HD.  There's no completion message, just another prompt.

     

    Then, for each of the other 3 disks, copy this and leave a space, but don't press Return yet:

     

    sudo rm -rf

     

    Drag one disk from the Finder sidebar or desktop to the Terminal window. That will generate the "path" to the disk, inserting a back slash before each space in the name. 

     

    Then copy this, with no space after the path:  /.fseventsd     Then press Return.

     

    If you get an error message, copy the window and post it here.

     

    If not, run a backup.  The first one will take a long time, as Time Machine must compare everything on your most recent backup to all your data (since it can't use the Event Logs you just deleted).  You'll see "scanning nnnn items" on the Preferences window.

     

    Then run another.  With any luck, you'll just see a quick incremental backup.

     

     

    EDIT:  I should have mentioned, quit as many apps as you can before deleting the Event Stores.

     

    Message was edited by: Pondini

  • Pondini Level 8 Level 8 (38,710 points)
    Currently Being Moderated
    May 29, 2013 11:44 AM (in response to ChicagoAl)

    ChicagoAl wrote:

     

    Okay, I did the Terminal commands; got a reply of 'resource busy' on two of the drives.  However I exited Terminal and tried a backup, and it did seem to go much faster.  Now another auto backup has run, again it completed much faster.  

    Yay! 

     

     

    Here's the readout from the next backup.  Note that though it's going faster, it is still saying that the same size files must be backed up.

    Yeah, there's no fix for that on Snow Leopard, I'm afraid.    But it's just the messages that are bogus, as far as we can tell.

     

    It seems to be fixed on Mountain Lion.

     

     

    Any further advice welcome...does this look 'fixed,' or should I delete the Event Stores again?

    It may or may not be fixed permanently; some folks had it reoccur, some didn't.  It's quite mysterious.

     

    My suspicion is, it doesn't really have anything to do with Time Machine itself; some process somewhere is messing up the Event Store, affecting Time Machine, Spotlight, and any other process that uses it. 

     

    But the fact that it's so rare makes me think it's some 3rd-party app, but nobody seems to be able to pinpoint it.  If you're interested, here's a looooong thread about it, full of the usual sidetrackings, speculations, other problems, etc: https://discussions.apple.com/thread/3992838

  • Pondini Level 8 Level 8 (38,710 points)
    Currently Being Moderated
    May 31, 2013 5:31 AM (in response to ChicagoAl)

    ChicagoAl wrote:

    . . .

    I must have inserted...a space?...or something that caused it to go wrong. 

    Yup, that'll do it.   Adding a space after the slash means the entire volume, not just the folder named.  And with a hidden item's leading period, it's easy to miss.

     

    That's why I post it with this:

    Open the Terminal app (in your Applications/Utilities folder). Be very careful with this app.  It's a direct link into UNIX, the underpinnings of OSX, but without the protections of OSX.

    . . .

    Copy the following after the prompt:

    But I'll change it to Copy, do not type, in the future.

     

    After restoring one of the disks, TM attempted a backup, but failed as there is now not enough room on the backup disc

    Correct.  Everything you put back is treated as new, so will be backed-up again.  On Snow Leopard, there's nothing you can do about that (effective with Lion, there's a way to tell Time Machine to "associate" the erased disk with the old backups, but not before.  If you have access to a Mac running Lion or Mountain Lion, and can connect them in Target Disk Mode, you can do it from there).

     

    BTW very wierd that TM was reporting that it was backing up lots of files from the two drives that were now empty.

    Sounds like the bug where it reports the same amount from every drive.

  • Pondini Level 8 Level 8 (38,710 points)
    Currently Being Moderated
    May 31, 2013 6:55 PM (in response to ChicagoAl)

    ChicagoAl wrote:

    . . .

    There is considerably more free space on the TM volume, so there must have been a good bit of 'housecleaning' when the deletion of old backups occurred.

    Or the backups were large (ie, large items that had been changed or deleted long ago, and appeared on no recent backups).  And Time Machine deletes entire backups, not just backups of selected files or folders.

     

     

    Backups are not taking the near-hour of before, but 18-20 mins.  They don't seem to bog the computer down so much either.  The widget still shows the identical file sizes being copied but that's evidently NOT what is happening.

    Watch the "xxx GB of yyy GB" messages, and/or use one of the apps in #A2 of Time Machine - Troubleshooting to get a better idea. 

     

    But the backups really do seem small; look at the space available after the first pass (in the messages you posted); that looks like only about 50 MB was backed-up.    And the deleted one was about the same.

     

    And it does look like another part of the problem is still there -- the huge numbers of files reported.  That's always large (it seems like metadata gets counted separately), but not like that.

     

    This is a really strange one;  it only affects a few folks on 10.6.8, but nobody seems to be able to find the culprit (not that Apple would fix it) or a better workaround. 

     

     

    The only other workaround I know of is to reinstall Snow Leopard again, but only go back to 10.6.7.  That does expose you to a different problem, the 3rd item in #D5 of the above link.  Or, of course, upgrade to Lion, if your hardware will run it.

     

    I am wondering why it seems, just now, to have deleted a backup made only yesterday.  Of course there are a day's worth + that lack anything from the two volumes.

    Yes, that's normal.  After 24 hours, they're "thinned" down to one per day (the first);  after a month, to one per week:

     

    12a TM Prefs - thinning schedule.jpg

     

    The backups may very well begin to slow again in a few days, so you'll be back, or nearly back, where you were.  If you can't or don't want to go back to 10.6.7, or to Lion, you may want to consider alternatives.  That will be a bit more complicated with 4 volumes (you'll need 4 separate "tasks," and probably separate partitions for each one's backups), and it's usually not practical to run one on your OSX volume more than once a day, but it's worth considering.  See the green box in Time Machine - Frequently Asked Question  #27 for more info, links, and some suggestions.

     

    Sorry not to have better news.

     

    Message was edited by: Pondini

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.