9 Replies Latest reply: May 29, 2013 3:16 PM by wordzenpix
Rhea Gavry Level 1 Level 1 (0 points)

I am running Final Cut Pro X version 10.0.6 on Lion and it will not recognize update needed for 10.0.7 or 10.0.8 - Am I missing something here?  The App Store says I need the update but then when I attempt it it says that my aps are up to date.


Mac OS X (10.7.5), 2x3.2 GHz Quad-Core Intel Xeon