Skip navigation

iPhoto gets beachball for 20 seconds everytime I launch it :/ PLEASE HELP!

1358 Views 25 Replies Latest reply: May 29, 2013 4:47 PM by Old Toad RSS
  • Old Toad Level 10 Level 10 (113,450 points)
    Its odd that this only happens when im connected to the internet.

     

    Do you have any Google accounts?  If so bring up Safari's Privacy preference pane and click on the Details button. 

    Safari001.jpg

     

    In the next window search for Google and delete all of the Google cookies (you'll just be asked to log into your Google websites the next time you visit them).  Then launch iPhoto and see if there's any improvement.

  • victorvs Calculating status...

    Like Waterbottle, when ethernet cable is NOT connected to my mac (WiFi is off on my Mac) iPhoto launches quickly (~2secs) and without the spinning beachball and is immediately usuable. But

     

    when the ethernet cable is connected to my mac, the iPhoto window appears within 2secs showing the last Event or Album looked at when it was last opened, and about 5 seconds later the cursor switches from an arrow to the spinning beachball, and about 37 seconds after that (42 secs after launching iPhoto) it changes to the arrow key and iPhoto behaves normally. During the first 5 secs after launch while the cursor is still an arrow clicking on anything in the iPhoto window does nothing. During the time the beach ball is spinning the Activity Monitor displays "iPhoto (Not Responding)" and when the beach ball goes away, it simply lists iPhoto.

     

    It has not always behaved this way, but I didn't notice if this started before or after I upgraded to Mountain Lion (from Snow Leopard).

     

    MacBook Pro 17-inch, Early 2008

    Processor 2.5 GHz Intel Core 2 Duo

    Memory 6GB

    MacOS 10.8.2 (12C60)

    240GB Solid State SATA Drive 95.73GB free out of 239.2GB <- from OWC

    iPhoto version 7.1.5 (378)

    There are only 879 photos and 8 Events in the iphoto library. All the photos are .jpg files.

     

    I have spent a few hours reading thru similar reports here and elsewhere online and tried the following:

    • deleting iPhoto cache files

    • deleting iPhoto .plist files

    • creating a new blank iPhoto library, it behaves the same as my usual iPhoto library

    • Rebuilding (Command+Option launch) iPhoto : small thumbnails, all thumbnails, iPhoto Library database, recovering and removing ophaned photos, examine and repair iPhoto file permissions.

    • iPhoto Preferences>Sharing "Look for shared photos" and "Share my photos" are unchecked

    • MobileMe "Check for new photos": is set to Manually and was never set up nor used in the past

    • iPhoto is not subscribed to any photo feeds

     

    While doing all the above our Apple TV, iPad, and our iPhones were all off or asleep. I am not using any iCloud services with the computer or any of our devices.

     

    Because other iPhoto libraries including a new blank one behave the same way, I do not believe it can be a problem with the libraries. Because it launches and works without delay when the ethernet cable is not connected (and WiFi is off) and only delays with the beachball when the ethernet cable is connected, I suspect that iPhoto is looking for something on the Network <- what or why that might be I do not know...

     

    Suggestions / solutions appreciated!

  • victorvs Level 1 Level 1 (0 points)

    I have iPhoto Preferences>General "Check for iPhoto updates automatically" unchecked.

     

    I updated from Snow Leopard directly to Mountain Lion skipping Lion; but that isn't likely the problem since others have reported similar if not identical problems with earlier versions of OSX and later versions of iPhoto, e.g.:

     

    spinning beachball suddenly every time...: Apple Support Communities <- iPhoto 9.1.1 under Snow Leopard 10.6.7

    iPhoto 7.1.5 spinning wheel issue: Apple Support Communities <- iPhoto 7.1.5 under Snow Leopard 10.6.7

    2 min. spinning beach ball during...: Apple Support Communities <- iPhoto 8 and 9 OS 10.5, but turning off sharing fixed this one

  • Arvid Tomayko-Peters1 Level 1 Level 1 (50 points)

    I was having this problem too with iPhoto 7.1.5 in OS 10.8.3. I just gave up and upgraded to iPhoto 9.4.3 and the wait at startup is gone.

     

    iPhoto 9 has a few things that are annoying and make it a poorer workflow than iPhoto 7, but it also seems faster, more responsive, and it happens to get better color from my Panasonic GH2 RAW photos. I just miss the simple way iPhoto 7 dealt with fullscreen editing.

  • victorvs Level 1 Level 1 (0 points)

    Yesterday iPhoto delay was present, but oddly after installing the following three updates today:

    • OSX 10.8.3 - from 10.8.2

    • Airport Utility 6.2 - I use a hardwired ethernet connection and have WiFi turned off

    • Java for OS X 2013-003

    the problem went away and iPhoto 7.1.5 (378) starts up instantly again... See my Jan 5, 2013 post above for more about the Mac and software I use and which fixes I tried back then.

  • victorvs Level 1 Level 1 (0 points)

    Well that was short lived. After opening a few times without problem, when I opened it with the iPad connected it hangs with the beachball again. After disconnecting the iPad still hangs upon opening. Why it worked a few times earlier today is a reall mystery...

  • Old Toad Level 10 Level 10 (113,450 points)

    Try backing up the iPad and then do a complete reset and restore.  See if that will clear the air.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.