Skip navigation

Help: iMac won't boot past Grey logo screen with spinning lines

5917 Views 11 Replies Latest reply: May 30, 2013 6:49 AM by noepa RSS
Smack518 Calculating status...
Currently Being Moderated
Mar 22, 2011 6:32 PM
My fiance's iMac (intel based) running snow leopard (upgraded from Leopard a couple months ago) will not boot past the logo and spinning lines. This started after at attempting to restart after installing updates to Safari and iTunes.

When booting in verbose mode I get these lines:

Launchctl: Dubious permissions on file (skipping): /Library/LaunchDaemons
Launchctl: Dubious permissions on file (skipping): /System/Library/LaunchDaemons
Launchctl: Dubious permissions on file (skipping): /etc/mach_inid.d
AppleYukon2: Marvel Yukon Gigabit Adapter 88E8055 Singleport Copper SA
AppleYukon2: RxRingSize <= 1024, TxRingSize 256. RXMAXLE 1024, TXMAXLE 768, STMAXLE 3328

Then it just stops and does nothing.

I've unplugged everything except the apple keyboard and mouse. Ethernet is not connected.

She doesn't seem to have the original disc that came with the computer, but I do have the Snow Leopard upgrade disc.

What do I do? It won't boot in Safe Mode either, freezes at the same spot.

I'm not a particularly savvy Mac user as I recently embraced them when we moved in together.

Any help would be greatly appreciated
iMac (intel based), Mac OS X (10.6.7)
  • rkaufmann87 Level 8 Level 8 (40,500 points)
    Difficult to say but my guess is the HD has crashed. You should either get the original Install Disc that came with the machine or contact Apple to buy a replacement for a nominal cost. Once you have that you should run Apple Hardware Test to see if it does come back with HD error codes. The only place AHD is available is on the original Install Disc. IMHO your only other option is to take it to an AASP or Apple Store to be professionally diagnosed.

    Roger
    iMac 6 GB RAM, MacBook Air 4GB, 128GB SSD, Mac OS X (10.6.7), iPhone 3GS Airport Extreme Airport Express
  • rkaufmann87 Level 8 Level 8 (40,500 points)
    Smack518 wrote:
    Thanks for the quick response. Seems odd to have a hardware failure coincident with a software upgrade though isn't it?


    I've seen it happen several times.


    Well after I posted this I was able to get it to load from the install disk by holding Option during boot to get to the Startup Manager. From there I chose the DVD and I was able to get to disk utility and I'm currently "repairing permissions" there's a whole list of permissions it seems to be repairing. Not that I know what any of that meant. Said 8 minutes to go for a long time, then 20, now it's dropped to 10.


    This will explain most of the messages you get: http://support.apple.com/kb/TS1448


    I can hear it doing stuff so I'm going to let it run and see where it goes. I'll post if it fixed it. In the meanwhile any additional advice is appreciated.


    Lets see if Repairing Disc Permissions helps. You can also try to Repair the Disk as long as you have the Install Disk booted.
    iMac 6 GB RAM, MacBook Air 4GB, 128GB SSD, Mac OS X (10.6.7), iPhone 3GS Airport Extreme Airport Express
  • Eljefe25 Calculating status...

    What was the fix? My Mac book is doing the same thing and I've run the disk repair with no problems and the permissions repairs with no problems yet It's still doing the same thing.  I've also reinstalled original ram with no change.  Can the HD be bad and still pass all the utility checks? I don't want to try to reinstall the OS yet cause I have a couple weeks of stuff I didn't backup. 

     

    Any advice would be appreciated.

     

    Thanks,

     

    Jeff

  • MacFlurry Calculating status...

    Repairing permission is not the first answer. Should try to run fsck and reset the PRAM

     

    1. Start up your computer in single-user mode to reach the command line.
      Note: If necessary, perform a forced restart as described in the Emergency Troubleshooting Handbook that came with your computer. On desktop computers, you can do this by pressing the reset/interrupt button (if there is one) or holding down the power button for several seconds. On portable computers, simultaneously press the Command-Control-power keys. If your portable computer doesn't restart with this method, you may need to reset the Power Manager.
    2. At the command-line prompt type:

      /sbin/fsck -fy

    3. Press Return. fsck will go through five "phases" and then return information about your disk's use and fragmentation. Once it finishes, it'll display this message if no issue is found:
      ** The volume (name_of_volume) appears to be OK
      If fsck found issues and has altered, repaired, or fixed anything, it will display this message:
      ***** FILE SYSTEM WAS MODIFIED *****
      Important: If this message appears, repeat the fsck command you typed in step 2 until fsck tells you that your volume appears to be OK (first-pass repairs may uncover additional issues, so this is a normal thing to do).
    4. When fsck reports that your volume is OK, typerebootat the prompt and then press Return.

    Your computer should start up normally and allow you to log in.

     

    Resetting PRAM and NVRAM

    1. Shut down the computer.
    2. Locate the following keys on the keyboard: Command, Option, P, and R. You will need to hold these keys down simultaneously in step 4.
    3. Turn on the computer.
    4. Press and hold the Command-Option-P-R keys. You must press this key combination before the gray screen appears.
    5. Hold the keys down until the computer restarts and you hear the startup sound for the second time.
    6. Release the keys.

    Your computer's PRAM and the NVRAM are reset to the default values. The clock settings may be reset to a default date on some models.

  • Duiesel Calculating status...

    I found the FIX!

     

    1) Shutdown your Mac

    2) Turn on in single-user mode (Press Command+S while power on)

    3) Type fsck -fy

    4) If it's printed "FILE SYSTEM WAS MODIFIED" type fsck -fy another time

              Do it while it will not print "FILE SYSTEM WAS MODIFIED"

    5) type mount -uw /

    6) type launchctl load /System/Library/LaunchDaemons/com.apple.kextd.plist

    7) type launchctl load /System/Library/LaunchDaemons/com.apple.notifyd.plist

         if in 6 or/and 7 You have any errors type:

         launchctl load -wF /System/Library/LaunchDaemons/com.apple.kextd.plist

    8) type launchctl load -wF /System/Library/LaunchDaemons/com.apple.configd.plist

    9) type exit wait and type it second time

     

    After that Your system will boot up succesfully!

  • ze_m0nk3y@73 Calculating status...

    I think i have the same problem. When i turned on my 2008 intel imac running mac os 10.7.5 this afternoon, it booted to the login screen then almost as soon as i went to select a user, the system hung up. Restarting the system again i get the apple logo and then an immediate hang up. It now does this every time!

     

    I've used the hard disk utility to check my hdisk and it comes back error free / ok!

     

    I can boot info safe mode without any problems, and from the snow leopard dvd.

     

    The last time i successfully logged in i updated the following... (Found in /var/log/install.log)

    Airport Utility

    Iphoto9.4.2update

    Iphoto9.4.2ContentUpdate

    Safari6.0.2Lion

     

    Has anyone else also with this issue, updated these recently?

     

    I also tried the above suggestions and they didnt work for me! Can anyone please help???

  • Duiesel Level 1 Level 1 (0 points)

    Can you boot in the single user mode?(tap cmd+S when power on)

  • noepa Calculating status...

    I have the same problem and I am trying your method. But in the waiting times from one check of the system to the other I cannot help thinking, this may be the answer but, What did just happen? Why do I have this problem?

     

    Do you have any clue on the origin of the problem?

     

    Thanks for the help.

  • Duiesel Level 1 Level 1 (0 points)

    Hi.

     

    Ok, I know at least four reasons that can be the origin of this problem.

     

    1) Hardware problem with HDD: old HDD start working with problems,bad sectors and other;

    2) Software problem when doing update:while installing update something going wrong;

    3) Software problem when you stop/off some services by yourself that cann't be stopped; using programs that can clean and boosts your system booting and working;

    4) Any combinations of the above.

     

    Good Luck.

     

    Best Reguards, Alan.

     

    <Edited By Host>

  • noepa Level 1 Level 1 (0 points)

    Hi:

     

    i was going through your steps and after 6,7 I tried with the option -wF and the answer was

    launch -msg():Socket is not connected

    Launchctl: CFURLWriteDataAndPropertiesforResources(/var/db/Launchd.db/com.apple.launchd/ov errrides.plist) failed: error -10

     

    I could not go on, and still does not restart. Any idea?

     

    Thanks

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.