Skip navigation

Airport Express (square) skips unbearably with Airplay

49530 Views 147 Replies Latest reply: Apr 17, 2014 3:01 AM by metamedia RSS
  • eccom Calculating status...

    I'm having these same issues using optical out from both my airport expresses. One N-compatible wall-wart and the new square one. Both skips when playing from my iphone using the native ios music player, or apps like spotify. From my computer only Itunes works fine, Airfoil skips just like the phone. Analog from both units works flawlessly, the issue is not network drop outs.

     

    What bugs me the most is that the Iphone music player is broken, and I basically can't use the chain I want:

    Iphone (spotify)>AX>Dacmagic Dac>Amplifier

     

    It seems to work fine using my old Denon 1804 receiver on digital in, probably because it hase no jitter rejection at all. Using passthrough from the reciever then show the same issue when connecting the better dac, the jitter is just passed through.

  • Payam Minoofar Level 1 Level 1 (70 points)
    Currently Being Moderated
    May 18, 2013 9:08 AM (in response to eccom)

    Firmware 7.6.3 dramatically improves music playback via toslink. Just heed my solutions having to do with the 5GHz network on this thread: https://discussions.apple.com/message/21842014#21842014

  • MacHinery Calculating status...

    I've been frustrated by these dropouts on AirPlay for as long as I've has an AirPort Express and I've spent quite a lot of time characterizing this problem in the vain hope that Apple will finally find enough information to tackle this issue.

     

    First, the network setup:

    * Apple MacBook Pro running Snow Leopard & iTunes of various versions as released over the years (11.0.3 right now)

    * Wireshark to observe network traffic

    * Verizon FIOS with Actiontec router

    * Apple Airport Express cabled to Actiontec router using Cat6 cable

                   - Cabled Airport Express audio output cabled to my stereo Aux input

                   - Cabled Airport Express configured to "Create a wireless network" dedicated to Airplay

            - Configured to use WPA2

    * Second Airport Express wirelessly connected

                   - Second Airport Express audio output cabled to a self-powered speaker

                   - Second Airport Express configured to "Join a wireless network;" the same network created by the 1st Airport Express

     

    I've tried every trick described that I can find on the Internet including:

    * Disabling IPv6 everywhere

    * Installing various Airport Express firmware versions: 7.6.3, 7.6.1

    * Assigning static IP addresses to both Airport Expresses

    * Leaving iTunes on the MacBook Pro configured to use its internal speaker

    * Leaving Airport Utility running continuously

    * Assigning Airport Express to use a WiFi channel unused by any neighbors

    * No kitchen appliances running

    * All network participants within 30' line of sight

     

    Here's what I observe when all works properly using Activity Monitor and Wireshark:

    * iTunes is the top CPU user at ~20%

    * Kernel task PID 0 is second at about 5%

    * ~256 packets per second transmitted by MacBook; ~128/s for each Airport Express

    * Each transmitted packet is ~700-1000 bytes (I assume this is real time music)

                   - To each Airport Express, UDP port 6000

                   - From my MacBook Pro, UDP high port

    * ~3-5 packs per second received by MacBook

                   - One packet per second from each Airport Express. The rest appear to be DNS queries & responses

                                   - Each packet is 62 bytes in length; 20 byte payload

                                  - To my MacBook Pro, UDP port 6001

                                  - From each Airport Express, UDP port 6001

                                  - No reply from MacBook

                   - One other packet per second from each Airport Express

                                  - Each packet is 74 bytes in length; 32 byte payload

                                  - To my MacBook Pro, UDP port 6002

                                  - From Each Airport Express, UDP port 6002

                                  - Each gets a single reply of same length & protocols from Macbook

     

    Here's what happens during a dropout:

    * Kernel task PID 0 is top CPU user at ~25% (does this process service the IP stack?)

    * iTunes drops to ~5% CPU

    * Network traffic sent by MacBook spikes to ~800 packets per second; traffic received spikes to ~600 packets per second

    * Each packet (sent and received) is 50 bytes in length; 8-byte payload

                   - To MacBook, UDP port 6001; from each AirPort Express, UDP port 6001

                   - Macbook appears to respond to every UDP packet received

                             - same source and destination port numbers (6001)

                             - same packet size, same payload size (50 bytes with 8-byte payload)

     

    I have no idea how to decode the protocol in the payload. I'd love any information there.

     

    Can anyone at Apple explain these periodic packet storms that cause a roughly 1-second dropout at irregular intervals? I can supply wireshark packet captures with payload data. Please help. There are clearly hundreds of dissatisfied customers out here.

  • ZeusFaber Level 1 Level 1 (0 points)

    Went with the philips airplay speaker. Works much better than any of the apple products, sad to say...

  • cbreed28 Calculating status...

    I had the same skipping issue when attempting to stream to my airport express that I just bought today. Fixed it by turning off my 5GHz band on my router and using only 2.4GHz. Firmware 7.6.3 must needs some serious work in the 5GHz area...

  • Bryan Navarro Level 1 Level 1 (0 points)

    All,

     

    Just wanted to give everyone an update as to my journey in hopes to help.  I'll put down the cliffs notes:

     

    1. Same issue streaming via Airplay from Airport Express (current generation) connected to Bowers & Wilkins Zeppelin via optical cable.  Airport Express connects to Time Capsule with 'Join a Network' setting, Does not act as a relay or wireless access point.
      1. Analog audio streams just fine
      2. Optical produces skips every 10 seconds or so
    2. Have been back and forth with Apple Engineering on the issue.  They captured my network logs, etc to ensure it was NOT due to the network environment - it isn't.  Its the optical hardware/firmware
    3. There is NO technical resolution as of this writing.  The suggestion from engineering has been to either:
      1. Wait for a firmware fix (no time estimate, if ever if it is even possible)
      2. Use an Apple TV (we knew this)
    4. Here's the real rub, people like me who aren't able to return the Airport Express to the retailer of origin (mine was a gift) are gonna have an uphill battle to get Apple to replace the Express with an Apple TV.  I am currently working with Customer Relations to figure out a resolution.  The seemingly simple task of swapping a $99 item for another $99 item is a logistical nightmare.  I'll update this thread once I have hammered out the resolution.
  • PaulWBrandt Level 1 Level 1 (0 points)

    Hi Bryan

     

    Fyi - I have had no success using an older and latest ATV connected via it's optical out to my Marantz SA8004 CD player, acting as a DAC. I have had endless jitter with horrible noise through my speakers. I tried every recommended solution from forums and even enlistedvhelp from an Apple store, with no solution.

    From the endless amount of research that I have done, it appears to be related to the type of DAC - the Marantz has the Cirrus and it doesn't work. Even the highly rated ESS Sabre in the Audiolab CD player had issues.

    Just a heads up - hope you have better success with the ATV.

    I have resorted to connecting my PC via USB to the Marantz as DAC and control playback through iPAD and this works fine.....and of course, I still just get up and change out my single CDs old style to get good sound.

    I couldn't return my older ATV, but use it mainly as a streamer for Netflix - works superbly. I was able to return the latest ATV, though and reported my issue in detail to Apple online.

     

    Best wishes.

    Paul

  • thewetdog Calculating status...

    Hi All,

     

    I've had the same stuttering issue as many here, in two separate systems, with my new Airport Express. I saw this thread a few days ago, but have not taken the time to go through it again. Quickly, what I did this morning seems to have solved the problem in my case, so I'll put it here to make sure you are aware of this. If it is redundant I'm sorry. I went to the Airport utility, clicked on the Airport Express in question, and clicked "edit". In edit, I followed the instructions to enable "Back to my Mac", and so far that seems to have solved the problem on my second choice for it's location. I bought it to use through an optical connection to a dac and on to my home stereo, but have not yet verified it's solving of that problem...  Dave

  • AsafChar Calculating status...

    Hello,

    Does anyone know if the skipping  problem on the new airport express' digital out has been solved?
    I plan on buying an Airport Express and connecting it to a Cambridge Audio DAC Magic (and from there to my amp), does it work well or are there still problems with the current firmware?

     

    Thank You!

  • Payam Minoofar Level 1 Level 1 (70 points)

    Performance has gotten better for me, but hopefully others will chime in. Losing connections as outlined and fixed in this thread may be a bigger problem

    https://discussions.apple.com/message/21842014#21842014

  • thewetdog Level 1 Level 1 (0 points)

    Even with the recent firmware update my Airport Express skips horribly, both fed through a dac and into my home stereo (which is what I purchased it for) and fed directly to an amp which feeds a pair of speakers on my patio - which I thought worked ok but has since fallen back into skipping badly. Sadly disappointed and surprised at Apple's choice to ignore this situation. I've downloaded most of my Itunes library in Apple lossless to a 160gb ipod classic and play it through a Pure I-20 to my preamp in my home stereo now. Wish I never bought the Airport Express. What good is it if it doesn't work?

  • AsafChar Level 1 Level 1 (0 points)

    Thank you for your replies. Does anyone have any experience with the Apple TV? Does it work better when playing through digital output to a DAC?

  • eccom Level 1 Level 1 (0 points)

    Yes, the Apple TV works well. it does however resample all audio to 48 khz (default tv), whereas most music is 44.1 khz.

     

    The express has a few different problems:

    Skipping due to network/buffering etc. This will appear without an external dac, and if your newtwork connection is poor the apple v might have issues as well.

     

    optical digital out reclocking - due to the multi-zone capabilities and how the clock is remote controlled the clock jumps. This causes many quality dacs to lose the signal lock. My crappy reciever dac has no issue, my cambridge dacmagic is losing lock all the time.

  • Bryan Navarro Level 1 Level 1 (0 points)

    Long story short: I've worked directly with Apple engineering and they are aware of the issue. I received no timeframe for a firmware fix - if it exists. I was encouraged to not wait for it and exchange my AE for an Apple TV.

     

    Now I am at least able to use Airplay with zero issues hooked to my B&W Zeppelin. There is a considerable upgrade in audio quality using the B&W DACs instead of the iOS products'.

     

    I personally don't think there will be a firmware fix. I think it's a hardware issue inherent to that product that won't be rectified until they do a refresh (possibly just a SKU refresh with the offending part changed out).

  • PaulWBrandt Level 1 Level 1 (0 points)

    Hi Asfar

     

    This is Paul Brandt - please see me response above on 9Jul on my experience with an older and latest versions of ATV using the optical out. It definitely works when paired with an my Onkyo TX SR 875 AV receiver (Burr-Brown DACs) via both HDMI and optical in my HT setting. But when trying to use it with a more upmarket Cirrus DAC like in my Marantz SACD 8004 in a stereo setting, it creates terrible static. Even Audiolab 8200 with it's fantastic Sabre DAC has issues. Apparently Peachtree Audio has been able to set up a successful system - check their website. Good luck - I have given up with the ATV optical out and use of Airplay and have resorted to connecting my PC to my DAC via USB and controlling iTunes remotely from the iPad.

    Paul

1 ... 5 6 7 8 9 10 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (7)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.