Skip navigation

External Hard Drive Not Showing Up

119227 Views 37 Replies Latest reply: Mar 28, 2014 11:04 PM by fitzlefrog RSS
  • DrTeak Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 15, 2012 6:36 PM (in response to mustngpny50)

    i was going through the same problems. went through the above steps and got my Hard Drive to amazingly showed up, then miraculously vanished again yet showed up in disk utilities...


    i think what is going on is that my hard drive has a sort of sleep function cause when my computer went to sleep then woke back up my hard drive mounted and is running fine... so maybe we just need the computer to go to sleep with the hd plugged in?



    will keep u updated if i go back to invisible state.

  • lestein Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 24, 2012 7:46 AM (in response to mustngpny50)

    My external HD iomega wasn't showing up either.

    In the end, it showed up when I connected the 2 usb for the HD to the iMac USB ports, insted of going through my Kensington USB hub ..

  • melissaamelia Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 27, 2012 10:02 PM (in response to mustngpny50)

    I have the same problem too! the day before yesterday it would read it on my MAC, then i added some files onto the HD on my PC at work, now it doesnt show up.. I have a program installed on my MAC so it can read a Windows formatted HD. There is nothing wrong with the hard drive as when i plug it into my WD Live Media player it works & reads files perfectly. It just wont show up on the desktop to open HD and access files.

    Does anyone know how to fix this?


  • melissaamelia Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 28, 2012 1:58 AM (in response to mustngpny50)

    So i have fixed mine, try this too.. it didnt do anything to my data but always back up

    go to Disc Utlity and click on the hard drive on the left, on the right there is an option to Verify Disc, run this and then mine said it had a minor error, so i ran the Repair Disc and once it ran it fixed it and all good now.

    hope this works for you

  • Sam Haron Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 29, 2012 3:00 AM (in response to mustngpny50)

    I had the same problem. Plug in an external hard drive, any hard drive, even a USB stick, it shows in finder's side bar, but not on desktop. Solved.


    Sounds like a huge problem? I'm just wondering if the answer you are looking for is on this link



    Its just setting in FInder's Preference. "Show these items on desktop". Voila!


    Not sure if this is the problems you guys are facing. Hope this helps.

  • Simon V. Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 18, 2012 7:24 AM (in response to mustngpny50)



    I have a problem with my external harddisk, when I plug it in my mac book pro version 10.6.8 I can't find it. When I look in my disk utilities he finds him but can't activate it anymore. I tried typing ls -laeO@ /Volumes in the terminal and then this comes out:

    ls -laeO@ /VolumesLast login: Wed Apr 18 16:10:09 on ttys000

    MacBook-Pro-van-Simon-Pierre-Verstraete:~ SimonVerstraete$ ls -laeO@ /Volumes

    total 8

    drwxrwxrwt@  3 root             admin  hidden  102 18 apr 16:00 .


    0: group:everyone deny add_file,add_subdirectory,directory_inherit,only_inherit

    drwxrwxr-x  33 SimonVerstraete  staff  -      1190  7 apr 08:54 ..

    lrwxr-xr-x   1 root             admin  -         1 13 apr 12:16 Macintosh HD -> /

    MacBook-Pro-van-Simon-Pierre-Verstraete:~ SimonVerstraete$


    Can somebody help me?

  • SanCarlosDad Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 23, 2012 6:43 PM (in response to Simon V.)

    The above thread put me on the right path, and I hope my experience helps others.


    Problem: iMac suddently stopped showing two 2TB iomega hard drives that store our videos, photos, etc. (reformatting was not an option...)  I tried different USB ports, firewire, restarting, connecting to my MacBook, etc. and message always said drives cannot be read by either iMac or MacBook.  It seemed too coindicental for 2 drives to have failed at once...



    1) Based on above thread, I went to System Profile in my MacBook with one drive connected via USB.  The drive was seen there.

    2) Next, I went to Disk Utility, where the drive was seen.  Icon showd up as "2TB External..." and underneath and indented there was a gray name that was NOT the name I had given the drive.

    3) I hit "Verified Disk" -- and it said "Invalid Index Key. ...(drive name I HAD given drive)...found corrupt and needs to be repaired.  Error... Click Repair Disk."
    4) I clicked "Repair Disk" a first time. It failed with message "Disk Utility Stopped Repairing..." -- not sure why.

    5) I tried "Repari Disk" again, and this time it took longer, gave many more lines in the window as it did it's job, had messages in green instead of red, and the file was repaired!

    6) Disconnected drive, turned off MacBook and drive, rebooted MacBook, connected drive via USB, turned on drive -- and there it was on the desktop with its correct assigned name!


    I hope this helps.

  • Omniasoft Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 1, 2013 4:23 PM (in response to mustngpny50)

    For me the problem was much more simple than any of this... the 4-port USB hub I was using suddenly went bad.  If you're plugging your external HD into a USB hub you may want to ensure that other things can connect to the hub okay before thinking something happened to your HD.

  • ZamirasDAD Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 16, 2013 5:37 PM (in response to jsd2)

    hey dude...... i need your help...... if i copy my terminate log to you can you tell me what i need to do to have my Mercury harddrive up.

    i updated because my Java was messing up and after restart my mercury never showed bak up

  • ZamirasDAD Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 16, 2013 8:20 PM (in response to jsd2)

    if i send you my terminal log can you tell having the same problem of ext harddrv hidden or not showing up..

  • ZamirasDAD Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 7, 2013 1:17 PM (in response to jsd2)

    robert-collinss-imac-2:~ robert$ ls -laeO@ /Volumes

    total 8

    drwxrwxrwt@  3 root  admin  hidden  102 May  7 07:26 .      32

    0: group:everyone deny add_file,add_subdirectory,directory_inherit,only_inherit

    drwxrwxr-x  44 root  wheel  -      1564 May  7 07:43 ..

    lrwxr-xr-x   1 root  admin  -         1 May  7 07:26 Mac OS -> /

    robert-collinss-imac-2:~ robert$

    @@@Cn you check this out for me too

  • mako78gma1 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 31, 2013 11:29 AM (in response to ZamirasDAD)

    I followed the various tips and tricks and ran into the same roadblocks found by all of the above.  The solution I discovered falls under this makes no sense but it worked:  With the Disk Uility open, and displaying the USB external drive with options faded/grayed out and unmountable, I connected another external USB drive to another USB port just to see if this drive not only displayed in the Disk Utility and on the desktop and the Finder window list, but also the non-recognized drive also displayed on the desktop and Finder window list though no change in the Disk Utility accessibility...I then did a proper eject from the finder window list (just in case it might disappear) of the now displayed drive (before it did not display).  Restarted the computer, connected the drive and now all works.  Go figure.

  • anarKaliG Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 29, 2013 10:50 PM (in response to mustngpny50)

    Do this:

    FRom the Finder Menu:

    click "Go to Folder"

    then type the path from what appears under Disk Utilty e.g.



    Then magically in Finder, you will be in the root folder of this invisible drive! (this worked for me)

  • natassa22 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 26, 2013 4:52 PM (in response to mustngpny50)

    The same happened to me.

    For me worked this:

    - go to disk utility - there you will see your disk

    - click on it - click on repair disk - wait

    - the you will be able to see your disk on the left panel of the finder

  • machusker Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 7, 2013 5:22 AM (in response to mustngpny50)

    My Iomega HD won't mount on either of my macs,  I ran disk verify and disk repair and get the following message. Any help would be greatly appreciated.  I can't reformat(erase) disk.  I need to recover the files.



    Screen shot 2013-11-07 at 8.15.00 AM.png


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.