Skip navigation

DVD Studio Pro no longer works with the new iMac. Solutions?

2114 Views 16 Replies Latest reply: Jul 8, 2013 6:26 PM by BradParsons RSS
1 2 Previous Next
On-Site Video Calculating status...
Currently Being Moderated
May 30, 2013 3:47 PM

Disc installations in general don't exist anymore and DVD Studio Pro is no longer supported in the new iMac that we have at our office. I used to have Roxio's Toast Titanium as a backup burner, but even that is not supported past mac OS 10.7. Final Cut X has the option to export straight to DVD but the menu options it gives you is so basic it doesn't even look professional. I was just wondering if anyone else has had this problem and what they are using now to burn a professional looking DVD. Many thanks

Final Cut Pro X, OS X Mountain Lion (10.8.3)
  • Ian R. Brown Level 6 Level 6 (17,505 points)

    It is possible to use FCS3.

     

    You can connect an external DVD burner or attach another Mac with a Superdrive so you can use the installation DVDs.

     

    Ideally you should make .dmgs of the DVDs as they are easier to use and much quicker for subsequent installations.

  • Nick Holmes Level 7 Level 7 (29,805 points)

    ??

     

    I have used both DVD SP & Toast Titanium on my Mac running 10.8.x to burn discs. It works fine. Made 5 yesterday.

     

    Or do you mean it doesn't work because the iMac no longer has a DVD burner buit in? Get an external burner like Ian says, they don't cost much.

  • mlaughbaum Calculating status...

    I find myself in a similar situation. When I try to install FCP 6 I get an error message saying "You can't open the application "FinalCutStudio.mpkg because PowerPC applications are no longer supported".

     

    I'm truly at a loss as to what to do. I just bought a new imac installed FCP X and really need both the compressor and DVDSP from my FCP disks.

     

    We shoot children's theater so I author DVDs all the time. I'm really unsure how to proceed as DVDSP was my got to ap and there doesn't seem to be a comparable replacement.

     

    PLEASE HELP!

  • darbypsnm Level 3 Level 3 (720 points)

    Presuming you have the install disks try this:

     

    https://discussions.apple.com/thread/4952865?start=0&tstart=0

     

    Make sure you have a time machine BU just in case.

  • Meg The Dog Level 6 Level 6 (9,395 points)

    If you are not confident about using one of the workaround for the installation problem of installing FCS2 applications on Mountain Lion, look on eBay for a copy of FCS3. This will install directly.

     

    Or investigate Adobe Encore, which is the Adobe Optical Disk Authoring product.

     

    Or download Roxio Toast. which will allows you to burn optical disks, but does not have as flexible menu creation system.

     

     

    MtD

  • David M Brewer Level 6 Level 6 (9,185 points)

    To add... If you have Compressor 3 or 4, Compressor can author/burn a DVD. Simple menus... you can add chapter marks... and you can make a disc image where you can use Disc Utility to make multiple copies. You can also burn Blu-ray discs. I think you need Compressor 3.5 and above to burn Blu-ray discs.

     

    (Better to make a disc image instead of burning directly to DVD from Compressor. If Compressor craps out burning a burn (a bad blank DVD) you will have to start all over, encoding too.)

  • mlaughbaum Level 1 Level 1 (0 points)

    On-Site Video wrote:

     

    mlaughbaum,

     

    It seems as though you and I are on the same page struggling. Were you able to find any alternatives to DVDSP or any way to continue using it?

    On-Site Video

     

    I'm considering myself lucky... Though I was unable to install either DVDSP and FCP v.6 on my new iMac, they are both still working on my older iMac even though it too is running ML. I believe this is because I upgraded to ML from Leopard with both already installed.

     

    My only suggestion would be to install Leopard (or the OS on which they were working for you), install FCP, DVDSP and compressor, and then upgrade to ML. Seems like a silly solution but I have a feeling it would work. I'm not doing it because it's working on the iMac that's closest to my DVD duplicator. That said, if I had to, I believe that's what I'd try.

     

    Really infuriates me. My business depends on DVD sales and there really isn't another cost effective DVD authoring solution for the mac out there.

     

    I do wish you the best of luck and would love to hear if you come up with a better solution.

     


  • David M Brewer Level 6 Level 6 (9,185 points)

    You can't install Leopard, Snow Leopard or Lion on the new iMacs. You can only (re)install Mountain Lion on the new iMacs.

  • mlaughbaum Level 1 Level 1 (0 points)

    Appreciated the suggestion as well, but this scared me a bit too... The iMac should really have an approved ap that makes older programs compatible. Argh!

  • mlaughbaum Level 1 Level 1 (0 points)

    David M Brewer wrote:

     

    You can't install Leopard, Snow Leopard or Lion on the new iMacs. You can only (re)install Mountain Lion on the new iMacs.

    Really! Wow... That's a bummer! They really should provide a compatibilty ap or somethng then. Especially for important programs they discontinue and don't provide a replacement for. Issues like this make me want to jump ship and join the PC world... almost.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.