Skip navigation

iTunes 11 airplay stops in middle of songs, why?

28726 Views 84 Replies Latest reply: Dec 31, 2013 9:25 AM by teppdude2 RSS
  • poäng Calculating status...
    Currently Being Moderated
    Jun 2, 2013 5:26 AM (in response to ChazH)

    Same issues here. iTunes keeps playing, but airplay just stops working, usually when  song is over and next begins. Tried all those tips, but none of them solved the problem. Windows 8, iTunes 11.03, Synology Diskstation DS211j, DSM 4.2. iTunes 10 really worked well for me. Seems aplle does'nt take this issue seriously. What a pitty :-(

  • Scotty_Evil Calculating status...
    Currently Being Moderated
    Jul 12, 2013 1:37 PM (in response to ChazH)

    audio stops on all outputs after each song. Streaming via airplay multiple to Apple TV and iHome speaker from Macbook Pro iTunes. Really annoying. Pressing pause and then play picks the audio back up.

  • nergenek Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 13, 2013 11:25 AM (in response to ChazH)

    I had the same problem this afternoon...

     

    Mac OSX 10.6.8 + iTunes 11.0.4 + two Airport Express 7.6.3...it never happened before...suddently the music stopped...searched on the forums, tested and tried nearly everything...iTunes was OK on its alone on iMac...Airplay from iPhone, iPod, iPad to the AE's was OK...except from iTunes to the AE's the music was stopping after some seconds and what was strange is that my DAC on which the AE is connected showing "connected via Airplay" but no signal...

     

    So in a hopeless moment I thought that this may have to do with the output buffer or similar memory used by iMac (and/or iTunes) for the streaming, which needs to be "cleaned" after longtime usage (months in my case)...

     

    Applying the "Maintenance" app ( http://maintenance.en.softonic.com/mac ) to the system solved entirely the problem...

     

    I am again an happy music listener since many hours without any interruption...

     

    Hope that this helps...

  • ssooii Calculating status...
    Currently Being Moderated
    Aug 17, 2013 1:48 PM (in response to ChazH)

    I am having the same issue. It drives me crazy. It stops playing randomly especially while playing the songs imported after the version 11. I updated the recent version hoping it gets better to no avail.

  • nergenek Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 17, 2013 3:03 PM (in response to ssooii)

    Did you try my solution ?

  • jgmayer Calculating status...
    Currently Being Moderated
    Aug 18, 2013 8:11 AM (in response to ssooii)

    Hi,

    I have the same problem, it happens very often.

    HOwever I found one thing that afeects my airport. MICROWAVE.

    Knowing that does NOT solve all the airplay problems.

    But Every time I use microwave it stops working... Wondering why.. eheheh

    I have seen this in my house and in other houses....

     

    Now... I have discover that place is important.

    The Airport should be placed in a high place in the house.

    I found out that after I change the place of my Airport it works better.

     

    I use ti hve down on the cabiet... That is no longer working...

    After the change it is performing much better...

     

    I dont understan why it would just work before and now it doesn't

    Even in lower place, with or without microwave and everything...

     

    I hope this can help some... I have been hasseling with this for while now...

  • dutchmike1966 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Sep 20, 2013 11:23 AM (in response to ChazH)

    Hi all,

    Did you update your iPhone to IOS7? Now it's not compatible anymore with iTunes 10.x !! So here we go, we're forced to go for version 11.

     

    Good luck all !

  • Klaus Boehncke Calculating status...
    Currently Being Moderated
    Sep 28, 2013 8:26 PM (in response to ChazH)

    Hello, I will also post a seperate thread as in my cases it affects two iphones and an ipad. Same issue: Airplay randomly stops all of a sudden. This interrupts eg itunes radio streaming or any other audio that's playing. Gen 1 iPad running iOS 4 works without problems, so it's clearly not a base station issue but some code that appears to be similar in iTunes 11 and iOS 7. Hope it gets fixed in the next update.

  • Macky63 Calculating status...
    Currently Being Moderated
    Dec 24, 2013 6:09 AM (in response to ChazH)

    I'm not sure how to fix this on a Mac but after experiencing the same problem I created 4 new sets of rules for itunes in windows firewall, both for incoming and outgoing connections to open up TCP ports 80, 443, 554, 3689, 5297, 5298 and UDP ports 554, 5289, 5353, 49159, 49163.

    After that Airplay worked like a charm again. When you install a new version of itunes or update an old one you most likely will have to do the same all over again.

  • teppdude2 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 31, 2013 9:25 AM (in response to ChazH)

    Happy New Year,

     

    Have you checked your power saving settings? Dont let your comp to go sleep!

     

    Cheerio!

1 2 3 4 5 6 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.