Skip navigation

Occasional Unsupported Image Format during import, why?

429 Views 4 Replies Latest reply: Jun 3, 2013 6:26 AM by Kirby Krieger RSS
aapl.crox Level 1 Level 1 (0 points)
Currently Being Moderated
May 25, 2013 5:38 PM

Once in a while when importing from my camera (Sony A99) RAW format, I get the Unsupported Image Format on a few pics of the batch. It's random so I'm not sure when it would happen. The only way I find that will fix those images is launch aperture into repair "repair database". It's not a deal breaker as I don't lose any files but it's bit annoying and not sure why this is the case. Any ideas how to permanatly stop this?

  • William Lloyd Level 6 Level 6 (19,220 points)

    Have you tried simply restarting Aperture to see if it fixes the issue?

     

    If that doesn't, you can probably select the image and select "reprocess master."  Usually a full database repair shouldn't be necessary.  As to why it happens, I don't know.  I've seen this as well, but like twice ever and I've been using Aperture since it was released in 2005.

  • léonie Level 8 Level 8 (46,560 points)

    Where do I go to reprocess master? Couldn't find it anywhere.

    In Aperture 3 this option is in the "Photos" menu:

    Aperture's main menu bar > Photos > Reprocess Original

     

    Does this always happen with the same card? When have you last reformatted the card? Perhaps the filesystem on the card needs repairing or you should try a different card.

     

    Léonie

  • Kirby Krieger Level 6 Level 6 (11,570 points)

    I see this regularly ( one or two files, every other time I import?) with the built-in SDHC card reader on my rMBP.  What I do is simply note which files are corrupt, immediately re-import those files, and then delete the corrupt ones (sorted by date, they are side-by-side with their non-corrupt twin).  Iirc, only once have I had to re-re-import a file that failed to import properly on the first try.

     

    I reformat (in camera) each card every time I fill it (and recommend this practice), but IME (casually observed and not tested) the problem originates with the built-in card reader, and not with the card.  How are you importing?

     

    Perhaps only a coincidence, but I use Sony cameras.  I don't recall this ever happening with a CF card though.  (The rMBP does not have a CF reader.) 

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.